Kodi freezing on PVR startup

I have a problem that started after the RaspBMC->OSMC/Kodi transition. While Kodi is getting started, a “PVR manager is starting up” alert box appears on the screen stating: “No PVR clients have been started yet. Wait for the PVR clients to start up…” The alert box has a cancel button. If I immediately click on the cancel button, the box disappears and Kodi loads the PVR information and finishes starting up normally. If I don’t click the cancel button soon enough, Kodi usually (but not always) freezes up and never competes the startup process.

I have two Raspberry Pi’s, and one Raspberry Pi 2, all running the most recent versions of OSMC and pvr.wmc. This problem occurs on all three of them. I also have Kodi – along with pvr.wmc – running on my iMac. Kodi starts up on the iMac without displaying the alert box, and without ever locking up. This suggests that the problem resides in OSMC, not in Kodi, nor in pvr.wmc.

The logs are here. [The kodi.old.log contains the information from a time when the “PCR manager is starting up” dialog’s cancel button was not clicked, and therefore Kodi locked up. All of the other log files are from the next time, when the cancel button was clicked so startup was allowed to finish.]

I’m sure you’ve moved on from this, but I ran into this exact issue this weekend and wanted to share what fixed it for me. I had been loading some new add-ons and tweaking settings.

Turns out I changed the default screen to ‘TV’ from the Main. Turning it back solved the issue. Maybe there is some race condition?

Thanks for taking the time to share your solution! That’s the only thing I’ve been able to do to avoid the problem. This bug seems to be peculiar to OSMC, since it doesn’t occur when I am running Kodi under Mac OS X. It would be nice to get it fixed!

are you using some pvr client for viewing live tv? when no, then you can disable it.

Hello, I have the same problem
Thank you

Having the same issue. Kodi freezes if I quite often when I try to load streams either through PVR or video plugins. SSH keeps working though and I am able to bring the system back by running “sudo systemctl restart mediacenter”. This are the logs for two cases that my system Froze:


You have several repositories/addons installed that are know to cause problems and that due to the piracy context can not be supported in this forum

Can you point me to a list that mentions the problematic repositories/addons? Happy to remove them and retry.

Well no specific OSMC list exists but reading FAQ - OSMC Forums and checking the Kodi banned Addons http://kodi.wiki/view/Official:Forum_rules/Banned_add-ons should give an idea.

Having the same on RPi, Kodi 16.1-RC2 Git:4cf382f, OpenELEC Beta Releases (7.0 beta 2)

OSMC does not provide openelec support my friend… They have their own forum.

Yes, but it seems Kodi problem and unrelated from distro