Kodi is not able to play .ts file anymore

hello,

I just installed latest osmc for rpi3 using disk image, enabled the PVR client and trying to play a streaming, but I got this error:

20:30:27.243 T:1926334976 NOTICE: VideoPlayer: Opening: pvr://channels/tv/All channels/pvr.iptvsimple_1975719580.pvr
20:30:27.243 T:1926334976 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
20:30:27.244 T:1387733760 NOTICE: Creating InputStream
20:30:27.637 T:1387733760 NOTICE: Creating Demuxer
20:30:27.641 T:1387733760 ERROR: Open - error probing input format, http://x.x.x.x/1234/video.ts
20:30:27.671 T:1387733760 ERROR: Previous line repeats 9 times.
20:30:27.671 T:1387733760 ERROR: OpenDemuxStream - Error creating demuxer
20:30:27.671 T:1387733760 NOTICE: CVideoPlayer::OnExit()
20:30:27.707 T:1926334976 NOTICE: CVideoPlayer::CloseFile()
20:30:27.707 T:1926334976 NOTICE: VideoPlayer: waiting for threads to exit
20:30:27.708 T:1926334976 NOTICE: VideoPlayer: finished waiting
20:30:27.708 T:1926334976 NOTICE: CVideoPlayer::CloseFile()
20:30:27.708 T:1926334976 NOTICE: VideoPlayer: waiting for threads to exit
20:30:27.709 T:1926334976 NOTICE: VideoPlayer: finished waiting

There’s not enough log there to be very helpful, but one thing you might check is to see if you are using MMAL or OMXPlayer as the Kodi player. OMXPLAYER does not handle streams well (which is what the PVR client is), and on my setup I just get a blank screen if I enable OMX hardware acceleration in the Kodi player settings. If I enable MMAL hardware acceleration and disable the OMX hardware stuff, everything works fine.

hello,

it is already using mmal with hw acceleration. What kind of information do you need to know more?

Debug logs would be useful.

00:14:23.795 T:1925812992 DEBUG: Previous line repeats 11 times.
00:14:23.795 T:1925812992 DEBUG: CAnnouncementManager - Announcement: OnScreensaverDeactivated from xbmc
00:14:23.795 T:1925812992 DEBUG: GOT ANNOUNCEMENT, type: 4, from xbmc, message OnScreensaverDeactivated
00:14:23.809 T:1925827072 DEBUG: Loading settings for pvr://channels/tv/All channels/pvr.iptvsimple_2039024006.pvr
00:14:23.812 T:1886384896 INFO: CActiveAESink::OpenSink - initialize sink
00:14:23.812 T:1886384896 DEBUG: CActiveAESink::OpenSink - trying to open device PI:HDMI
00:14:23.812 T:1886384896 DEBUG: CAESinkPi:Initialize Format:2 Channels:2 Samplerate:16000 framesize:4 bufsize:3200 bytes/s=64000.00 dest=PI:HDMI
00:14:23.813 T:1886384896 DEBUG: CActiveAESink::OpenSink - SinkPi Initialized:
00:14:23.813 T:1886384896 DEBUG: Output Device : HDMI
00:14:23.813 T:1886384896 DEBUG: Sample Rate : 16000
00:14:23.813 T:1886384896 DEBUG: Sample Format : AE_FMT_S16NE
00:14:23.814 T:1886384896 DEBUG: Channel Count : 2
00:14:23.814 T:1886384896 DEBUG: Channel Layout: RAW,RAW
00:14:23.815 T:1886384896 DEBUG: Frames : 800
00:14:23.815 T:1886384896 DEBUG: Frame Size : 4
00:14:23.819 T:1925827072 DEBUG: Radio UECP (RDS) Processor - new CDVDRadioRDSData
00:14:23.820 T:1925827072 NOTICE: VideoPlayer: Opening: pvr://channels/tv/All channels/pvr.iptvsimple_2039024006.pvr
00:14:23.820 T:1925827072 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
00:14:23.820 T:1925827072 DEBUG: CMMALRenderer::CMMALRenderer
00:14:23.820 T:1925827072 DEBUG: CMMALRenderer::UnInitMMAL
00:14:23.820 T:1925827072 DEBUG: CMMALRenderer::PreInit
00:14:23.821 T:1466954496 DEBUG: Thread VideoPlayer start, auto delete: false
00:14:23.821 T:1905259264 DEBUG: Thread MMALProcess start, auto delete: false
00:14:23.821 T:1905259264 DEBUG: CMMALRenderer::Run - starting
00:14:23.821 T:1466954496 NOTICE: Creating InputStream
00:14:23.822 T:1466954496 DEBUG: PVRManager - OpenLiveStream - opening live stream on channel ‘Test’
00:14:23.823 T:1466954496 DEBUG: opening live stream on url ‘http://x.x.x.x/live/130917/167.ts
00:14:23.825 T:1895908096 DEBUG: CActiveAE::ClearDiscardedBuffers - buffer pool deleted
00:14:23.882 T:1466954496 DEBUG: Previous line repeats 1 times.
00:14:23.882 T:1466954496 DEBUG: CDVDInputStreamPVRManager - Open - playback has started on filename pvr://channels/tv/All channels/pvr.iptvsimple_2039024006.pvr
00:14:23.883 T:1466954496 DEBUG: CurlFile::Open(0x576fe2f8) http://x.x.x.x/live/130917/167.ts
00:14:23.884 T:1466954496 INFO: easy_aquire - Created session to http://x.x.x.x
00:14:24.082 T:1466954496 DEBUG: CFileCache::Open - opening <live/130917/167.ts> using cache
00:14:24.083 T:1466954496 DEBUG: CurlFile::Open(0x6fe259e0) http://x.x.x.x/live/130917/167.ts
00:14:24.187 T:1420817152 DEBUG: Thread FileCache start, auto delete: false
00:14:24.187 T:1466954496 DEBUG: CDVDInputStreamPVRManager::Open - stream opened: http://x.x.x.x/live/130917/167.ts
00:14:24.187 T:1466954496 NOTICE: Creating Demuxer
00:14:24.188 T:1420817152 INFO: CFileCache::Process - Source read didn’t return any data! Hit eof(?)
00:14:24.191 T:1466954496 ERROR: Open - error probing input format, http://x.x.x.x/live/130917/167.ts
00:14:24.220 T:1466954496 ERROR: Previous line repeats 9 times.
00:14:24.220 T:1466954496 ERROR: OpenDemuxStream - Error creating demuxer
00:14:24.220 T:1466954496 NOTICE: CVideoPlayer::OnExit()
00:14:24.220 T:1420817152 DEBUG: Thread FileCache 1420817152 terminating
00:14:24.278 T:1466954496 DEBUG: CDVDInputStreamPVRManager::Close - stream closed
00:14:24.278 T:1466954496 DEBUG: OnPlayBackStopped: play state was 1, starting 1
00:14:24.278 T:1466954496 DEBUG: Thread VideoPlayer 1466954496 terminating
00:14:24.278 T:1925827072 DEBUG: OnPlayBackStopped: play state was 3, starting 0
00:14:24.278 T:1420817152 DEBUG: Thread JobWorker start, auto delete: true
00:14:24.278 T:1925812992 DEBUG: CAnnouncementManager - Announcement: OnStop from xbmc
00:14:24.279 T:1925812992 DEBUG: GOT ANNOUNCEMENT, type: 1, from xbmc, message OnStop
00:14:24.292 T:1925827072 NOTICE: CVideoPlayer::CloseFile()
00:14:24.292 T:1925827072 NOTICE: VideoPlayer: waiting for threads to exit
00:14:24.292 T:1925827072 NOTICE: VideoPlayer: finished waiting
00:14:24.292 T:1925827072 DEBUG: DeleteRenderer - deleting renderer
00:14:24.292 T:1925827072 DEBUG: CMMALRenderer::~CMMALRenderer
00:14:24.293 T:1925827072 DEBUG: CMMALRenderer::UnInitMMAL
00:14:24.293 T:1905259264 DEBUG: CMMALRenderer::Run - stopping
00:14:24.293 T:1905259264 DEBUG: Thread MMALProcess 1905259264 terminating
00:14:24.293 T:1925827072 NOTICE: CVideoPlayer::CloseFile()
00:14:24.293 T:1925827072 NOTICE: VideoPlayer: waiting for threads to exit
00:14:24.293 T:1925827072 NOTICE: VideoPlayer: finished waiting

You may want to check your PVR setup.

Same url works with vlc on my laptop

Provide a complete log if you wish to receive relevant support information.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

1 Like

hi,

here is the full log till the error
https://pastebin.com/7Y2PAYZY

I noticed that the url doesn’t contain the streaming directly, but has 2 http redirects before the right stream.

Would be nice if you provide all data as described in the article @ActionA told you, next time.

20:01:04.519 T:1412215552   DEBUG: CDVDInputStreamPVRManager::Open - stream opened: http://x.x.x.x:15004/live//130917/166.ts
20:01:04.519 T:1412215552  NOTICE: Creating Demuxer
20:01:04.519 T:1382851328    INFO: CFileCache::Process - Source read didn't return any data! Hit eof(?)

Please check your NAS whether you can set SMBv3 protocol as max. protocol to use (for Synology and most QNAP this should work).
In case SMBv3 is not supported on your NAS, set your OSMC device to use SMBv1.

smb? the pvr url is not controlled by me, and it is on internet, not internal ip. It works with vlc and if I try to do wget of that link there are 2 http redirect (Location).

Does the player support http url redirect?

Hi,

Just for testing, does the stream play if you disable hardware acceleration?

Thanks Tom.

Ahh, sorry, totally confuses this by only having seen the x.x.x.x for the IP, no, no idea what’s going on here but it looks like the data is not coming in at all or fast enough.

What happens if you download the .ts-file locally to a USB-stick or -disk and try to play it locally?

it is a stream, I can download it correctly with wget, but the file content is raw, it works with vlc.
As far as I can understand it is a http redirection problem and the player can’t follow http redirection… do you know if there is a player that is able to follow redirections?

it is the same, it seems to be an http redirection problem with the player…

Hi,

Have you asked the iptv provider about this?

Could be being blocked at there end:

  • Provider could be blocker user agent, some have started blocking kodi & osmc.
  • Also MAC address, easier if its this you can normally ask them to add back in, its normally done on the wired mac, even if you are using wifi. (I normally submit both to be on the safe side.)

Thanks Tom.

already asked, there is no block on iptv provider.

Hi,

Have you tried this on kodi on windows, just trying to find if its specific to osmc or something that has changed in with kodi in general?

Thanks Tom.

hello Tom,

same error on kodi with ubuntu. So it seems a general kodi issue.

Hi,

I would report this on the kodi forums: https://forum.kodi.tv. More chance of a fix there.

But we can continue to investigate the issue:

  • Which PVR client are you using?
  • I assuming the iptv provider, provides a playlist is it m3u or m3u8?

Thanks Tom.