Kodi Krypton for OSMC is now available

If you've been using OSMC for a while and checking in regularly on our updates, you may have noticed we've been talking about a new version of Kodi for some time. Today, we're happy to announce that this new version is now available for all OSMC devices.

This is a companion discussion topic for the original entry at https://osmc.tv/2017/02/kodi-krypton-for-osmc-is-now-available/

What do we need to do if we want to continue receiving updates for Jarvis while Krypton matures?

There are no more Jarvis updates. It’s end of life and we’ve only been giving it maintenance fixes for the past few months.

Jarvis images will be kept on the Download page. If you want to stay with Jarvis, refuse the update when prompted.

Is the videoclock improvement already included in this new update or should i do this now again?

at testing phase it doesn’t improve my performace but maybe now?

No – there weren’t enough testers so it wasn’t included.

It will come in a future update

1 Like

I’m not happy at all. The Kodi 17 is slow with addons navigation and in general; very far by the brilliant performance of Kodi 16 on my both RPI


Really, really disappointed


That information is outdated.

Addon caching has been reenabled in the final version of Kodi Krypton that we have released today as an update

Have you actually tried today’s update and experienced a performance problem, or are you talking about an older build?

We would not release anything that we feel doesn’t match the level of quality people have come to expect from OSMC


Hi Sam,
I’m talking about the official one; updated now from the OSMC update from Kodi 16 to Kodi 17. Even if the archive_cache is in place, the UI navigation it is not immediate and I could say regressed. The other RPI with the test version of OSMC same behavior.

As I wrote in the posted links, when a video is terminating from an addon (youtube in my test), the system still thinking a while instead to give immediately the last menu when the video was selected.

This kind of slowness reflect the general performance of this new version.

I really hope that these performance issues will be fixed soon.


I do not see this behaviour. Please start a new forum post with debug logs.

Make sure you are using the same addons as you were on Jarvis. Try and keep the environment consistent. Also check you are actually on the final version

If you can let me know how to reproduce this regression I’ll look in to it for you. It’s possible the addon you are using has been updated in a similar timeframe and this is a coincidence.

Moving through the menu was slow on the test build if 17 when I get home I will update my test box and if it is still happening I will post my logs here.

Please start a new post if issues persist with the build we released today.
Older test builds of Kodi v17 were slower, but that’s why we did testing :slight_smile:


Hi Sam, I have been using OSMC / kodi 17 release candidate releases for the last few months - RC4 was the latest. I expected that the dist-upgrade today would leave my raspi with 17Final, and instead of that, I see it got 17.1RC1 (!!!). How do I get out of the alpha/beta trial and go back to the normal stable releases? thanks

I’m using OSMC on a Pi3 with tvheadend on a different box on my network.

I got the upgrade notification, so upgraded, and on reboot the LiveTV menu item has disappeared. My kids are nagging me now.

System Info Summary says I have OSMC running Kodi 17.1-RC1


Have you renabled the PVR TVHeadend addon?

It’s not showing in the add-on browser any more. I’m trying to figure out how to get it listed there again.

Also for me system info says it is RC1. I updated the official way and never tried release candidates before. I’m using Vero 2.

That’s strange, are you sure update worked completely through including addon updates? PVR TVHeadend addon worked for me after reenable

I’m a casual user - just use OSMC on a Pi3 as a settop box for watching tv recorded off terrestrial signal on the other machine that has multiple RTL-SDR’s plugged into it.

I switched on the TV to watch the news, saw the OSMC update notification and hit the GO button. After reboot, I no longer have a LiveTV option. Needless to say, I’m not watching the news right now. :^)

I’m trying to find a menu item that will force another system upgrade.

Woot. I got something.

I had to go into “add-on browser”, then go into “my add-ons” and then “all” to see the disabled “tvheadend” add-on, as no “PVR clients” menu option was showing up. Now, it is.

I must say - it appears the user interface for the PVR has changed DRAMATICALLY. Before hand I could get to where I wanted (a scrollable list of recorded programs) with a couple of keypresses. Right now I’m still trying to figure out WTF is going on.

Gotta say the new UI is horrible compared to the old one, and there is a huge delay going back to the menu when you stop watching a recording.

Is this another case of fixing something that wasn’t broken and coming up with a product worse than before?

1 Like