KODI's High Bitrate Audio Issue handling!

This is not directed at OSMC

Am I the only one that is pissed off with the lack of effort to fix this issue! this is not a new issue. it is making KODI and The Vero4K+ Unusable for me.

having guests over to watch a movie and having audio dropouts in a movie is embarrassing!

You can use PCM for now which will sound the same for TrueHD, but you won’t get Atmos through.

There is a known, upstream issue on Kodi’s issue tracker. I believe that it’s still being worked on.

interesting idea,

last i heard the issue and the fix were known but it is NOT being worked on. seems KODI 19 is more Important.

That’s not correct.

That’s the downside of an open source project like kodi. Since all the work is voluntary bugs are sometimes not fixed if none has interest and motivation to fix it

I suspect those with any clue how it might be fixed don’t have Atmos.

1 Like

Didn’t think of that possibility!

The issue has recently been fixed with Plex on the Shield. It could really do with fixing as its been known for a long time.

It was fixed with androids player not kodi. That fiix has no bearing on kodi’s fix

You mean by disabling TrueHD passthrough, right?

Yes, this will force the Vero to do the decoding and send it as LPCM.

I assume it does not work for DTS-HD MA and DTS:X the same way, cause if you disable DTS-HD passthrough, the device will just send the lossy DTS core instead of decoding it and send it as LPCM.
Is that correct?

We’re not aware of a problem for DTS-HD MA. Or did I miss something?

DTS-HD MA should not be affected.

Sorry for the confusion.
No high bitrate issues here with DTS-HD MA, but I just wanted to know how DTS-HD MA tracks are handled when passthrough is disabled.

I guess for DTS-HD HRA/DTS-HD MA tracks to be decoded by the Vero, I also have to disable standard DTS passthrough?

Yes but if passthrough is working, leave those. Just turn off TrueHD passthrough.

In fact, I don’t even have problems with Atmos tracks, at least until now.
But the reason I had to disable at least TrueHD passthrough is because I got a new soundbar and it has a couple of different sound modes, like music, movies, standard etc. but those are not selectable when a Dolby Atmos or DTS:X track is played, because if the soundbar detects a 3D audio track it changes to a specific, not changeable sound mode. The problem with that is, the soundbar seems to lower the volume in loud scenes and for me the movie comes completely unwatchable.
And before anyone asks, yes it has a “auto volume” setting, which is set to “off”. In fact this setting is also not changeable when a 3D audio track is played.

I hope I can return this soundbar.

So that is the reason I asked for DTS behaviour, even though I haven’t tried if this volume lowering problem also exists with DTS:X tracks.

DTS-HD MA should always embed a standard DTS 5.1 stream. If you disable DTS-HD passthrough but not DTS passthrough you will get DTS 5.1 passed through.

i was reading through the commits for KODI 18.7 release, guess whats NOT there. yup. a fix for the Atmos/TrueHD issue

Well, there hasn’t happened much in the respective Git issue, so what did you expect? Kodi 18.4 crashes with high bitrate TrueHD+Atmos audio stream · Issue #16704 · xbmc/xbmc · GitHub