Last update broke RC6-MCE remote

Today i updated to the latest version, but after the update, my VERO is not responding to my remote.

I checked the remote settings, and found no remote file selected, and the ‘disable RC6’ checkbox enabled.

i removed the checkbox, and reselected the rc6-mce-lircd profile, but this time the remote won’t work… any way to fix this?

Exactly the same problem with me.

I was using until then the built-in IR receiver with no problem.

I selected Samsung TV remote as a yes t(it was working before) : fail

I inserted an IR dongle which was working before : fail and it gets red non stop

it looks as if IR had disappeared

I also lost my RC6 remote when updating today.
Selecting it again in the OSMC menu does not help and have removed the ‘Disable RC6’

I also lost my remote after updating

I only registered to report this same problem.

Can confirm, ir remote is no longer working för me neither.

Same here. Logitech Harmony remote stopped working with the latest update. Please fix this ASAP!

Go to My OSMC -> Updates -> Manual Controls -> Check for Updates and select Yes when prompted. It could take an hour for this update to reach your mirror.

Hi Sam,

I tried this again about 20 minutes ago after my remote stopped working. I did get another update but it still has the same problems. Checking again says no update available. How can I tell if I have the correct update please?



I saw on another thread for broken sound you said check uname -a so this is what I get:

osmc@osmc:~$ uname -a
Linux osmc 3.14.29-66-osmc #1 SMP Fri Mar 16 21:43:36 UTC 2018 aarch64 GNU/Linux

I guess that’s too early so I’ll try for an update later.

Please let me know if that’s the right thing to do…



Please check the output of uname -a.
The kernel should end with version -67.



Just had an update and it is now the correct kernel version. No errors shown on boot but my remote still doesn’t work.

Any ideas?



Not from that I’m afraid.
Did you toggle any settings to try and get the remote working again after updating?


nothing. I just used the android app. instead. What should the setting be in remotes? I actually use a harmony so from what I remember I should have selected xbox as a remote type should I? I also notice a ‘disable rc6’ checkbox (or similar from memory) what should that be?

So close - and yet all gone wrong :slight_smile:

The same for me.
I installed the update but my remote (harmony) still doesn`t work.

I’ve reselected xbox360 since I think that’s what I used before and still no dice. If I select the vero remote that doesn’t work either.

I have tried restoring a backup taken in Jan in case any settings had changed during the updates but still no difference.

I’m at a lost

Could the IR port have suddenly stopped? I’ve tried with and without the extender.

Just seen Inferno3 has the same issue - so not just me then.

Please have a look Sam…



I tried flipping around selecting different ones but no difference unfortunately.

I doubt it’s a hardware issue. We have done some testing and meson-ir has some issues. This is one of the reasons why we avoided media_build (you will remember May / June 2017).

One final update may do the trick, as I’ve synchronised our changes in tree with the backports.

Add me to the list. RC broken after last update.

I have installed the updated update, and still can’t use my Logitech Harmony remote.

Kernel version is:

osmc@osmc:~$ uname -a
Linux osmc 3.14.29-68-osmc #1 SMP Sat Mar 17 02:04:25 UTC 2018 aarch64 GNU/Linux