Latest udpate - OSMC 4.2.3-3 (kernel update) not booting after update

Ok, so OSMC prompted update is available for my Pi B based OSMC, I selected yes. asked to reboot, I selected reboot… now… dead !
doesn’t even get to OSMC splash screen. How Do I revert back?

Don’t see anything on screen. no SSH access either. Is my OSMC hosed?

Hey. I think I have the same problem, OSMC does not start, there is no picture and SSH is no accssible :confused:
I didn’t touch my RPI with OSMC for around two months. Yesterday I tried to connect it to projector but there was no picture. I also thought that RPI was gone but the I limited it to problem with SD card. I inserted some other card with NOOBS on and it started OK. I installed fresh OSMC (2015-09) on that SD and the same problem - no picture, nothing. After that I have installed older OSMC (2015-06) and it booted ok. So there is probably something wrong with latest update.

And maybe this would be of any help with debugging: If I look at green led it blinks few times at power on (so image probably starts) and then starts repeatedly blinking really really faintly. Like it would be broken

Do you not see the rainbow colour screen that normally appear for about a second ?

Can you get a directory listing of the fat partition (including file size and dates) on another machine and post it here ?

Did you run an update in the last couple of days ? If not your issue is unrelated and should be in a separate thread.

I have automatic updates switched on? So I do not know how long the problem persist. The problems described are simillar and I think it has something to do with latest build/update, but you are correct - I do not know that. I will open a new thread and described my problems there. Sorry for spaming in this thread.

Automatic updates won’t install anything without your permission, so if you didn’t say OK to a prompt to install updates, then you won’t have installed any updates. (Of course another family member might have selected OK in your absence!)

I have the same problem. I left the beast on last night because I was doing a download and all that I can see this morning is the non smiley face.
And no, I did not do the update myself, though I think it happened as I see a last night dated OSMC file in the partition.

I took the micro sd card to another PC, removed the .kodi\temp directory contents, but that did no good.
I did this because that fixed it the last time it happened.

So, how do I do a restore by using ssh ?


OSMC does not update itself without your permission, it will always prompt you to install updates no matter what preferences settings you have.

Please provide full debug logs so we can get an idea of what is going on. From ssh:

grab-logs -A

ok, log dump has been posted.
Additionally, the removing of the temp directory did solve my problem.
The SD card was not fully seated when I rebooted.

You need to post the URL provided to you by the grab-logs command otherwise we have no way to access them.

Sorry and here is the link.

And apparently another update, not osmc is causing this.
I am still on 4.2.3-2

First, remove the overclock. Very few Rpi2 will run at 1000.

So exactly what problem are we looking for here?!

The fact that when booted, all that I got was a blue screen with the unhappy face. Removing the stuff in home\osmc.kodi\temp, and from memory I think that I got the path correct, that will allow it to boot properly.

You’re topic has exactly NOTHING to do with this thread! You already have a thread for this issue. I don’t understand why you are bogging this one. Please make an attempt to assist us in keeping our forum neat and orderly for others seeking resolutions to their problems! Post your logs in your original thread regarding this issue if you want to continue…

Overclocking removed, though if it really can cause problems like this, I wonder why OSMC makes it so easy to take the option without some appropriate warning.

QUIT threadjacking and return to your thread!

Action, I appreciate your technical suggestions but put your other comments elsewhere.
This thread on the main page is prominent about not being able to boot after an update. It sounded exactly like what I had. Hence my post.
So, lighten up.

Prominence means nothing when your issue holds no relevance…