Latest VERO4K May release broken Remote IR Mapping for XBOX ONE / 360 Remotes

That is something else unrelated to the IR driver bug that has just been fixed. I’ve just tested my xbox 360 white media remote (looks exactly like the one in the screenshot in my osmc) and it is working perfectly on the latest update.

A few things to check:

  1. Make sure you are actually running the right kernel. From ssh:

    osmc@vero3-db:~$ cat /proc/version
    Linux version 3.14.29-21-osmc (root@vero4k) (gcc version 4.9.2 (Debian/Linaro 4.9.2-10) ) #1 SMP Sun Jun 11 20:02:40 UTC 2017

Check that you have version 3.14.29-21-osmc and that date and time matches as well.

  1. Try using the irw command to see if keypresses from the remote are being delayed or whether the problem lies in Kodi. From ssh run irw then press some buttons on the remote:

    osmc@vero3-db:~$ irw
    67 0 KEY_UP linux-input-layer
    67 1 KEY_UP linux-input-layer
    67 0 KEY_UP_UP linux-input-layer
    6a 0 KEY_RIGHT linux-input-layer
    6a 1 KEY_RIGHT linux-input-layer
    6a 0 KEY_RIGHT_UP linux-input-layer
    6c 0 KEY_DOWN linux-input-layer
    6c 1 KEY_DOWN linux-input-layer
    6c 0 KEY_DOWN_UP linux-input-layer
    69 0 KEY_LEFT linux-input-layer

You should see an event immediately when you press a button and it should keep repeating if you hold the button down. If you see this immediately but Kodi doesn’t respond until a lot later the problem is elsewhere with Kodi.

If the output from irw is delayed as well or seems very intermittent, my first guess would be some sort of light interference on the IR sensor such as from daylight or a faulty energy saving bulb - fluorescent energy saving bulbs have been known to cause flicker that can upset IR receivers, and I have had this problem before on different devices.

Try to shroud any light sources from the vero4k and test the remote again with a good line of sight, if that works then it is probably a lighting issue in the room - try turning off specific lights to find which one it is.

Another thing you could try is to plug in and use the external IR receiver dongle if you are not using it, or remove it if you are.

Finally, check the room for any other IR remotes that may have an object on top of them holding a button down - if another remote in the room is broadcasting an IR code even if it is partially obscured it can interfere with other remotes in the room. Yes I’ve had this happen too, as spare remotes sit in a box that often gets toys dumped on top of them by a 1 year old… :wink:

@DBMandrake I will do these things. However kindly note that my setup or remote didn’t change since the May Update and only change that happend was May update broke the functionality and post the fix I got the lagging.

I respect all of your points and will do double and triple checking and will post the results.

Also I got a similler setup downstairs and will apply the fix and will try that as well.

Also to eliminate all other IR and HW issues what steps I can follow on VERO4K to downgrade to April update? Any link or steps will help as I can easily isolate the code.

Again not trying to be difficult and want to get this fantastic setup up and running again as I was over the moon when I controlled all of things with just one TV remote.

@DBMandrake feedback on 3 points as below

  1. Got the correct Version

osmc@MbrVERO4K:~$ cat /proc/version
Linux version 3.14.29-21-osmc (root@vero4k) (gcc version 4.9.2 (Debian/Linaro 4.9.2-10) ) #1 SMP Sun Jun 11 20:02:40 UTC 2017
osmc@MbrVERO4K:~$

  1. I do see a delay in the logs

Then what I did was rather than my TV smart remote which is the Samsung Smart TV one. I used my other old Samsung TV stock remote (which got the profile already in OSMC Samsung) and try to use it. Then all the delays was gone and all was working fine…

So @DBMandrake @sam_nazarko it seems to be some IR changes implemented in May release have broken my working setup which listed under below post and same lagging issue preset with both of my setups. (Master Bed room setup and my Rumpus room setup)

Can you kindly let me know will you guys consider fixing this issue or will I need to look at alternative approach to satisfy my needs.

Way my setup works clearly explained in above post and details around my remote is available on above post…

We need to work out what’s broken first. Of course, once we work that out, we’ll resolve it.

There seems to be a concencus that remote support is now working as expected again.

Can you post those logs? I think perhaps you may be relying on CEC rather than IR, and this may not be working as expected for you. If you can also try powering off all devices at the mains for 10 minutes, then powering back up, this would be helpful.

Sam

You didn’t mention that one of your remotes was working again - that’s an important piece of information. :slight_smile:

In that case have you tried changing the batteries of the remote that isn’t working properly ? Obvious possibilities should be checked before more complex ones.

A second point I would make is that are you sure that your Samsung Smart remote was working via IR in the first place and not via CEC ?

I also have a Samsung Smart TV supplied with both the rectangular “standard” remote and the small curved “Smart remote” with the touch pad in the middle and a voice control button.

As far as I know, while the standard remote is a normal IR remote the smart remote is not an IR remote but an RF remote, (possibly bluetooth or similar) as it works without line of sight - you can put it inside a sock or a closed bag in an adjacent room and it will still work - in fact mine has sometimes started operating the TV from the bottom of a closed toy box exactly because of this, and I’ve then had to go searching for it to stop it taking over my TV…

It’s possible that it is both IR and RF but its much more likely that it is only RF, in which case it could never have worked with the IR receiver on the Vero4k in the first place.

Assuming the remote belongs to the TV connected to the Vero then its much more likely that it was controlling the Vero via CEC which is a remote control protocol over HDMI which is enabled by default in OSMC. Most TV remotes will work out of the box with OSMC via CEC.

It may be that you are having problems with CEC rather than IR.

Another thing I would say is that if you have learnt your Samsung remote buttons in a remote profile in OSMC (or downloaded a lircd profile for it) for use via the IR receiver in the vero and the TV is also in the room and connected to the vero then this is probably asking for trouble - because the IR receiver in the vero would respond to the button press directly and the TV would respond to the button press and attempt to send that to the Vero using CEC. (And even if CEC was disabled the TV would try to act on the button press itself causing unintended actions)

Normally it’s not a good idea to learn the remote codes for any remote that is already controlling a device in the room.

Edit: this is the smart remote I have that is RF not IR:

@DBMandrake @sam_nazarko Thanks both for your feedback and I will explain the conditions again and clarify few things. This will again help to understand the situation and find a fix.

My SETUP:
Remote:
1: My Samsung Smart TV remote (Appendix 1) is a bluetooth remote which ALSO got the universal remote control functionality which can be configured via the TV interface to support devices when I select the source accordingly

2: As per my initial post, via TV setup I have configured HDMI1 to have my Foxtel IQ3 box and selected the remote to act as an universal remote which programmed to Foxtel IQ BOX (Appendix 2)

3: As per my initial post, via TV setup I have configured HDMI2 to have my VERO4K box and selected the remote to act as an universal remote which programmed to XBOX 360

4: Note that as per point #3 TV do have the ability to select and program the Smart Remote as an IR remote (This as be VF as well and I am not sure). This is why I can select XBOX ONE option via the TV and also XBOX 360 profile as OSMC supports them

5: Whenever I select the Universal remote option via the TV, I do have the ability to TURN the CEC OFF for connected sources and I have done this.

6: I did replace my remote batteries with new batteries yesterday

7: Via the HDMI source 1 which connected to the FOXTEL Box all working fine as Universal remote mode and FOXTEL box is controlled via the TV remote and CEC IS OFF

OSMC SETUP:
8: Given I programmed my TV smart remote to mimic XBOX ONE first, then I went to OSMC and loaded the XBOX
ONE config and TV interface for some test called Power Test and when hit the “Power Test” button from the TV screen I can see the OSMC BOX turning off (RED LED Colour) and this mean Remote is sending correct IR signals (Or RF) and only issue is lagging. I promise that 100% this setup was working prior to MAY update

9: Given above point #8 got lagging after the May Update then I configure the TV smart remote to mimic XBOX 360 , then I went to OSMC and loaded the XBOX 360 config and TV interface for some test called Power Test and when hit the “Power Test” button from the TV screen I can see the OSMC BOX turning off (RED LED Colour) and this mean Remote is sending correct IR signals (Or RF) and only issue is lagging

Explanation on the successful test on Stock Remote:
As @DBMandrake highlighted this is the key and what I also can’t explain. When I used stock old TV remote, first I went to OSMC and load the Samsung TV config and given this is different remote came with one of my old TVs, I can’t control my Smart TV with this remote. I just used this remote to see any issues with my env. setup / light issue and other things DBMandrake informed me to check and all was working fine.

10: This can conclude that my env. not changed and whatever happening now happening way my Universal TV remote sending commands to the VERO4K

11: Also we can’t complain the universal TV remote as my FOXTEL Box connected to HDMI 1 working in the universal mode without any issues

12: This point is KEY. I got the same setup above in my downstairs RUMPS room. SAME TV / SAME REMOTE / SAME FOXTEL IQ3 BOX / SAME VERO4K BOX / SAME HDMI SETUP. All above symptoms replicated in this new setup as well and this setup also stop working post the MAY Update and lagging is experienced after the fix issued.

Hope this will give a big clarity and I can do a simple thing to showcase issue is with the MAY Update. If one of you can guide me with steps to install VERO4K April update that will show all will start to work and I am happy to be a ginny pig and install serious of small incremental releases if applicable to find the problem.

As per my resolved post I really love the setup I got and having one remote control my boxes and if you can help me to come back to that state I will appreciate it lot. I know I am just a one user and you guys got million other priorities but kindly think about of my situation and this humble request.

Appendix 1: Tv / Remote Picture and Details
TV Model:
SAMSUNG SUHD TV - KS8000 - 60’’
Link:

Remote Model: (Images attached)
BN59-01241A

Appendix 2: Video Clip of how the Universal remote configured via the Tv and how it will be used to control the Foxtel Box

Link to the TV and Remote Manuel:

P.S:
Found the link to downgrade and install April VERO4K update and I will do this soon as well.

I’ll see if I can produce a new kernel which may resolve the issue for you. Unfortunately, it might cause problems for users with other remotes, so needs a bit of testing.

Sam

Wow!

Please don’t break the xbox 360 remote mapping again :slight_smile:

Of course!

Sam

Hi

Hopefully the issue is fixed now.

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

P.S. @mlavende – I’d appreciate if you could test and make sure nothing is broken so I can get this in the next update. If it is, I can very easily give you downgrade instructions.

Sam

Hi Sam,

I’m away from home at the moment but can check later tonight or tomorrow evening after work.

Hope that’s ok
-Mat

@sam_nazarko

I tested the new release in both setups and findings as below

  • Its a fair statement to say when I press the keys twice it translate to action in VEO4K in a consistent manner. For example when I click the remote “Left” key once nothing will happen but when I click it twice it will action. Same with Enter key and even with my “IR Long Press KEY Back” which translate to Context Menu. (Logs as below)

  • If this is the best you can get with without impacting Others I am OK SAM… I can live with the current behaviour of this FIX and way better than the MAY Update FIX.

Here are the logs to showcase my 1st Point Sam.

osmc@MbrVERO4K:~$ cat /proc/version
Linux version 3.14.29-22-osmc (root@vero4k) (gcc version 4.9.2 (Debian/Linaro 4.9.2-10) ) #1 SMP Sun Jun 18 03:12:22 UTC 2017

After First time “Left” key Press:
IRW: Output was blank

osmc@MbrVERO4K:~$ irw

After Second time “Left” key Press:

osmc@MbrVERO4K:~$ irw
69 0 KEY_LEFT linux-input-layer
69 1 KEY_LEFT linux-input-layer
69 0 KEY_LEFT_UP linux-input-layer

Here is a Video clip therefore you can see for yourself…You can see the my remote illuminating “Red” that mean my key press and you can clearly see how it interacting with VERO4K. Happy to do more testing and send more logs if require… As I said this is a huge improvement vs current May update fix…

https://goo.gl/photos/zbQvMvwYuWXAbnsy7

@sam_nazarko I tested the above with XBOX360 Remote profile and now it one is 4 to 5 key presses Vero4K dropping key and I need to repress. I think I can live with XBOX360 profile and happy to accept this as the fix. I will wait for your confirmation remove the dev DEB. Thanks again for looking in to this and fixing this even it was reported by only me.

Thanks for standing up for your word and value of VERO4K…

Okay, that’s good to know.

We might be able to do better. I’ve effectively reverted the changes that we introduced in May, so to be honest, I was expecting better results here. So it needs further investigation. I’ll do a bit of testing here soon enough and if there are further improvements we can make I’ll let you know. I’ve been testing with the Xbox 360 Media Remote and the original Vero 1 (RC5) remote.

You can remove this repository listing now. It won’t revert
the changes you made earlier today.

Sam

Hi Sam,

I’ve run your instructions and my Harmony still works fine. I’m using the XBOX360 profile so all seems good.

Thanks

-Mat

Great – thank you for confirming this.

and adding what @sniferx1 said about the double-click etc., keep in mind that on the harmony, you can enable/disable key repetition (advanced settings).
I have had quite a hard time until I figured this out.

@sam_nazarko: I would rather concentrate on the non-Harmony devices to work with the lircd first, as these devices are too prone to misconfiguration. IMHO from experience, if lircd works, the harmony will work too.

My Harmony has not been configured to disable key repetition. I originally just picked the XBOX360 profile and it worked. Then it stopped totally after the previous release, then the fix came and it works again.

I’m using the standard XBOX360 profile that would be used if you were using an XBOX360 remote

Thanks

-Mat

My old one too. With the Hub - it behaves differently though.

Doesn’t the Hub connect via bluetooth rather than IR?