Library & Network Issues

#1

Hello

I have just recently ran into a few issues with osmc on my vero4k. When selecting the file manager, nothing loads and the system UI freezes. Furthermore, no media is currently playing and will just buffer when selected. I have my media setup as an NFS fstab with hanewin and I have tried both reinstalling and updating hanewin to no avail.

Additionally when I SSH, the connection drops when I try to access mnt.

Logs here: http://paste.osmc.tv/lucinusabi

Thanks!

#2

This is the big clue to me, seems that Hanewin may be a problem. When you connect via ssh, are you doing it from the same system running Hanewin? If so is there another system that you can try connecting to the Vero and try accessing /mnt?

You may try running some network tests with iperf3 between the Vero and the server.

#3

Here are the iperf results:
Capture

I also tried accessing via ssh from another device and I was having similar issues. Accessing the subfolders was not possible due to freezing.

#4

You say freezing now, that’s different from being disconnected. The freezing is because it can’t mount the shares. Have you checked the logs on the the server for any obvious errors? Anything change on the server recently?

#5

I looked at the errors and is essentially just confirms what you told me and doesn’t really list any reasoning as to why.

Besides restarting the host computer a few times I have no idea what else changed. May have been a windows 10 update or a GPU driver update and that’s it.

#6

Check this post, it seems similar: Cannot Access NFS Shares

#7

Yeah I did check out my old post. Was lucky to find I still had that old version backed up somewhere but it didnt solve the issue. One thing I did notice when screwing around with hanewin is that port 111 is the only one listed on portmapper. 1058 and 2049 are not there and I did not see them on netstat. They are under the same firewall rule as 111.

#8

Does Hanewin have any support forums? I think you need to turn to them.

LOL, sorry I didn’t notice when I linked that that it was you. I just remembered someone having a similar problem so I searched and linked without checking the details :innocent:

EDIT:

Have you tried adding a vers=3.0 in the fstab? It may be something with the NFS version being used. If 3.0 does not work, try other versions, even 4.[0-2]

1 Like
#9

No worries man, I was actually relieved to see it was you reply, since you have been very helpful with a multitude of issues.

I just updated to the latest version of hanewin 1.2.42 and everything works again. Wow, I love this software since it works 99% of the time but some of these issues can be annoying, although simply fixed.

#10

Great news. Seems that Hanewin is a little, um flakey. Or is it the interaction with Windows.

Thanks for that. Nice to have someone appreciate the help given :blush: