Lightning bolt symbol

Just the other day the yellow lightening bolt symbol appeared in the top right hand corner of my screen. I’ve read that this is a power problem. I’ve tried using another power supply which definitely works and he hasn’t fixed the problem. Any suggestions?

Both power supplies are not up to the job. What other ‘stuff’ do you have connected? You might need to use a powered USB hub

1 Like

No other stuff at all. I just use it to run kodi. Been running fine for months. Since the lightening appeared I can’t do anything. Won’t connect to the internet. Won’t let me use a mouse.
The second power supply I tried is powering a different pi as we speak

well its as simple as the psu isnt up to the task might wanna change the cable while your at it if that is old too.

Why would the second power supply work on another pi but not mine?

Is the other Pi running OSMC or some other distro? OSMC is optimised for performance and with higher performance comes higher power usage.

Both pi’s running kodi through osmc. Exactly the same builds. Exactly the same sd cards. Same power supplies. Same everything. I’ve ordered a new power supply which should be here tomorrow. I’m just worried there’s something wrong with the hardware of the pi

The latest OSMC uses more power than previous versions. Older versions didn’t report under voltage when they should have.

If you update the ‘other Pi’ to the latest version you will probably see the lightning bolt there too. It’s also a good way to rule out a hardware fault, provided you’re connected to the same socket and TV with the same peripherals.

You can get a good PSU here.

1 Like

I’m pretty sure it did start after the latest update. Thanks for your help guys. I’ll let you know how I get on with the new psu. Fingers crossed.

Did you also tried different cables or you just swapped psu?

So my official raspberry pi psu and cable 5.1v 2.5A arrived today and it’s made zero difference! Should I just wipe my sd card and start again ?

Any custom settings in config.txt?
Can you provide a link to the power supply you bought?
Describe anything attached to the Pi.
Do you have a volt meter?

try another cable also if you haven’t

No custom settings that I know of. I don’t have a volt meter. I also just tried another sd card with the exact same set up that is working on another pi and it’s doing the same thing in my pi.

Here’s the psu

Is that a decent psu?

It is the same PSU that other people have been having issues with recently

If he did get the 5V 2.5A one though, it should be up to the job. He may just have a faulty one. Worth arranging for a return to the vendor if that’s the case.

Hi Jaggysnake,

This sounds very similar to my problem with a pair of 2015’s Pi2B models. I have/had a complete “twin” setup, only exception: I did not spend money for the VideoCoreIV license for the 2nd Pi2. The Pi2 with hardware decoding some day started randomly displaying the rainbow box within Confluence as well as within playing films.
I swapped all and everything, but the problem was only gone when I exchanged the Pi2. Currently the “somehow thirsty” Pi2 is here for LED / python testing, doing it well. But I don’t trust this device anymore, would never connect it to my expensive TV or my (writeable) music files base.

BTW: this lend me to the task to order the decoder license file. Pi2B is able to software decode any SD content from DVB-T and DVB-S, but some HD content is sometimes stuttering. Rarely, but my wife is not amused…

try a short micro USB cable. At the low voltage (5v) of usb power, every inch of cable constrains the current that makes it through to the pi.

I know it sounds a bit snake oily, but it really does make a difference.


Changing software will make NO DIFFERENCE. This is because the low voltage detector is implemented in hardware. Raspberry Pi Power Limitations describes the Pi power if you want further detail.