Load roms/games from NAS/network location

Anyone know how to load games from a nas instead of from sd card?

Via smbclient and mount under fstab there are threads here on the forum

Or NFS threads also here on the forum on howto

hi,

as it comes to linux i’m not good at it. ans i don’t know what you mean.
anyone has a tutorial?

tried to edit fstab, but when saving it says permission denied.

use sudo before the edit command

//mynas_ip/Roms /home/pi/roms cifs defaults,ro,user=xxx,password=xxx 0 3

is this the sdcard rom folder? /home/pi/roms

my roms are in this folder: /opt/retrosmc/home/pi/RetroPie/roms

what else do i need to do?

Ok, some confusion here:

  1. I assume you have installed OSMC, then you have /home/osmc/
  2. THis sounds like to be the folder from the old install and not from the latest RetroPie install that has been provided here [HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC
  3. After you installed latest version roms are in /home/osmc/RetroPie/roms

i’ve found this RetroPie - Running games directly via network - YouTube
but what are the paths for osmc?

On OSMC, the paths are the same as with any other RetroPie installation with one exception:

Everything that is normally in /home/pi/ is in /home/osmc/ here.

i’ve put this script in Ports folder:

sudo mount -t cifs -o user=xxx,password=xxx //your_server_ip/Roms /home/osmc/roms
sudo ln -s /home/osmc/roms/snes /home/osmc/RetroPie/roms

Unable to resolve host osmc
can’t chdir to /home/osmc/roms: no such file or directory

You have to create a folder first before mounting something on it.

It doesn’t help to put any scripts into the Ports folder.

But let’s start from the beginning:

First change to your home directory:

cd ~

Then make a new folder where you want to mount the networkdrive to:

mkdir roms

Then mount the networkshare to it:

sudo mount -t cifs -o user=xxx,password=xxx //your_server_ip/Roms /home/osmc/roms

Where you have to replace xxx with your password and username to access the netwotk share and your_server_ip with the ip of your server. The share Roms (case sensitive) has to exist on your server and needs to have your roms in the same directroy structure that is present in the /home/osmc/RetroPie/roms folder in it of course.

After that check, if the folder is mounted correctlyby listing it’s contents with

ls roms

If you see the directories for the different systems, it worked.

Now you need to replace the roms folder on the sdcard with the one in the mounted folder.

First rename the old folder to get it out of the way:

mv RetroPie/roms RetroPie/roms.old

Now create a symlink to your mounted romfolder:

ln -s /home/osmc/roms /home/osmc/RetroPie/roms

Check if it worked:

ls /home/osmc/RetroPie/roms

If you see the directories it worked and you can now start and enjoy RetroPie.

Edit: If you want to remount the roms at restart, you can do the mount command again or google how to put it into fstab.

Edit2:
It doesn’t hurt to read about the commands and understand what they are doing before blindly pasting commands around btw.

Hi,

thanks for you’re help!!!

osmc@osmc:~$ cd ~ osmc@osmc:~$ sudo mount -t nfs mynasip:/volume1/roms /home/osmc/roms osmc@osmc:~$ mv RetroPie/roms RetroPie/roms.old osmc@osmc:~$ ln -s /home/osmc/roms /home/osmc/RetroPie/roms osmc@osmc:~$ ls /home/osmc/RetroPie/roms @eaDir atarilynx gb megadrive psx videopac amiga atarist gba msx quake3 wonderswan amstradcpc c64 gbc n64 scummvm zmachine apple2 coco intellivision neogeo sega32x zxspectrum atari2600 dragon32 macintosh nes segacd atari5200 fba mame-advmame ngp sg-1000 atari7800 fds mame-mame4all pc snes atari800 gamegear mastersystem pcengine vectrex osmc@osmc:~$

so this looks okay to me.

but when i start retropie it doesn’t show any emulators.
Do you know if i must delete all folders inside this path? /opt/retrosmc/home/pi/RetroPie/roms

You do not only have to have the roms in those directories but also all files that are there besides the roms. Copy them from your backed up folders.

Also if you delete files from the path you mentioned you delete them from your nas then :wink:
This folder is linked to the mounted share now.

hi,

i’ve ditched osmc and installed kodi and retropi dualboot and now it’s working :slightly_smiling:

Thanks for all of you’re help.

Ok. If that is a better solution for you that’s fine.

Hi All,

I took a gamble and installed minecraft from the experimental menu. Now retropie doesn´t start anymore, let allone minecraft, which was the whole purpose.
Any idea how I can uninstall minecraft again? And/or where to dig to see the problem. What logs should I look for?

To be clear: the symptom now is that if in OSMC I go to Programms and start retropie launcher, I see the emulation station screen for a few seconds. Then a black screen and then it falls back to the main screen of osmc/kodi again. No errors are shown in the process:-(

Regards,

Bert

Not sure if I can help, but minecraft runs in a x11 window. I guess the installation installed a lot of dependancies with it like mesa graphicsdrivers and stuff.

Try this:

@mcobit

How do I get rc.local to remount upon restart? How do I retain the mount/symlink of the rom folder upon reboot?
Setup Via SSH:

cd ~
mkdir roms
sudo mount -t cifs -o user=guestread,password=MyRealPass //192.168.1.139/osmc/roms /home/osmc/roms
mv RetroPie/roms RetroPie/roms.old
ln -s /home/osmc/roms /home/osmc/RetroPie/roms


ls /home/osmc/RetroPie/roms

Returns a list of all of the ROM system folders

Sudo nano /etc/rc.local


#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

sudo mount -t cifs -o user=guestread,password=MyRealPassword //192.168.1.139/osmc/roms /home/osmc/roms
mv RetroPie/roms RetroPie/roms.old
ln -s /home/osmc/roms /home/osmc/RetroPie/roms

exit 0

Reboot

Now

ls /home/osmc/RetroPie/roms

Returns ROM

Manually running

sudo mount -t cifs -o user=guestread,password=MyRealPass//192.168.1.139/osmc/roms /home/osmc/roms

and then

ls /home/osmc/RetroPie/roms

Again Returns a list of all of the ROM system folders

Thanks

Not sure who got you onto the idea of using rc.local, just at the Mount point to fstab.

Search the forum for “fstab cifs” and you should find enough hints