Location of Recordings and EPG question

Finally I have quality Live TV [from a HDHomerun tuner] on a Raspberry Pi3 thanks to OSMC. Tried twice before using LibreELEC with very poor quality.

I completed the setup of TVHeadend/Backend and have two issues.

  1. Selecting: OTA EPG and forcing an update, so far has not generated any guide information. I am willing to run a paid for service if needed, as long as question 2 is resolved.

  2. While my KODI Client on a Win 7 PC displays live TV perfectly, and if I tell it to Record, I get the notification it is recording and when I click the record button a second time I get the message it stopped. So far so good.

However, when I look on the Client for TV/Recordings that directory is empty. Right now the “Digital Video Recorder Profile” shows “/home/osmc” for the recording system path.

Being a good assembly programmer and proficient in windows still makes me a Linux moron, and I cannot "cd"or “ls -a” or “sudo” my way out of a wet paper bag to find where on earth the recordings are going. Every instruction on the web seems to leave out a critical step.

Ideally, I would want them to go to my NAS server but from what I have seen on the web the instructions to mount and direct the recordings to my NAS might as well be written in Klingon.

  • Look up /etc/fstab for mounting NFS or SMB shares on your NAS.
  • Point TVHeadend’s recording directory to this directory; e.g. /home/osmc/wurlitzernas

Thank you Sam.

I found a site which seems to give me a starting syntax for the /etc/fstab file.

Tomorrow, I’ll see if I can make it work.

I have a WD Mybook NAS so the path in the NAS is “\MYBOOKLIVE\Public\Shared Videos\HD Homerun”

You have given me a good start on this.

Thanks again.

If you search the forum for /etc/fstab you’ll probably find some good hints too. I think the MyBook shares via SMB by default.

Sam, I first created a sub-directory on the RPi “/mnt/MyBookLive”

I then did a sudo nano fstab which opened the fstab file without any problem.

To fstab I added a line at the bottom: MyBookLive:/Public/LiveTV mnt/MyBookLive nfs

Did a ctrl-o to write it then a ctrl x to exit.

I attached to the TVHeadend web page and changed the Record System Path to “mnt/MyBookLive” and saved that edit.

I rebooted the RPi.

I then opened KODI on my Win 7 machine and selected a OTA channel and it played perfectly, hit the record button in KODI and got the start recording message, let it record for a few minutes, then canceled the recording and received the canceled recording message.

I then looked at my NAS Public/LiveTV directory and it was empty.

At this point in time I have no idea where, if any place, KODI is recording live tv.

Can you spot where this noob is going wrong?


This line isn’t quite right.

Something like this:

IP-OF-MYBOOK-LIVE:/Public/LiveTV /mnt/MyBookLive nfs _netdev,defaults,user,auto,noatime,intr,x-systemd.automount 0 0

Avoid hostnames if possible too, use a static IP as it’s more reliable.

Thanks for the quick reply Sam, I really appreciate it.

I had tried using the IP in my original fstab which my first attempt failed without any success.

I then tried just a manual mount syntax I found on the web using:

sudo mount MYBOOKLIVE/Public/LiveTV /mnt/MyBookLive

And I got a Special Device MYBOOKLIVE/Public/LiveTV does not exist.

I then tried the same command using the IP address
sudo mount /mnt/MyBookLive

And I got a Special Device does not exist.

sudo mount -t nfs /mnt/MyBookLive

Yes ActionA I had entered “:/” but failed to show that in my post. Just a noob floundering.

I did get one syntax to work and it had something to do with not liking my “/mnt/MyBookLive” directory.

This works or at least does not generate an error [still doesn’t work for recording from TVHeadend].

sudo mount -t cifs -o guest // /mnt

Note: just used the /mnt directory and I got an error if I tried to put IPAddress:/Public…

So an apparent successful mount, albeit it, just a manual mount but if I set “Recording System Path” in TVHeadend to “/mnt” I still do not get any file on my NAS. I still don’t know where or if TVHeadend is recording as there is no error in KODI so I am assuming it is recording somewhere on the RPi.

Sorry for being such a linux ignoramus.

Well, yes, it must be cifs if you are sharing samba/smb and aren’t sharing NFS. NFS is a completely different sharing protocol and I’m not sure why you’ve tried to incorporate it here.

Then you need to address the file/folder permissions on the NAS side to specify who may or may not read/write the files shared from there. Maybe you must enable “guest” access there, I really have no idea how this is handled on MyBook…

Ok getting closer.

In fstab, I remarked out my first attempt to mount.

I added: // /mnt cifs guest, uid-1000 0 0

I then rebooted and checked the mounts using the df command and now see " with all the blocks, used, available and use% information. Seems we have a successful mount at this point.

I had set this directory on my NAS for sharing.

But now I am still left with no apparent recording from TVheadend.

Thank you ActionA and Sam for helping me on this. Seems we are just a step or two away.

Am I correct that the TVHeadend “Recording System Path” should be /mnt and not the path to my NAS?

I SSH’d into my MyBookLive NAS and set permissions in Public/LiveTV to 777 which when I do a ls -l seems to show full permissions.

I am still left with my KODI Live TV recordings going someplace but certainly not MyBookLive [using the IP address]/Public/LiveTV.

So close but no cigar.

It seems like the TVHeadend does not use the “/mnt” in the “Recording System Path”

Lets make sure I have the rest of that setting correct.

In the TVHeadend “Recording Parameters” I have

Enabled = Checked
Stream Profile = Pass
Cache Scheme= System
DVR Log Retention = 31
Extra time before Recording = 1
Extra time after Recording = 1
EPG Update Window = 24 hours
Post Processor Command = blank

Recording File Options:
File Permissions = 0664
File Name Charset = ASCII
Tag files with metadata = checked
Skip commercials = UN-checked

Sub-Directory Options:
Directory Permissions 0775
Make Sub-directories per day = Checked
Make Sub-directories per Channel = UN-checked
Make sub-directories per Title = UN-checked

Sam, don’t know if you have seen my subsequent posts to ActionA but it seems I have a successful mount at boot of my NAS and I have used SSH into MyBookLive to set permissions to the LiveTV directory to 777.

I also posted my current TVHeadend Recording Parameters as I still cannot find where or if any recordings are being sent.


I seem to recall when I tried to get LibreElec/RPi 3 to run TVHeadend and write to my NAS some discussion regarding the need to force the Mounting of the NAS drive prior to KODI/TVHeaded being launched. I have searched and searched but could not locate such a discussion.

Anyone know if this might be my problem and if so, how to force the mounting of the drive first?

Right now OSMC/TVHeadend is doing much better at Live TV then I was able to achieve with LibreElec/TVHeadend but I still need to implement a Record function to eliminate the need for my laptop running ServerWMC 24/7. Note: OSMC/TVHeadend is even working better than ServerWMC for Live TV.

If it would help, and if I could configure this [a real question], I’d be willing to just add a HDD to the RPi and hope I could get my 3 KODI clients to be able to read the HDD on the Pi.

Yes, you can do that.

But you should also be able to mount in fstab, and point TVH to that in the web interface.

If I understand you correctly Sam, I believe I have a successful Mount as a “df” command shows the MyBookLive NAS and what appears to valid drive information.

However, I still cannot get TVHeadend/backend to record anything or to be more accurate, I cannot tell if it is recording even though the Kodi clients say it is, and if it IS recording, I can not find where on earth it is writing the recordings.

Again, if it makes this easier, I’ll buy a RPi HDD and see if I can successfully record to it and have the Clients see it.

Thanks my friend for taking the time to reply.

You need to log in to the web interface, and set the recording path to the mount path that df shows. If recording is working properly, the directory will start to fill up with recordings.

Sam, the mount on the RPi is “/mnt” and I had set the TVHeadend “Recording System Path” to “/mnt” [without the quotes]. I believe my limited understanding of the mount process may be causing this problem but again I thought the fact that the “df” command showed the NAS as mounted was sufficient.

Sorry for being so thick.

Show us the output of df please.

Here is the line after a “df” command

//my nas IP address /Public/LiveTV 1941348672 386911360 1554437312 20% /mnt