Lock Preferences for SMB

I am using an Asus RT-N66U for NAS connected by cable to a Pi 3 running OSMC September 2017 update. There was no problem on my initial setup of the database, then one day last week it couldn’t access any of my media. When I tried to access the shared drives it asked me for username and password for smb shares. I had never set any up, but it became an issue between one viewing and the next.

I setup a new user on the router called pi with a password of pi and gave it full read/write authorization and tried that on the lock preferences screen with no luck. I then allowed guest users on the network to have full privileges. That DID work, and I regained access to my media…for a few days.

This afternoon, the problem recurred and I’m locked out of my media again. We watched a show and it worked, came back a couple of hours later and it asked for lock preferences. This system is not connected to the internet, so there was no unexpected updating happening behind the scenes. I tried re-adding the router as a media source, undoing and redoing the guest network option on the router, and re-added the pi:pi username/password as a user on the router. I then changed my password.xml to point to the ip as follows:

smb://192.168.1.1 smb://pi:pi@192.168.1.1

I’m at my wits end here. My PC and tablet can both access the shares, so I’m certain the problem is on the Pi’s end. And I’ve got a 3 year old who is very upset at being unable to watch Animaniacs, so any help here would be much appreciated.

1 Like

Have you tried to set the SMB protocol to SMB1 in settings?

BlockquoteHave you tried to set the SMB protocol to SMB1 in settings?

I have not. Would that be a setting on the router or the smb.conf file on he pi?

I guess your router only supports SMB1 so therefore you would need to force OSMC to do the same.
You can do that via the gui Settings -> Services -> SMB Client

Blockquote Settings -> Services -> SMB Client

I tried SMB1 & SMB2, but no luck.

Logs are needed then.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Thank you. Here is the log.

Please use OSMC log uploader either via GUI (MyOSMC) or grab-logs -A

That machine does not have an internet connection.

Ok, you still could use https://paste.osmc.tv/

Feeling like a noob, sorry. Like this?

That worked, but somehow no SMB errors visible in the logs, only thing I see is that you use DNS/Netbios names for the shares which some people has reported to have issues with…
You might need to enable “component specific logging” for SMB.
But to be honest I am not sure if it maybe easier to go for fstab based mounting of SMB shares which would make it easier and more performant.

If you don’t want to switch to fstab based samba share you also could try this

I’ve been messing with this all day. Adding the user.conf file did nothing at all as far as I can tell. When I tried editing the fstab file file, I added this line at the end:

//192.168.1.1/Movies /mnt/Server_Movies cifs x-systemd.automount,noauto,rw,iocharset+uft8,username=admin,password=admin,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

and then when I typed $ sudo mount -a I got an error that the mount “is does not exist.” It’s almost like it’s using bad grammar to tell me how dumb I am :slight_smile:

The particularly frustrating thing about this is that I made a system with identical hardware for my dad, and it just works. SO I can’t help but think there’s some user error, but the user is stumped.

Should be

iocharset=utf8

Thank you for the typo catch, Mount point still is does not exist. Does that imply there’s another typo in there?

The mountpoint will be automatically created.

Have you rebooted? You need to do that for the automounter to run.

Yes, I’ve rebooted. the full error that I get on mount -a is:
mount: /etc/fstab: parse error: ignore entry at line 2.
mount: mount point is does not exist

provide the fstab to us with cat /etc/fstab | paste-log

Did you add a single line to fstab, or 2 lines.

Please show your entire fstab file, easiest way is to

grab-logs -f

And share the link here.

Fstab file