Looking for information (future buyer)

Hi everyone!

Just a quick message to tell you that I received today my Vero 4K+!
It was very fast to deliver in France.

I’m not sure to have enough time to try it before this weekend…



I’ve just installed it and made the last update. The system seems to work!

But I’m lost for the next step.
If I understand, I don’t need Plex at all.
But how can I access to my files from the Vero?
Do I have to install something on my laptop?

I tried to share a folder from it, and then I tried to add a source in Vero.
I selected SMB, but nothing appears then, only “…” .

I tried to search answers, but I’m really lost!

You can install the Plex add-on and use that until you get a regular library sorted. As for browsing smb shares that is not possible with SMB 3 due to security related changes over the years. A good place to start would be to read through this thread and if you get stuck just ask a more specific question on where exactly your getting stuck.

Alternatively, there is a bit of a workaround that will let you browse with kodi links but it is only much of a benefit if you have a lot of individual sources. This method is to add your source device/s in a special file manually. You would ssh into your Vero and…

nano .kodi/userdata/passwords.xml

and then enter the following with your own information…

        <from pathversion="1">smb://</from>
        <to pathversion="1">smb://user%20name:password@</to>

To save and exit out of this you ctrl-x, y, then press enter. This adds your credentials for the machine your pulling the files from. If you have any spaces in your username they must be replaced by “%20” as shown above. You then need one more file…

nano .kodi/userdata/mediasources.xml

In this one you will need…

        <location id="2">smb://</location>

Then ctrl-x, y, enter, type “reboot” and hit enter. If you entered your information correctly you will then have a browsable path to that computer.

To get the best possible performance out of SMB you may need to use something like autofs - mount the SMB shares at OS level and then have Kodi treat them as if they were local folders.

See Mounting network shares with autofs (alternative to fstab)

1 Like


I had some time to try it.

First, I was suprised when I wanted to launch Vero, nothing happened.
I learned that I must don’t shut down it.
So, I can let it working all the time?

Then, I installed PKC. It was quite easy to follow the instructions you gave me.
All my files are now availble in Vero.
It seems to work very well, so I think I don’t need to try the other way to access to my files.

Now, it’s time for the problems! :wink:

I didn’t have any sound when I played a movie. I connected the optical cable, and it worked.
Are you sure I can have the sound just using the HDMI Cable?

Even with the Optical Cable, I have sounds problem.
With stereo audio, everythings work.
With 5.1, I can’t hear the voices (or very very low).
I tried to launch the same files in Plex from my PS4 (with the same HDMI and Optical), and I could hear the voices.
What do I have to configure in Vero?

The other problem I have is with the screen.
I have some black screens that appear randomly and quickly, in the menu or when the movie is played.
Is there something to do?

Thanks again!

Yes designed as a 24x7 device. If you want to you can use the Suspend mode (also trigger automatically via TV off) but not a must.

Yes, disconnect the Optical Cable and upload logs via MyOSMC -> Log uploader so that we can check capabilities of your TV/AVR

Did you read this article?

Sounds like a HDMI cable problem. Suggest to try another cable or maybe we can see something in your logs.

Here is the log :

I will do it.
I just tried to change the audio settings 5.1 to 2.0, and I can hear the voices.

Is there something different between the Vero and the PS4?
I’m asking because I use the same HDMI cable for both, and I don’t have any problem using the PS4.
During the tests I’ve just made, no black screens this morning…

So you have the Vero directly connected to your TV not a AVR? Then surely your TV only supports 2 Channels

CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48 kHz, 16 bit

Well question is when did you had black screens? If it was during resolution/frequency change (e.g. Movie start) then it’s normal. If it happen even if you navigate the menu then try enabling HPD Lock under Settings - > Display and rebooting.

No, it is not connected directly.
I have :
Vero 4k -> Receiver Sony STR-K880 -> Panasonic TX-75FX780

I had the black screens while navigatind and playing the movie. I will change the settings.
I don’t know if it is related, but as I read in another topic, I modified : adjust display refresh rate” to “start/stop”.

I don’t think your AVR has any hdmi 2.0 or hdcp 2.2, so you could better connect it directly to your TV and use an optical cable for the sound.

I can only find a service manual: http://sportsbil.com/sony/STR/STR-K/STR-K880_K900_v1.1.pdf

In future, @EdBangerRecords, you might also consider adding an Egreat H10 or an HDFury AVRkey to the system. These are devices that split an HDMI signal into separate audio and video streams, so you can send video to the TV and audio to the AVR.

I assumed a more modern AVR which is most likely causing the blackout issues. The sound should have still output if you had changed the settings in your AVR to come from hdmi instead of optical. The point is a bit moot as you will want to plug the Vero directly to the TV to allow for 4K output. Unless you decide to purchase a splitter to split off multichannel PCM (which you say is not currently working) you will want to use an optical cable from the Vero to the AVR and set the Vero to 2 channels and enable passthrough for AC3 and DTS (you will have to enable advanced or expert view in settings).

I understand that my AVR is to old, and I can’t use the HDMI for both video and audio.

So, I read the “Connecting up your audio setup & audio settings” topic, and I think my audio setting is : when connecting your OSMC device to your AVR/soundbar’s S/PDIF input.

I selected the different settings as explained.

I played a movie with 5.1 audio, and I can hear sounds from all my speakers.
I also tried a DTS Demo file, and again it worked well (speakers and subwoofer).

So, is there really a problem if I let everything like this?

From what I understood, i would need to change my AVR for a modern one.

Or you could do what I suggested three posts ago. :stuck_out_tongue:

I was thinking that if I am buying a new device, I might as well choose an new AVR…

Anyway, what would be the difference if with what I have I can hear sounds from all my speakers?

One of those devices would likely be a great deal cheaper. But if you’re planning on upgrading anyway, sure.

If the video has uncompressed audio (e.g. from a blu ray film) the sound quality would be better. Your amp and speakers might or might not be good enough quality for the difference to be easily audible.

A more modern AVR might also decode Dolby Atmos for a height channel (sound coming from above).

1 Like

For Stereo LPCM, AC3, and DTS, (and ignoring the audiophiles debate of jitter in TOSLINK) there is no difference in audio vs using HDMI. What audio over HDMI (using your current AVR) allows is more than two channels via LPCM which would allow the Vero to decode formats your current AVR doesn’t support and then send to to your AVR as a uncompressed multichannel signal that it does support. If this is worth the cost of purchasing new equipment, you have to decide for yourself.

1 Like

Do you have any other devices in your home that are accessing the files or is it just the PS4 and now the Vero.
If so, I would recomended getting a USB hard drive if you start getting into 4K remuxes with lossless audio.
If most of your sources are 1080p and compressed down from their original sources than it won’t matter much.
I just mention that because you sound like you may be at the begining of an eventual upgrade path.
I have all my UHD remuxes on a USB hard drive connected directly to my Vero and I don’t have any playback issues with video or audio.
I even have UPNP enabled so my boys can watch videos from the Vero’s USB hard drive on their Roku TV.

1 Like

Thanks everyone for your replies.

We watched a movie yesterday, and we were happy with the video and the audio.
So I think I don’t need to change something right now. I will wait a little, and will think about buying new AVR and speakers.

I have now my Vero (which replace the PS4), and another TV (wifi connected, no AVR).
So Kontrarian, I will think about your advice at the same time.

Regarding my black screens issue, I can give more information after watching a full movie.

After approx. 30/40 min, very short black screens started to appear.
20 min later, I would say they lasted 1 second.
Pause button, I unplugged the HDMI from the Vero, and plugged it again.
Then, we could watch the movie (1 hour left) without any problem. No more black screen.
At the end, when I closed the playing to go back to the menu, the screen started to “flicker” a lot. I had to unplug the HDMI cable again.

I would say the cable is not really the problem here.

This was with the Vero connected directly to the TV or though the AVR? I scrolled up a bit and found you posted a log and saw that you were running the UI in 4K which is problematic. Please note the following…

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty)
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.