Malfunctioning Vero 4k RF Remote


I’m having an issue with my Vero 4k RF remote. If I try to navigate, I get a few presses in then whichever direction key I pressed seems to get “stuck” and the UI keeps on scrolling and making the keypress click like a machine gun. It continues until I press another key.

So far, I have:

  • Replaced the remote battery
  • Done a power-off reboot of the Vero 4k
  • Plugged the remote receiver into the other USB port
  • Dismantled the remote - There is no obvious sign of damage or contamination

It didn’t do this when the Vero was new and I’m not sure if it coincided with one of the updates.

The remote may have got sat on a couple of times but there are no obvious signs of damage inside.

Is there anything else this could be other than a faulty remote and are there any more fault finding steps I should try?

Is it possible to buy a new remote?

Thank you.

Ideally don’t do that – as you may struggle to put it back together or cause some problems.

Did you try pairing the OSMC remote by holding Home and OK?
Is anything else connected via USB?

We removed the repeat filter recently and devolve that to Kodi now instead of eventlircd. Perhaps there was interference before but our repeat filter was catching it.


I hadn’t paired the remote. I just held down HOME and OK. The blue light stayed on for some time then went out. The problem hasn’t gone away.

There’s nothing else plugged into the USB.

I just tried plugging a USB extension cable in and moving the USB receiver 2 meters away from the TV and all the other gear. The behavior is slightly different now. The blue LED in the remote is lighting up with every key press and it isn’t lighting when the key appears to get stuck. It is missing the some presses though

What frequency is the remote please? That will help me narrow down which pieces of my computing or ham radio gear might be interference suspects

2.4Ghz – so unfortunately, quite congested!

If the device is not re-pairing, something is jamming it.

What would the correct behavior be if it does re-pair? How do I know if it’s successful?

You might find this answers your questions…

Thank you. I have paired it again successfully but the problem remains.

Is it worth trying a new remote? If this is an environmental problem I can’t fix, are there any third party remotes that might work better for me?

I’d say the odds of whether a new remote would work would hinge a lot on whether it ever worked well before and if anything recently changed in your environment.


The Vero has an IR sensor integrated, and supports CEC as well. If you have a universal remote laying around you can see a list of preconfigured remotes in the My OSMC add-on. Pick one of those, program your remote to that. It may be a bit less responsive than the rf remote but if you have a particularly noisy environment this may solve your issues.

It did work perfectly. I haven’t got any new 2.4 GHz gear in my environment but I live in a small terraced house so it could easily be something my neighbour has installed the other side of the wall. No other 2.4 GHz gear I have is misbehaving

In normal times I’d suggest trying it around a friend’s house.

We do produce and sell the remote separately but I don’t know if it will work for you (you could always return it).

Interference is rare and usually there has to be something like a keyboard receiver on top of the Vero itself for it to be noticeable.

I would feel really bad about buying something and returning it. I would feel like I was costing you money and taking advantage.

I put the receiver on a 2m USB extension and put it on the table, 6 inches away from the remote. It may be a little better but it’s still misbehaving.

Ive had the exact same problem the control seem to get stuck and keeps scrolling and is making the same machine gun noise. But for me it was a quick fix I replaced the battery with a new one and everything is working normally now

1 Like

This thread is three years old so I assume it’s resolved for OP.

But I suspect you stumbled across this when searching for yourself. The remote will behave a bit odd when battery is low. New remotes have a low battery warning indicator.

Yes Sam as you said I just stumbled on an old thread while searching new batteries solve a multitude of problems :+1:

1 Like

Everything from remote functionality to marriages…

Glad it’s solved.