Manual Update Not Working

Hello,

I have a RPi2 running OSMC 2016.01-2, and when I try to perform a manual update via Programs -> My OSMC -> Updates -> Manual Controls -> Scan for Updates Now, I receive an “Add-on Error, check the log for more information”.

Normally updates have been running fine on this install as I tend to update when prompted. The only difference this time is I said No to an update when prompted last week because I didn’t want to install Kodi 16 yet due to having a MySQL database. I then turned off updates within Schedule by setting “How often do you want to check for updates?” to Never.

Today as I am ready to upgrade, I first tried a manual update but received the above mentioned error straight away, and unfortunately I can’t get around it.

Looking at the Kodi log, the following is recorded when I attempt to update:

16:26:59 266.749786 T:1582560288 NOTICE: OSMC settings sending response, update
16:26:59 266.752808 T:1582560288 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<–
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <class ‘socket.error’>
Error Contents: (2, ‘No such file or directory’)
Traceback (most recent call last):
File “/usr/share/kodi/addons/script.module.osmcsetting.updates/resources/lib/call_parent.py”, line 18, in
sock.connect(address)
File “/usr/lib/python2.7/socket.py”, line 224, in meth
return getattr(self._sock,name)(*args)
error: (2, ‘No such file or directory’)
–>End of Python script error report<–

Thanks in advance!

I think today not only the Update functions of OSMC has a problem but also the search function of this forum seems not to work anymore :frowning:

Sorry guys, I did do some searching before hand but none of them revealed your linked topic.

I used the following terms, browsed the top few results and tried some of the suggestions, but none seemed to work. It makes sense that the suggestions didn’t work now that I know it’s a leap year bug. :slightly_smiling:

“update”
“update not working”
“IGNORING THIS CAN LEAD TO MEMORY LEAKS”
“No such file or directory”

I can see why my searches didn’t work though (having just checked again), the default search option is Relevance which didn’t show any of the recent posts on this topic, and changing this to Latest Post reveals the one you linked to.

I’ll definitely use the Latest Post option next time.

1 Like

I have the Same problem: i also try to perform a manual update via Programs -> My OSMC -> Updates -> Manual Controls -> Scan for Updates Now, I also received the same message: "Add-on Error. Cannot update

Thanks but we are well aware of this problem as the many, many threads on the topic will show, including the one you just replied to.

The problem will resolve itself tomorrow.

3 Likes