March 5th update broke xbox DVD dongle

i will try that!

thank you k0usi it worked for putty

here is my dsmeg

(dsmeg osmc - Pastebin.com)

i have found this line

[ 5.065586] usbcore: registered new interface driver xpad
[ 5.067741] lirc_dev: IR Remote Control driver registered, major 243
[ 5.117329] lirc_xbox: module is from the staging directory, the quality is u nknown, you have been warned.
[ 5.118732] lirc_xbox: module is from the staging directory, the quality is u nknown, you have been warned.
[ 5.119154]
lirc_xbox: XBOX DVD Dongle USB remote driver for LIRC $Revision: 0.01 $
[ 5.119158] lirc_xbox: Jason Martin austinspartan@users.sourceforge.net
[ 5.119246] lirc_dev: fops pointer not filled in!
[ 5.119287] lirc_xbox[5]: inbound endpoint not found
[ 5.119331] usbcore: registered new interface driver lirc_xbox

and it is about the same in k0usi’s log

I have the same issue, using a Harmony 950 but my context menu buttons do nothing, normal buttons, play pause etc work ok

When you say it’s the ‘same issue’. Are you using an Xbox dongle?
If not – then the issue is not the same

1 Like

any hints sor far?

by the way thanks you for helping

I use the original XBOX dongle modded and connected to the usb ports, been working for a couple of years, still works in the sense normal commands work, play, pause, FFWD etc.
Remote is a Logitech Harmony remote but it simulates a original XBOX remote. XBOX remote is selected in OSMC, whatever I select say Apple remote etc, it still works the basic commands.

February 2018 update issue - #2 by hal8000 is my own post

I think I’ll just reinstall and then avoid updating for a while.

Ah good, I’m not the only one with this issue. :slight_smile:

Luckily my CEC seems to be working fine so the remote isn’t useless. I lose some functionality not being able to use the xbox IR but I’ll survive. Subscribing just in case a resolution comes of this.

I’m a baller on a budget, so I’m still using a large CRT TV with an RCA to HDMI converter, so no CEC for me :’(

Thank goodness for Kore

Nevermind, I just ordered another nVidia Shield, later virgins!

But if anyone tries to fix this problem, let me know I’ll still provide info, or that $25 to sam

Yes I have the same issue after the most recent update my original Xbox DVD dongle and remote do not operate at all. I have been trying to read on the web any changes that may have been made. I did see on another software platform that they said “It looks like the kernel detected the dongle but didn’t load any driver” and the “lirc_xbox driver was missing”
Has there been any changes to LIRC in Kodi?

Hi,

I had a chance to look at this today. The lirc_xbox module hasn’t been updated since 2012 and I’ve been maintaining it downstream out of tree for several years. Not many users use this module anymore.

Hopefully the issue is now addressed with the following commit:

Unless the original maintainer comes back to maintain the driver; this is the last update it will receive. This means it should work for the next year or so, with support ending in March 2019. After this point, I won’t be able to trivially update and maintain it as it will have fallen far behind from the V4L2 stack.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Sam

Followed your instructions and after reboot I can confirm it is working.

Thanks Sam! Offer still stands to send you money!

Thanks for confirming that things are working as expected.

If you want to contribute to the further development of OSMC, you can make a donation at About - OSMC.

Cheers

Sam

There was no option to take the $33 and put it into singles and stick it into your waist though. #broken Please fix this

1 Like

Sam

Hopefully this will work for me as well. You mention support ending, so instead I need a different remote receiver (??) or turn the HDMI CEC back on and use that.

Next year, you’ll want to pick up a TSOP receiver. These are about a dollar and can sit on the GPIO of your Pi.

Hi Sam,

Its not a simple a purchasing a TSOP receiver. This normally means cutting a hole in PI case (depending on case) and it looks downright ugly.

In addition, the feek of the xbox remote is much better than any other remote I have tried (and I have tried lots) and the ease of choosing the remote in OSMC is much simpler that other distributions (that I wont name).

Please, please, please dont give up on the Xbox DVD remote as we are a small but loyal group :slight_smile:

Thanks

Unfortunately I don’t really have a choice. Using a TSOP would let you continue using the Xbox Remote.

Sam

Thanks Sam for the March update my xbox DVD remote is working fine again. I have also placed an order for a TSOP31256 (xbox remote uses 56KHz carrier) I will try that out too, ready for a years time :slight_smile: