March upd broke fstab mounts

Recently updated from december update, all my fstab mounts now have failed:

all i see in systemd log is

Mar 16 19:48:56 osmc systemd[1]: Dependency failed for Remote File Systems.
Mar 16 19:48:56 osmc systemd[1]: Job failed with result ‘dependency’.

Make sure that your mount point still exist. And you should really move them to /mnt instead of in your home directory.

If the mount points exists, what happens if you run from command line:

sudo mount /home/osmc/peliculasnfs
1 Like

You should enable “Wait for network” in My OSMC > Network.

You might want to slim down your /etc/fstab entries. Some of the options are probably unnecessary: will be taken care of when you enable “Wait for network”.
intr is deprecated after kernel 2.6.25.
nocto Are you sure you need this?

1 Like

the mount point exists, i’m not going to move them as kodi appoarently likes media on its home folder.

the “wait for network” is already on from long time ago.

the was added because of the bug that plagued OSMC that some update broke the unmounting on poweroff and forced you to watch a 1:30m timeout before shutting down.

nocto is because i’m opening files that will never change.

if i run “sudo mount /home/osmc/peliculasnfs” then the target is mounted correctly and i can see the content.

edit: after a reboot the peliculasnfs mount point worked, but the seriesnfs does not mount, even after the sudo mount thing

editr2: the systemd log is still full of errors 32 on both mounts

Interesting, you seem to be the only person who seems to have that problem… I have 4 NFS mounts and none of them are in /home/osmc…

I think that problem was resolved some time ago.

Then just use ro instead of rw when mounting. But that’s shouldn’t matter.

And what happened when you did the sudo mount thing?

The log shows no mention of it being enabled, which is why I suggested that you enable it.

What’s the output from running systemctl status connman-wait-for-network ?

1 Like

interesting because i just checked and the checkbox IS set for wireless(not set for wired, i set it just to be sure)

this is the result:

  • connman-wait-for-network.service - Wait for Network to be Configured
    Loaded: loaded (/lib/systemd/system/connman-wait-for-network.service; enabled
    Active: inactive (dead) since Sun 2018-03-18 19:33:30 -03; 3min 35s ago
    Process: 278 ExecStart=/bin/bash -c if grep -q nfsroot /proc/cmdline; then exi
    Main PID: 278 (code=exited, status=0/SUCCESS)

Then just use ro instead of rw when mounting. But that’s shouldn’t matter.
i’m already using RO

And what happened when you did the sudo mount thing?

it works for both sources, but on reboot one is lost

That is not what you said before!

So I ask again, what happens if you manually mount it?

it is what i’ve said before some 3 posts ago!.

after doing the esudo mount manually that you told me, ONE source(peliculasnfs) appears to have fixed itself, it mounts and PERSISTS on a reboot. BUT the other one does not(the manual mount works, but it’s lost on reboot).

I ended up removing the mount point, deleting te folder, recreating it and rebooting, now they BOTH work

Ok so it was a problem with the mount point. So I’d suggest that you move the mount points to /mnt to prevent this from happening in the future.

1 Like

A post was split to a new topic: September 2022 Update Broke fstab mount to SMB Server