MCE remote button press lags

I have updated to the buster builds before GA and my Vero4K+ was affected by the LIRC bug that has been fixed a few days later.

Since then the mce keys are working again, but a few days later i have detected a severe lag for the key presses. Shortly after booting everything works as expected, but than a few seconds later the UI responds seconds after the keypress or not at all and i have to press the key (for instance the basic direction keys) again.

Also after updating to GA the problem persists.

We haven’t updated LIRC since that confirmed fix. The version you tested there is the version that we shipped.

I suspect something else is at play. Some logs may help.

Hi Sam,

i will upload the logs. Btw. how can i check if the external IR receiver is detected and used by the OS?

This is done opaquely at a hardware level. The OS won’t be able to detect it.

I have updated the Harmony remote and hub firmware, but this has not changed the situation. I also have checked if the IR extender is plugged into the outermost port. This has also not changed anything.

Here are my logs

They seem to have similar problems…

CC @DBMandrake

Which device did you record your LIRC profile on?
Have you tried this on the stock OSMC release? I see you’re using the 4.9 kernel which introduces more variables.


I’m using a Harmony Remote and the activity uses

  • CEC with the Sony TV for some buttons
  • MCE Keyboard for some buttons
  • MediaCenter PC for some buttons

The CEC buttons are working fine and also all other activities (Netflix on the TV itself and an XboxOne X) are working fine on this remote. Before the OSMC updates i had no LIRC problems in OSMC too.

I have not recorded the profile. I have just selected the rc6-mce-lircd.conf from the MyOSMC app. Later i have just fixed some small errors in the out of the box profile, but this has not fixed the problem.

Based on what/ The first post you linked to did not provide any information on what remote they were using (most like a OSMC remote so wouldn’t be related) and the second post as to do with tweaking a custom lircd.conf so again, not related to your situation.

I don’t know what is going on with your system but I can tell you that I have tried and can’t reproduce any issue with a harmony remote using “media center PC” and the rc6 conf on a Vero 4K using the front IR. Have you tried unplugging the IR extension and tested with just the built-in sensor?

I get why you would combine one of them with the CEC on a Harmony but either of those by themselves should have enough buttons to cover any extra functions you would want to add. Why are you using both of these?

I use some CEC buttons to let the TV decide when to turn off for power saving reasons. With the MCE Keyboard combined with the MediaCenter PC buttons i can avoid tweaking the LIRC settings or the KODI remote mappings.

I have unplugged the IR extension and it has not changed the behavior. Is the internal IR receiver active if the extension is plugged in? Maybe the extension is just dead and the remote is not working properly because the Vero is inside the TV cabinet. The IR extension is on the top of the cabinet nearby the DAC. Btw. the DAC is working fine with the Harmony remote configured in the same activity…

I don’t have one myself to test, but i’m pretty sure i’ve read that the internal one is always active. I was thinking that signals from two sensors might have been causing an issue but apparently not.

They will cancel out (you can’t get duplicate presses).

hi, i posted the first problem and i plan on adding logs as soon as i find time…
But yes, i use the OSMC remote. The description is pretty similar with this post but in my case a restart does not fix the problem.

The OSMC remotes don’t run through lircd so it is unlikely to be a pretty similar issue.