MCE Remote not working after December Update

After the December update, my Harmony Remote stopped working.

I have the MCE USB IR Receiver. It’s model is “Microsoft 1039”, and is the same one I’ve used for many years with the Pi/Raspbmc/OSMC.

When I reboot the Pi, it’s not even loading the USB IR receiver:

osmc@osmc:~$ irw /var/run/lirc/lircd-lirc0
connect: No such file or directory
osmc@osmc:~$ ls /var/run/lirc/
lircd
osmc@osmc:~$ lsmod
Module Size Used by
8021q 22870 0
garp 7558 1 8021q
stp 2430 1 garp
llc 6031 2 garp,stp
nf_nat 19472 0
nf_conntrack 110806 1 nf_nat
iptable_mangle 1934 0
iptable_filter 2212 0
ip_tables 13649 2 iptable_mangle,iptable_filter
x_tables 23831 3 iptable_mangle,ip_tables,iptable_filter
ipv6 456416 48
osmc@osmc:~$

and lsusb yields:

osmc@osmc:~$ lsusb
Bus 001 Device 004: ID 0471:0815 Philips (or NXP) eHome Infrared Receiver
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

So I force load mceusb:

osmc@osmc:~$ sudo modprobe mceusb
osmc@osmc:~$ lsmod
Module Size Used by
ir_lirc_codec 5647 0
ir_rc6_decoder 3447 0
lirc_dev 10631 1 ir_lirc_codec
rc_rc6_mce 1560 0
mceusb 12121 0
rc_core 26883 6 mceusb,ir_rc6_decoder,rc_rc6_mce,ir_lirc_codec,lirc_dev
8021q 22870 0
garp 7558 1 8021q
stp 2430 1 garp
llc 6031 2 garp,stp
nf_nat 19472 0
nf_conntrack 110806 1 nf_nat
iptable_mangle 1934 0
iptable_filter 2212 0
ip_tables 13649 2 iptable_mangle,iptable_filter
x_tables 23831 3 iptable_mangle,ip_tables,iptable_filter

and now when I run irw, I’m getting repeats:

osmc@osmc:~$ irw /var/run/lirc/lircd-lirc0
000000037ff07bdf 00 KEY_LEFT mceusb
000000037ff07bdf 01 KEY_LEFT mceusb
000000037ff07bde 00 KEY_RIGHT mceusb
000000037ff07bde 01 KEY_RIGHT mceusb
000000037ff07be1 00 KEY_UP mceusb
000000037ff07be1 01 KEY_UP mceusb
000000037ff07be1 02 KEY_UP mceusb
000000037ff07be0 00 KEY_DOWN mceusb
000000037ff07be0 01 KEY_DOWN mceusb

I think I’ve messed around with the lircd.conf files so much that I’ve confused myself :frowning: Tried many of the proposed solutions suggested in the forms like picking individual remotes, swapping USB ports.

So my question is:

  1. How can get mceusb to automatically load and not force it by modprobe?
  2. How can I get rid of the repeats?

Full Logs are here: https://paste.osmc.tv/owupapayil

Thanks,

Mandr

I stopped using the IR receiver and just changed my Harmony remote to use the TV remote through the CEC commands.

Hello
I have the same issue but your solution is not a global solution, it’s juste a workaround for you !

Have you any command to check and debug lirc remote.
A clean install of osmc work with my configuration so that’s not an hardware problem.
How to check lirc work ?

Thank’s

Same remote?

Try enabling the RC6 decoder in My OSMC.

I have already try this but not working
I don’t know how I start my investigation.

I think there is a command like irw that show on ssh the command but i can’t remember the correct commant.
The lirc log see nothing

The IR worked perfectly before update

You have to stop LIRC for this to work first.

Nothing changed in this update, re IR. So if you updated from November, it’s unlikely to be an issue with OSMC.

I have update from August

sudo systemctl stop lircd_helper@lirc0
osmc@osmc:~$ sudo systemctl start lircd_helper@lirc0
Job for lircd_helper@lirc0.service failed because the control process exited with error code.
See “systemctl status lircd_helper@lirc0.service” and “journalctl -xe” for details.
osmc@osmc:~$ journalctl -xe

– Unit lircd_helper@lirc0.service has begun starting up.
Feb 03 15:30:30 osmc sh[1375]: /bin/sh: 1: /var/run/lirc/lircd-lirc0.sh: not found
Feb 03 15:30:30 osmc systemd[1]: lircd_helper@lirc0.service: Control process exited, code=exited status=127
Feb 03 15:30:30 osmc systemd[1]: Failed to start lircd remote support.
– Subject: Unit lircd_helper@lirc0.service has failed
– Defined-By: systemd
– Support: Debian -- Support

irw /var/run/lirc/lircd-lirc0
connect: No such file or directory

Hi,

Sounds like you may missing packages. Try checking for updates again, if that doesn’t fix; please provide logs.

Thanks Tom.

update say nothing to update
I will try to restore backup and re-update with a new SD Card

I have restore my backup and restart update
download update ok but error on package : it’s say : report error in forum
So that’s the same error I will have with other sd Card

what happend ?
what log do you want ?

grab-logs -a

https://paste.osmc.tv/rolozipawa
it’s the August version that’s update won’t start

This log indicates no attempt to update since September. Are you only trying to update from MyOSMC? Have you tried running

sudo apt-get update && sudo apt-get dist-upgrade?

1 Like

I have made backup from August
Yesterday, i have try to update with myosmc with this result so i have try sudo apt-get… and i have passed osmc to december version but IR don’t work.

I can test all of you want to start lirc again

I will restart update again with apt-get and so on

>  Setting up rbp2-image-4.9.29-10-osmc (10) ...
> 
>  Hmm. There is a symbolic link /lib/modules/4.9.29-10-osmc/build
>  However, I can not read it: No such file or directory
>  Therefore, I am deleting /lib/modules/4.9.29-10-osmc/build
> 
> 
>  Hmm. The package shipped with a symbolic link /lib/modules/4.9.29-10-osmc/source
>  However, I can not read the target: No such file or directory
>  Therefore, I am deleting /lib/modules/4.9.29-10-osmc/source

Progress 91% mysql update is slow…

Thanks for the reminder. That’s just a warning which I’ve now removed.