Menu and media more black after April update

#1

Hi guys,

I have a bit of an odd issue since the April update. When I first boot OSMC things look like this on the main menu:

However, after playing the first item (no matter what length), it looks like this:

As you can probably see, there appears to be a lot more black in the menu, and I am not sure what the correct amount of black should be. This state is preserved until the next reboot of OSMC.

Besides the above behaviour, while watching a serie (even if its the first one), I also noticed that the amount of black might be too much, as i gets to the point that details in darker scenes are not visible.
When I checked the same file, but played with VLC on a Windows machine using the same display, the amount of black seems to be correct, as background details in dark scenes are still visible (Although, I did notice some banding)

Is this something I can fix somehow?

In case they can be of any assistance, I have uploaded some logs:

https://paste.osmc.tv/lobedufavu

Skin/interface much darker after april update
#2

hi, it happened to me, also
try to change the skin and then revert it
after that it should look fine

#3

That did not do anything in my case. It seems that only a reboot changes the colours to be less black for the interface (until any media is played).

Issue of the media being to dark remains as well.

#4

Can confirm this symptom as well.

Pi 3B* and Vero4k connected through AVR to same HDMI input of Panasonic TV.

  • The TV’s input HDMI RGB type is configured as “Full”.
  • Pi3B+ pixel encoding ist set to “Full RGB”
  • Vero4k, settings->system->video->use limited colour range is OFF, rest is default
  • Screensaver is OFF on all devices

After restart both devices looks nearly the same switching the AVR’s input.
After playback on the Vero4k the menu on the Vero4k looks more dark compared to the Pi3B+.

If I configure the Pi3b+ to use “Full YCbCr” pixel enconding, I get the same dark ambiente like displayed on the Vero4k.

#7

If your Panasonic is like mine, you can only set full-range for RGB. YCC is always assumed to be limited range. So on vero you should set limited range and output YCC. On the Panny, best to set ‘auto’ for the RGB range setting.

I thought Pis always output RGB but again if the Panny RGB range is set to auto it should be fine.

1 Like
#8

Set limited range output.

#11

So, can confirm: Setting the “use Limited Colour Range” at Setting->System->Video solved the issue, here. :+1:

1 Like
#12

Confirmed here too, thanks!

I have never fully grasped how the setting actually works, apart from limiting the amount of colours. I have an LG OLED tv, so I am guessing it can do full colours when in some form of PC mode(a feature thats probably hidden under a silly menu)?

Would I actually notice any difference, or is it fine for video content to be ‘limited’

Thanks!

#13

All (nearly all) video is distributed as limited range so there is really no point in coverting it to full range and you would not notice a difference if it was. Full range output is only necessary if you are using a PC screen which can’t accept limited.

#14

So I tried all options mentioned and some more like re-adjusting the settings of my TV (a Sony Bravia by the way) but nothing seems to make it any better. I’ll keep to this thread if I may because after watching some content I do believe the output signal is overall darker. As said before, the Interface looks perfect when playing HDR content. I’m now thinking maybe something went wrong when installing the osmc image this morning so i am inclined to do a total fresh install if nobody has any other ideas?

#15

Great! Thanks! No further weirdness to report regarding the update then ! :slight_smile:

#16

This is unlikely. If something was wrong with the installation you would see other issues.

#17

OK. Well other question. I had an electrical problem at home a couple of weeks back and it has cut of the power a couple of times repeatedly in a short period of time. I know this affected my vero 4k because after that it really had a problem to restart. But after a while it came back to life and had no problem since. But could something happen to the Emmc which now is causing a problem?

#18

I’d suggest that you start a new topic as this question has nothing to do with this topic. And make sure that you include logs.

With that said, I live in a rural area where power cuts are very common, probably several times a month, sometimes just quick blinks, sometimes minutes/hours and my Vero 4K still works flawlessly, so it’s unlikely that the eMMC is an issue.

#19

I am sorry but it has to do with this topic. I am trying to rule out any other problems that could be responsible for the darker interface. Hence this question.

#20

If you had filesystem corruption, you would be having far more problems. Posting logs may help us see the problem.

#21

Yeah sorry. I already posted my logs in a topic I opened today but then realize it was similar as this one.