Skin/interface much darker after april update

First of, thanks for the update. Everything seems to work really well. But I noticed that the interface ( I am using the osmc skin) is much darker. I did not change anything in my tv settings but I can’t set the picture brighter. I noticed that when I play a 4k film with HDR and scroll through the menu the interface is much brighter but when I stop the video it reverts back to 1080P and is really dark again. I did a clean install today on the vero 4k.

Here are my logs:

Anyone has any idea what could be wrong?

I think I might be experiencing the same issue:

Apart from that, the media being played also seems to be affected somehow, in the way that dark scenes seem to be TOO dark, and details get lost in the black. I havent played with any tv settings however.

Have a look in Skin Settings - Colours. I find setting background opacity Highest corresponds to what I used to have on v17. YMMV of course.

Yeah I saw your thread but I don’t think that my media is any darker just the interface but I didn’t watched anything to be completely sure.

I will try this and get back to you.

I tried this but it makes no difference. Yes it will change the background somewhat brighter but the font and miniatures stay dark. To dark.

Also tried to toggle the limitid color range but that makes no difference as well.

Make sure to reboot after toggling limited colours, seems to have sorted the problems I had.

OK will try. Thanx

I know this thread is more than a year old, but this was the solution for an issue I was having and it was one of the few threads not specifically talking about HDR when I searched for ‘dark’.

I was also seeing a brighter screen when the Vero first booted up, but after a while, or after I played a video, it got significantly darker. A reboot would fix it every time.

I toggled limited range ON in the Vero’s settings and rebooted, as @Warstomper pointed out, and, now, everything stays at the correct brightness through reboots and video playback. Thanks!

Thanks for the report. Full range should not be used unless you are playing on a monitor that doesn’t support limited range.