Missing center channel with OMX player

I just installed OSMC on a spare Pi to see how it compares to LE. As with LE, I find that there can be random loss of the center channel (my AVR is a Marantz NR1603) if OMX player is enabled. Here is a log of a playback with the problem:


The problem occurs with the official build of OSMC as well as the latest test build with the latest linux kernel, and as mentioned, with LE as well. The behaviour is not title-specific, sometimes playback of a given title is fine, sometimes it’s not.

Not a big deal perhaps as disabling OMX fixes it, but that does I think increase the CPU load, and in some settings, OMX can have better de-interlacing performance (though it can go wrong, as I’ll mention in another thread).

This has been a long-standing issue for me with the Pi - is OMX support still available? Would be nice to know what’s going wrong.

Is your audio configured correctly?

Can you be more specific? I’m an experienced Kodi user and know most of the usual trip-points. All aspects of playback (channel mapping, frame rate etc) are perfect if OMX is disabled. Enabling OMX leads to random loss of center channel. I’ve observed this with regular Dolby Digital, Dolby True HD and DTS-HD.

Passthrough is disabled, everything is PCM.
Setting Output configuration to either Best Match or Optimized makes no difference.

I’ve also noticed that issue since the last January update.
Before that it was working just fine.

The turn around I’ve found was to disable omx :frowning: