Missing German keyboard and Umlauts again

Just installed the latest OSMC build which is from 23rd of June 2019.
I’d like to add that in an earlier build from 2018 my German keyboard worked just fine, by configuring it from the regional settings menu within OSMC.

Now my German layout and especially the Umlauts are gone again. I tried all possible options from the settings menu, then also different install and configuration commands from the console - nothing.

The latest related post I found is this one, however the steps described in there also don’t work for me:

Any advice?

It’s nowhere near the regional settings: System->Input->Keyboard.

Thanks grahamh, you are so right. Changed it there and all is well :slightly_smiling_face:

There is still one thing that confuses me though, and likely what lead me towards the wrong path:
If that is all to be done, what are the following settings still for?
Settings > Interface > Regional > Character Set
Settings > Interface > Regional > Keyboard Layouts

Those are for what you see on the screen - characters generally and the on-screen keyboard.

Perfect - noted.
Thanks a lot.