MKV files missing chapter markers after added to library

I rip bluray mkvs that contain chapters however I noticed chapter skip hasn’t been working nor are they listed under bookmarks OSD. Its very strange because if I play mkv though file browser it works fine but if same file is added to movie library it doesn’t work. It’s so strange. Works fine on my Mac at least with local files.

I have Vero V with mysql server running on Synology NAS. Here is log file where I play mkv file from library and then from file browser stored in different folder on same NAS. Can you see anything in log?

I did run latest update after posting log. No change in behavior. Appreciate anyone that can help point me in right direction. Thank you.

The chapters are being read as can be seen in the log. Can you switch the skin to Estuary and see if they show there?

I’ve tried the Estuary, OSMC skin and aeon nox Silvo with same result.

Is there a cue file in the same folder as the video? If so that would override the chapters even if the file was empty in which case no chapters would be shown. If you play a regular film from your movie library that has chapters do they show up on that?

On an unrelated topic you might want to make an additional change to your advancedsettings.xml file…

No cue files in folder. Only poster, fanart, and nfo file. Could nfo cause issue?

Thanks for tip. I used to have this to hide eaDIR files years ago but for some reason removed it or lost it. And I have noticed scrapping is slow so I will try adding that back.

I don’t know. You could read through the nfo file for this movie your testing with and see if there is a relevant tag. They are just plane text xml. I suspect not though as they are only used for scraping and as far as I know chapter markers are not stored in the database but just read anew when the file starts playback.

Did you look to see if the problem is all types of movies or just music stuff? Knowing that may help narrow things down.

Oh sorry. It’s all movies. I created a new folder with movie file without nfo file and scraped. chapters didn’t work. renamed movie file and tried playing from files browser and still chapters didn’t work. Moved same file to a folder that isn’t added to media library and played file and chapters work.

Its not making any sense to me.

I can’t think of any setting that could cause this behavior but if you wanted to gut check with a ‘is it Kodi or something particular to me’ you could try stock Kodi temporarily.

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

I thought maybe it was something to do with mysql database so I deleted my advanced settings and restarted so nothing was in library. played video with chapters fine. then added folder to library and tried playing same video and chapters didn’t work. I will try what you suggested next.

So I tried reseting to default settings. Scraped folder to library and chapters worked.

Then added my advanced settings file and tried same movie and chapters didn’t work. Here is what’s in my advanced settings.

<?xml version="1.0" encoding="utf-8"?>

So maybe database corruption then? I think the next step would be to remove the temporary .kodi we have now, move back your original .kodi and then edit advancedsetting.xml to change the <name> tag for the video database to something other than what it is currently so it makes a new video database and see if that gets you to a happy place. Your sources should still be intact, but you will have to do a “set content” on them as that information is stored in the database. Additionally if that works you might want to delete texture13.db and the Thumbnails folder before rescraping your library just so your not taking up a bunch of room on abandoned files.

And as a side note, you don’t need that import watched state anymore as they changed the default to import with Kodi v20.

1 Like

I tried changing database name but it didn’t work. Then I tried repeating steps last time it worked and it seemed like files that worked during test no longer worked. Some files showed chapters and some didn’t. Decided to start fresh today.

Now it seems issue may be related to using NFS share. I added folder via NSF and none of the videos had chapters. Then I added same folder via SMB and all the video had chapters. Can you think of anything to do with NFS setup that would cause this issue? I have attached some of my Synology NFS settings screenshots.

How odd. It wouldn’t be anything to do with your NFS server settings, if this is what it is doing it would be a Kodi bug. I suppose if you wanted to retain your old setup and work around the issue you could just make a system mount and then add a path sub to redirect from the nfs path to the mount point. Guides for the two processes can be found at the following…

1 Like

Thanks for suggestion. If I didn’t want/need to retain my old setup would you suggest something else?

I’d personally would just switch to Kodi SMB paths to keep things simple wherein you can setup a new client by just adding an advancedsettings.xml and it works regardless of what OS your running Kodi on. A NFS system mount will offer a higher transfer rate, but if SMB is already fast enough, then that doesn’t really gain you anything. On top of that you can still use a system mount on any particular client if need be with what I posted above. My main thought of using the existing setup though was more about assuming that would be preferable to modifying all your Kodi instances since changing the sources would need to be done on all clients so they match and you don’t wind up with a bunch of duplicates in you library if you update on more than one box. You would also want to dump the Thumbnails folder on all these clients as well as texture13.db as building a new library is going to abandon the old cache files. Switching the library so the sources point directly to a system mount would be okay if you only have a couple OSMC clients but is kind of a pain if you also want to run Kodi on Windows or Android as well since you can’t setup the same system mount there.

Thanks I might try that. I only use two clients and was pretty much redoing them anyway since I got new Vero V’s. The system mount instructions were a little confusing for me. I remember moving away from SMB to NFS years ago for some reason but can’t remember why.

What about mySQL server? Is that still best approach if I am trying to sync watched/resumed states?

I think the system mounts sound more complicated than they are. If you had a non-plus 4k with the 100 Mbps networking you might have moved to NFS as Kodi SMB paths could struggle with larger files on that slower connection. It can help with wireless setups as well.

I personally think it is. If you run independant that means you have to update the library for every client and rely on an add-on to sync watched status. It also means that you can make edits on one and not have to remember to do the same on other boxes. Something minor like fixing a mismatched movie can get really annoying when you doing it more than once in more than one location. I also rather like the freedom of just tweaking things in Kodi on my PC and not having to tweak anything in the library on my players themselves.

it’s a long standing issue with kodi, uncheck show hidden files in kodi settings

Your saying the show hidden files option affects if chapters are shown during playback?

sounds crazy i know, try it and see