Monitor resolution wrongly recognised


I’ve just received my Vero 4K Unit today,

The reason I am posting here it’s because OSMC on Vero 4K isn’t recognizing my monitor properly.

I have a DELL 24’ which has a native resolution of 1920x1200.

It’s being recognized as 1920x1080.

The funny thing is that my Rpi 3 running OSMC does recognizes my monitor resolution properly.

I wonder if someone else encountered this issue?

Please, let know. I have already power down everything to start anew and it did not work.


Post the output of
cat /sys/class/amhdmitx/amhdmitx0/disp_cap


Sorry for the delayed response.

The output from this command it’s an empty one.

I think you need to run sudo -s before running that command

Sorry. I found that very odd myself.

I went to my laptop. powered down everything.

And here’s the output of that command line on vero 4k:


As I mentioned on my first post. I have a Raspberry Pi3 running OSMC on this same monitor that does recognizes the correct native resolution of my Dell monitor. 1900x1200.

Suggest to connect the pi to the screen and provide the URL of grab-logs -A

This is the output of this command line:

grab-logs -A
Logs successfully uploaded.
Logs available at

But it appears to be an empty url. I don’t know what went wrong.

Yes there should be a combination of numbers and characters behind the address

I ran dist-upgrade and now it is working.

here it is:

hope that helps. I believe if the rpi3 settings were merged to the Vero 4k it will work. All my PIs (running OSMC or others distros) always recognized my native monitor resolution properly.

Your monitor appears to be advertising 1080p60Hz as it’s preferred and supported mode, which is why this is being chosen.

Currently, Vero 4K doesn’t support the 1920x1200p mode as this is not often found. I can add support for it but I cannot remember off the top of my head if additional work is needed to make it work with Kodi.


Hi Sam,

It is not a TV. It is a Dell UltraSharp 2408WFP monitor.

Please, do. I intend to use Vero 4k on this monitor. I needed a HEVC capable device on it.

Like I said before I have been running OSMC (On this monitor) since it was called Raspbmc (Rpi B+ in 2014), Rp2 and Rp3 and all version recognized my monitor properly.

Yes – I’m aware it’s not a TV. Not many of our users are using monitors.

They are different platforms, which explains the difference.

I will add support for the monitor, but you will need to test it and let me know if it works as expected.

Don’t worry. I will report it.

I understand that I have to help you. I am perfectly fine with that.

I had a look at this today. Support for VESA modes was included previously:

The problem here is that they are only 60Hz modes. This wouldn’t be very smooth for video playback and you wouldn’t be able to take advantage of the ‘Adjust Refresh Rate’ option. This would give you motion judder, particularly on panning shots.

It doesn’t look like your display supports anything other than 50Hz or 60Hz, which doesn’t make it very ideal for watching video.

I will look at reincluding these modes; but will check with the SoC manufacturer first. They were likely removed because they are not appropriate for video playback.


Hi Sam,

Thanks for replying.

I haven’t noticed any tearing using all PIs all over these years.

I know you already told me that are different systems.

I will gladly test it. I purchase this Vero to use on this monitor. I have no idea of the possibility of an issue like this.

If I got the same experience that I have using the Pis I would be very grateful. I just wanted a HEVC ready device running OSMC.

I don’t own a 4K TV. Don’t intend to. At least until the REC. 2020 reaches its final cycle.


FWIW and as I said in the other thread. I have been running OSMC on a Pi1B+ for years with 1360x768x50 and never had any issues with video quality. We never watch HD though.

It’s not the quality that’s going to be the issue, it’s the refresh rate. It will be the same experience as other OSMC devices. If you haven’t noticed a problem on those, then you won’t here either.

I will add support for these modes in the next update.