Movie scraper not geting most titles

So there is no difference in the video content between your profile and the Childrens profile, correct? The only thing that the profile does is keep separate watched status and one profile has music in it?

I have 3 HDDs.
8TB = Movies
5TB = TV
4TB = Childrens Movies and TV

So the master profile scans the 8TB and 5TB, the childrens just scans the 4TB.

The sources.xml that you shared does not seem to show any difference. You need to in the Childrens profile add the 4TB drive as the only source. And in that profile you should remove the ‘Auto-mounted drives’ source.

In the master profile if something doesn’t scan in it allows you to edit the title to help the search, in the childrens profile it just gives you the error saying no information found.
That might be a skin thing since I use different skins.

Not sure how that helps the scraping but I’ll follow wyour suggestion.

That’s some important information that would have been nice to know from the beginning…

Everything looks correct to me in the library as far as sources.
In my childrens profile the only movie source is /media/Seagate Backup Plus 4TB/Movies and the only TV source is /media/Seagate Backup Plus 4TB/TV.

Changed my children’s skin to the default OSMC skin and tried scraping again and got the same results.

That’s not what sources.xml shows. Try this, create a new profile for the children, add their drive as a source scrape again.

Created a profile called Children 2 and it’s scraping.
So now how do I fix the original Childrens profile?

My guess is that it’s the database has a problem then. You could just:

sudo systemctl stop mediacenter
mv .kodi/userdata/profiles/Children/Database/MyVideos116.db .kodi/userdata/profiles/Children/Database/
sudo systemctl start mediacenter

You will need to add the source again after doing that.

osmc@osmc:~$ sudo systemctl stop mediacenter
osmc@osmc:~$ mv .kodi/userdata/profiles/Children/Database/MyMovies116.db .kodi/userdata/profiles/Children/Database/
mv: cannot stat '.kodi/userdata/profiles/Children/Database/MyMovies116.db': No such file or directory

Opps, sorry that should be MyVideos116.db

How would I go about deleting the “Children 2” profile vis SSH?
Because if I use the interface it locks up when it asks to confirm deletion yes or no.
Tried more than once and it always freezes.
I have to SSH reboot.

Oh,and after doing your command and wiping out my database on the original Children profile, i set content and it didn’t scrape the same files as before.

Stop kodi and edit .kodi/userdata/profiles.xml and remove the test profile from there. Restart kodi and it should be gone. Then remove the test profile:

sudo systemctl stop mediacenter
nano .kodi/userdata/profiles.xml
rm -rf ".kodi/userdata/profiles/Children 2"
sudo systemctl start mediacenter

I deleted both the “Children” and the “Children 2” profiles.
Then I created a new “Children” profile and proceeded to start it fresh, scraper still doing the same thing.

Did you add the source? Did you remove the auto-mounted source? What does the Childrens source.xml look like now?

I figured it out.
There was a left over settings file it was still using.
I deleted everything.
Now it’s scraping fine again.
That’s twice now recently that the Vero has given me odd issues that were never resolved outside of starting over from scratch.
That really bugs me because I want to know what caused the issue in the first place.