Movie & Tv Folders not always displaying after a scan

I was hoping someone could help me, Im new to the Vero 4k after moving away from my trusty Mede8er of 7 years so its a bit of a learning curve. Firstly here is my logs link -

Media is stored on my SynologyNas, everything is sharing fine but I sometimes have trouble when I add a new Movie or tv show folder. After a fresh scan the folder is not showing up on the home menu link but I can access it if I go to media/video/files and choose the relevant folder, in this case tv

If I delete the tv folder completely and add it again the missing folder will be available but I cant keep doing this, there must be an easier fix…any help much appreciated :+1:

My main menu with the tv folder

Inside the tv folder there should be a tv show (Friday Night Lights) where the yellow line is but it is not displaying…

tv folder accessed from Videos files…

Friday Night Lights folder is available, I can play the files etc…


When you access this “missing” show from the video section is all the media info present signifying it has been scrapped? I assume yes since I see artwork. In the library view slideout menu there is an option to toggle between watched, unwatched, and all videos. Is this maybe filtering out the display? If not does the show display in the library after a reboot or only if you remove and rescan?

darwindesign thanks for your reply, yes all the media info is present…all videos are set to be seen even if watched, i just checked this again and it not filtering…only shows if i remove & re-scan :frowning:

So it doesn’t show up even after a reboot? I can’t say I have ever run across that particular issue before. Can you try the Esturary skin and confirm that it happens with that as well.

Hi witched to the Esturary skin same issue


But “Friday Night Lights” is the only one in your screenshot which has the watched mark.
If you’re in the menu GUI->TV Shows, go to the side bar (press left 2x) and check whether hide watched is selected, see also screenshot attached

Another possible issue could be that this folder is empty or at least the osmc user cannot see the files!
With that setting deactivated at GUI->Settings->Media->Videos->Show empty TV shows you won’t see the folder at TV Shows if it is empty.


I had not noticed the white circle watched indicator on the folder, from the video/files section I can not find a way to switch this off. I also checked whether hide watched is selected and its not, tried turning on & off but still the folder does not show.

I have added the Friday Night Lights folder to the favourites and again I can see and watch it from here. FNL folder is not empty and contains season 01-05 in 5 folders.

It maks no sense as to why it is not showing up in the TV folder…head scratching… :face_with_monocle:

The view filtering is unique to the library views and not available video>files. You would need to check the side menu in the TV shows section to see how your filtering and display modes are set.

Hello I have checked the filtering and its all OK. I tried removing the complete FNL folder & subfolders, cleaned & updated the library and then created a new FNL folder and copied over the season folders and still its the same. Really does not make any sense…

a quick update, just created a folder for a new show, added and scanned and this folder shows up fine in the TV folder!

Your situation as I read it from what you describe and from looking at how your configured is unique. I don’t know how it could be explained other than somehow your database got corrupted. As such the most prudent path forward may be to delete the database and start fresh. We don’t have to affect the rest of your setup to do this but it would require a bit of command line work via SSH. If this is a path your interested in let me know and I can give you step by step instructions.

Hello darwindesign
Sorry for the late reply, well I deleted the TV folder and reloaded it but still the FNL folder does not show but a new TV folder I created shows fine on a scan :frowning:

I think the next step is a bit of command line work via SSH as you mentioned. It would be great if you could advise me

much appreciated

irishkeet :+1:

If you need instructions on how to access the terminal please look [here]. Please Note that file names in Linux are case sensitive. If you think you may want to revert there is a backup utility in the My OSMC add-on. The following will remove just the video database and cached artwork leaving everything else in your setup intact. You sources will still be present but you will have to setup the scrapers again as this information is stored in the database your deleting.

systemctl stop mediacenter
rm -r ~/.kodi/userdata/Thumbnails
rm  ~/.kodi/userdata/Database/Textures13.db
rm  ~/.kodi/userdata/Database/MyVideos116.db
systemctl start mediacenter

And just for reference if you wanted to just remove your entire Kodi setup and start from scratch then it could be accomplished with…

systemctl stop mediacenter
rm -r ~/.kodi
systemctl start mediacenter

many thanks for your help :+1:

1 Like