MPEG 2 License Install Location

So i bought a MPEG 2 license (still waiting) and i just wanted to confirm the location i would add the key to?

Would i just add to sudo nano /boot/config.txt and that’s it? or would it be in a different location.

Thanks for any guidance.

That would work or it does have a place to enter it from the pi config section of the my osmc add-on.

Either does the same thing of just getting it in the config.txt although I prefer the ssh command line way then typing in text with a remote and the on screen keyboard since I don’t have a USB keyboard.

Just put decode_MPG2=LicenseNumber in /boot/config.txt

EDIT: Use the OSMC Settings addon. As Sam sayd, less prone to mistakes.

Use the OSMC Settings addon. Less prone to mistakes.

Just put decode_MPG2=LicenseNumber in /boot/config.txt

Did you not understand that the the previous post indicated that this was indeed an option, confirming ops posed question? Because I think your post, 4 hrs after ops question was answered, is quite disrespectful and dismissive of the time and effort that the OSMC team have spent to provide a simple method for users to accomplish such tasks, particularly novice users. Do it whichever way you like but, IMO your useless “echo” here is unnecessary and disrespectful.

Sorry for appearing so “disrespectful and dismissive”… my intention was just to answer a question related to config.txt and MPG2 license.
The Sam’s reply about the best way to configure MPG2 license was extremely clear so, in my opinion, your post seems quite unnecessary :wink:


Hi all. I have two Pi’s, so I ordered two licences, quoting each PI serial. I just received one mail with instructions for adding to the config.txt. No reference to either of the serials. How do these licences actually work then, if there’s no reference to the serial of the PI? Is it just a generic line that you can put into any PI? In which case what is to stop one person from just sharing this code with anyone else? Or am I missing something?

I would contact the support email. You should receive two emails.

I suspected that. Thanks. I have mailed them.

Well now. I received a confirmation email with both licences in it, related to the serials of either Pi. So now I now which one is which. However I’ve added them to the config.txt file as suggested (through the Pi Config add-on), and after a reboot there seems to be no change. Videos with the MPG extension only play sound with omxplayer as the default. If I change to DVDPlayer, MPGs play, but then they always did, and I get the wow and flutter sound problem again on all videos (see other thread).

Am I missing something, or is omxplayer incapable of playing these files? They are encoded with MPeg1 by the way.

A debug log may make it clear what is wrong.

Have you read this post: Pi Config not saving settings
This one is dealing about a bug in the Pi Config add-on not saving the updates.

There isn’t actually an “event” occurring that I can pinpoint (you know, “I click something, things go funny, you can find it in the logs”). I’ve already made the changes to the config.txt file and rebooted several times. At what stage should I start logging?

Enable debug logging, reboot, play one file and stop. Then upload the log files.

Very strange. My MPEG video files now play fine through omxplayer. I didn’t make any changes other than the several reboots yesterday, but now it works.

Does anyone know how the licencing process works? Does the OS contact some remote address with my licence number and PI serial, and wait for a confirmation to come back saying “yes, you can hardware decode now.”?

That’s the only reason I can think for the lag between updating the config file and hardware encoding being enabled.

No. Add licence key to config.txt and reboot. It will be enabled without any network checking.

Hmmm…So I wonder why it took 24 hours to be enabled on both Pi’s? The next time I try this I’m going to disconnect the network and see if it enables after reboots.

A network connection is not used to verify the serial keys at all.

Otherwise, it would not be possible for Pis not connected to the Internet to take advantage of the gpu accelerated decoding.

A reboot is always needed when you change the codec keys

Yes I know a reboot is required. I amended the config.txt file 2 days ago, and rebooted both Pi’s at least twice afterwards (as detailed earlier). But mpeg decodeding did not work after each reboot. However it did work 24 hours later (and neither Pi had been rebooted during that time).

This isn’t a support query by the way, so please don’t take it as one. The licence key is working fine on both Pi’s, and I’m perfectly happy with it. I’m just curious as to why activation did not occur after reboots, but after the board had been left unattended for a day.

What you seem convinced has happened here is simply not possible. Your method of determining if activation had occurred was likely flawed. The appropriate way to confirm installation of the key would have been to use the command provided in the email that contained your key from RPF.
vcgencmd codec_enabled MPG2
Since nowhere at all in these last confused posts have you mentioned using or having any knowledge of this command, then I would assume you simply overlooked it in the license key email and were not really using a reliable method of confirming codec function. But alas, it would seem this horse has now been beaten.

Thanks! :+1::laughing::point_up: