Music is crashing my Vero4K and finding it hard to troubleshoot

Hi,

I’m having consistent, reproducible crashes with playing any mp3 from my SMB network drive. The other problem that I’m encountering is the inability to save out any log data. It gives me a paste url with the tag, instead of the bespoke string. I’ve tried the grab command in the terminal too, but it also gives me the same result. I’ve copied out the kodi.log to try and paste them into paste.osmc.tv, but it doesn’t let me save it and states ‘Something went wrong’.

Any ideas?

Ben

Try and reboot before playing a file to reduce log size

I have, on each occasion. Should I have log data set to Basic?

Can you log in via SSH and do a ls -lah .kodi/temp/ and show the output?

Set Event Logging to Basic - not sure why I (or if) I had ever touched that. Got the file down to under 4 meg. Here’s the link:

https://paste.osmc.tv/lufamiruye

Sometimes the Vero4K crashes (Red Light) after playing one song, or it might make it to 5 songs. I’m tried old mp3’s and newer ones, but it doesn’t seem to matter. I don’t have any issues playing videos/movies.

The screen saver I’m using is set to ‘Black’. I’ve tried other screen savers too, all producing the same result.

Your logs are flodded by uyou VPN Manager. Suggest to disable that addon for the troubleshooting otherwise there is no real way to find the right stuff in the logs

2019-12-02 21:36:04.196 T:3765388000 DEBUG: CSettingsManager: requested setting (label624) was not found. 2019-12-02 21:36:04.196 T:3765388000 DEBUG: CAddonSettings[service.vpn.manager]: failed to find definition for setting label624. Creating a setting on-the-fly...

Attempting now…

I disabled the openVPN manager. Restarted, played music, got a crash, uploaded here:

https://paste.osmc.tv/amozagojud

Looks like a zomboided problem

2019-12-02 22:29:30.318 T:3722298080   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.TypeError'>
                                            Error Contents: runPlaybackEnded() takes exactly 2 arguments (1 given)
                                            Traceback (most recent call last):
                                              File "/home/osmc/.kodi/addons/service.zomboided.tools/service.py", line 364, in onPlayBackStarted
                                                if self.playing_file: self.runPlaybackEnded()
                                            TypeError: runPlaybackEnded() takes exactly 2 arguments (1 given)
                                            -->End of Python script error report<--

How can I easily tell what has been installed from a repo, like Zomboided? In the meantime, I’ll work out how to disable it to test again.

Thanks for your help thus far.

In My Addons you can see what comes from the Kodi Repository when you don’t choose All

I’ve uninstalled Zomboided repo and tried it again. For some reason, Zomboided is mentioned a lot in the log. Got the same crash…

https://paste.osmc.tv/utiqicotiz

I just saw that Zomboided Tools was still installed. I was assuming that uninstalled the repo would also remove any apps that were related. Trying again now…

Yeah definitely you logs are still very messy. Also please indicate which file you tried to play as it is support hard to find.
To be honest you might want to start with a clean .kodi directory to see if that works.

Update - I haven’t yet encountered any crashes after removing Zomboided Tools. My Log file is also a lot smaller in size too.

Latest news - still no crashing, so I guess removing Zomboided worked a treat

Ok, so I thought everything was working but it certainly isn’t. I tried to remove a bunch of repositories and apps that I couldn’t identify as being used.

Here is my log
http://paste.osmc.tv/yuhaxiriku

Well suggest to start with a clean install

This log doesn’t show Kodi crashing – did you experience the problem when you uploaded these logs?

Sam