MVC, IR (kernel 4.9.113-20-osmc MVC (Testing)) not working

Hello,

I read the thread Vero 4K+ Review: Finally, a Native Kodi 4K + 3D Do-it-All Player? and ordered der Vero4K+.
Installed kernel 4.9.113-20-osmc though it was not mentioned in this article.

I have now 2 critical issues:

1. MVC MKV files are recognized but not displayed in 3D

  • tried differend Resolution and Hz configurations; never changed anything
  • starting a mvc video (mkv) it ask for the method to be displayed -> as movie, then it starts playing in 2D and if I open the 3D menu the sliders (3d&2d) are off - cant set 3d to on, but 2d … what ever it is not running in 3D

My HW: Yamaha 680 Receiver with passthrough Video on an LG 55UF860 (passive 3D)
(Was and still is working fine with the Windows MVC build on my Intel NUC)

osmc@xbmc:/sys/class/amhdmitx/amhdmitx0$ more config
cur_VIC: 16
cur_video_param->VIC=16
colordepth: 8bit
colorspace: 422
AVIF VIC: 16
VIC: 16 1920x1080p60hz
Colour depth: 12-bit
Colourspace: YUV422
Colour range: full
EOTF: SDR
YCC colour range: full
PLL clock: 0xc000027b, Vid clock div 0x000a739c
Aspect ratio: 16:9/full frame
audio config: on
audio on/off: on
audio source: I2S
audio type: L-PCM
audio channel num: 2 channels
audio sample rate: 44.1kHz
audio sample size: MAX
3D config: off

/sys/class/amhdmitx/amhdmitx0/disp_cap_3d is empty

2. IR remote not working with One4All RC URC7960
Figured that the far out Jack was for IR …
Setup my One4All for MCE/XBOX RC (Code 0009/1972)
Selected the both config in MyOSMC … not working
Used irrecord (why not integrade this into the OSMC GUI?) what recognizes signals but when it starts to assign Buttons/Keys I get:
“That’s weird because the signal length must be odd!”

Nothing is working … well could try a shorter distance

Please advice for further proceeding.

Thank you
If you need a log please discribe precisely what output you need and where to find it.

3D support is still in the testing stage. Assuming that you have updated to the latest OSMC update (with Kodi 18.7) you would need to downgrade Kodi to 18.6 until 3D support is readded to the latest version.

Thx for the fast reply:
sudo apt-get install --reinstall vero3-mediacenter-osmc=18.6.0-13
MVC is working.

Problem 1 is “solved”.

Any Idea with my 2. issue?

With the remote issue, I’d suggest trying another IR profile.