My reflections about the differences between Vero 4K and NUC Braswell running LibreELEC

I’ve noticed there’s no option in Kodi to turn of display after like 5 minutes, like there was in LibreELEC. I’m not talking about a screensaver, but that the GPU stopped the signal, the TV doesn’t get any signal, and then will turn off after a while.

How come there’s no option like that in OSMC?

Also, in LibreELEC there was an option for Color management. Intel VAAPI howto with Leia v18 nightly based on Ubuntu 18.04 server
There was a way to set limited range for colors, but that’s options is not here on my Vero 4K.

I also got an x264 10bit mkv file, that wasn’t played with HW, but only SW. I know that x265 works with 10 bits, but the x264 10bit didn’t. It was a normal 1080p file.

Also, about the 100mbit LAN. I can’t really understand that there’s no gigabit. Now when I stream some 4K 10bit HD x265 mkv’s there’s problem. I guess it has to do with the speed of the LAN.


The main difference is that you’re comparing two very different pieces of hardware.

One is Intel based and one is ARM based.

The colour option is to allow colour gamut adjustment for the Intel i915 iGPU. On OSMC, you can select Force RGB, but Vero 4K will automatically detect and output the ideal colour space.

10-bit x264 can’t be decoded on hardware by either the NUC or ARM, so has to fall back to software. The Intel CPU will have more power to do this (although it’s video hardware acceleration is much more limited).

Kodi v18 will have improved playback of Hi10 content.

Gigabit Ethernet isn’t necessary for playing back UHD content.


1 Like

If you’re having throughput issues with high-bitrate files, I’d advise to look at one of these wiki entries and try mounting your media share via FSTAB and SMB or NFS (depends on what you’re using and what you prefer, but NFS will give even better throuput):

Throughput issues are mostly resolved by following those guides… The limiting thing here is mostly not the Fast Ethernet of the Vero 4k, but the mountig method.

OK, Will check in to that. Right now I got it mounted by SMB, but also that I run Kodi library over mySQL (mariadb). Can I still do the mount in a better way and use mySQL?


Don’t know the details of your set-up, but as an example, I run mariadb on a Synology NAS, and mount via NFS in Kodi and have a fully wired network. I have no trouble at all playing UHD mkv’s via the latest OSMC version.

1 Like

Via the Kodi GUI or via FSTAB like advised to the OP?

In my case via the Kodi GUI. I have quite a few Kodi clients, all the others run LibreELEC. Mounting via the GUI enables complete consistency even if the clients run different OS’s. I’ve assumed that fstab would not work well in that environment but happy to be advised otherwise.

Was just asking out of curiosity… FSTAB is not always needed, but it’s the best way to fix thoughput issues. If everything’s working fine for you, why change it? Never change a running system :wink:

FSTAB will always be a bit faster.

I was a bit worried about the ethernet port as well in the beginning but it is not a problem, atleast with the UHD stuff i have. The only problem if ever had was with a 60fps, 4K file encoded in H264 (all others HEVC or VP9) which jumped a bit during playback but since it was a test video anyway i didnt really bother investigating this any further.

You can get a compatible gigabit ethernet adapter for the vero to improve the speed (not full gigabit aber atleast 2-3 times faster as far as i read here) but this is not necessary imo unless you do a lot of seeking arround in movies :wink:

Im using nfs with a mysql library, maybe this could be a issues if you have any windows clients in your setup but for me (only linux/openelec) this was no problem.

I think the most demanding UHD content I’ve tried so far would be the IMAX sequences in The Dark Knight Rises where the bit rate really pushes the connection. Even via Kodi-mounted NFS, I had no issues at all.

1 Like

Thanks for all the replies.

About the color stuff. Before on LibreELEC, I was told to use not full color range, making the black a little bit less black, but I could differences in different shades of black. Now, the only mode I have is the one that was the darkest before.

Also, I will check in to the different fstab and all that.
EDIT: Also, how can it work with a network path, mounted to the local player, and then set it up with mysql? Shouldn’t all the path in mysql point to an IP?

I’ve noticed one more thing that differ. On the main menu in Kodi, with Kodi skin, I’m mission the top icons, that was showing genre och stuff like that. How come they are gone?


I don’t think you need to adjust anything on Vero 4K.

Make sure your TV is in the same mode and not any ‘PC mode’. You will then see the same colour range,

The setting you found is a fixup in LE for Intel platforms using i915.

Search for Path Substitution.

But, as I said, I was told when I was using LibreELEC, to use the limited color settings in the Kodi settings. What it then did, was to kind of fade the black, to a more grey-ish black. If I didn’t limit, the picture was more real black. I kind of liked it that way, but the people at Kodi forum told med the limit settings was the right way.

Now in Vero 4K, there’s only one mode, and you say it’s the correct, and it’s the same as what I was told wasn’t the correct mode on LibreELEC, that’s why I find it strange. =)

About path substitution, I’ve used that before, and know how it works. But, what I did now first, was to set the mysql settings in advancedsettings.xml, and then in sources in Kodi I set SMB shares to two folder, series and movies, and set content to these two folders, and stuff went in to the mysql-database.

What I also noticed was that when I used my Android phone to use Kodi with mysql database, it just worked, even without adding sources (like I understand from Kodi was needed).

But, my question now is, how is the path to the media in the database now set? Is it a SMB path, or what? How do I change it to NFS or make it a fstab internal mount?


If you want to use different share access methods on different clients you would use path substitution to equalize them.

OK, so, we can assume that the database now saved in mysql is at the form smb://, and for my Vero 4K I should just use path substitution from smb:// to nfs:// then?

On my unRAID server I got both SMB and NFS on.

And for the units that works well with SMB and maybe nott NFS (maybe Mac OS and Android?) I can keep the default SMB:// path?

EDIT: OK, so this is what I did now on my Vero 4K.

  1. I edited my sources to use nfs://IP instead. On SMB the path was direct to smb://IP/media but with NFS it looks like I have to use nfs://IP/mnt/user/media instead.

  2. I tried to use the fstab instead, and followed this.
    Configuring fstab based NFS share mounts

I added this line in fstab, and did the rest of the commands. /mnt/media nfs noauto,x-system.automount 0 0

But, when I do the checks, there’s nothing in the /mnt …

EDIT2: I used two sources in my Kodi before I wrote here. It was smb://IP/media/videos/series and smb://IP/media/videos/movies. I then scanned the library to the mysql database.

Is it enough for me to substitute this then?


on both those path is /media a subfolder.

or, if I do a fstab mount, I use from SMB to /mnt if I mount my media path (smb://IP/media) to the local folder /mnt ?


Are you using a synology nas? I think you are. In fstab setup use the IP address followed by the path to your videos. It will most likely be /volume1/web/YOURVIDEOFOlDER then you put /mnt/NAMEOFOLDEYOUARECREATING

My first part looks like this as an example. /mnt/movies

Then for path substitution as an example I have 2 Vero and one windows machine. Vero is use fstab connection and only windows machine has path substitution. My path substitution looks like this…


Windows source is mapped via Kodi nfs. The above is just the paths used. Make sure you use the proper way to put it in your advanced settings file. Hope that helps

No, I use a unRAID-server.

I can’t see what should be wrong in my setup. I got my IP:/mnt/user/media first, and the the /mnt/media I want it on the Vero. I guess I should create that last folder myself?

In you exampel you have created the mysql database where you already had your share set up as a NFS share, right? And only in your Windows machine you have to change it to a server path, is that right?

In my case, I need to do the path substitute for the mysql I think. The library is at first scanned as a SMB://IP, and if I want the Vero to connect as a NFS, I need to make some changes.


Yeah I’m not 100% sure. For synology I have to give nfs permission access to the IP of the Vero machine trying to access the shares. Do you have to do this for your unraid server possibly?

No, I can access the NFS via Kodi. The shares I had in Kodi, that first was set up as SMB, and then edited to use mysql and scanned to that database, these shares in Kodi I have changed to use NFS instead, and I can access them without any problem.

I also think I have made a correct path substitute, where SMB are substituted for NFS (and when starting a movie from the mysql database I think it now uses NFS instead…), but as I understand it, it should be EVEN better to use a fstab with NFS instead of the Kodi version of NFS…


I may be confused but it sounds like you switched to nfs from Smb for your MySQL database by rescanning and recreating the database? If so in your fstab setup the nfs path to your server must be wrong or doesn’t have appropriate access. When you follow the fstab guide are you saying the folders are there now on the Vero but none of your movies show up? If so I had same issue and it was a permission issue accessing the share. I had to give the IP of the Vero access. I only really have synology knowledge here so maybe I’m not helping. I would reconfirm your unraid path is correct and it’s open to the internet. In synology that is what the web folder is.