My Vero4k seems to be dead

Exactly as: Persistent red light - will not boot nor reinstall

My Vero4k seems to be dead. Same exact pattern as the issue I linked. Now it’s just a red light on the front, with no video signal output, nor any other activity.

This unit is over 3 years old, so I’m sure it’s out of warranty, but I just wanted to see if there was anything else I could do before I re-order a new one?

I did try a different power supply (two actually).

Any ideas?


Can you show us photos of the two PSUs you tried?

Do you remember what you were dong with the device last?

If you have a USB-A cable, plug it in the white port of the device and in to a PC and see if it’s detected under Device Manager



PSU 1: 5v 2.5A

PSU 2: 5v 1.2A

When I plugged it into my computer via USB it shows up as:



All three scenarios result in a single red light on the front, but no other activity.

GX-Chip is a good sign. It means the device is in a recovery mode and it’s possible that just the internal software is corrupted.

I’ll send you some instructions on what to do via a PM later today.

1 Like

Hey Sam, I didn’t receive a PM. Guessing you may have gotten busy. Is that something you could send me today? THANKS!!!

Yes - I’ll send some instructions shortly. I’m still preparing the necessary files for you.

Ahhh! We’re gonna do a firmware flash or something? Didn’t mean to rush ya. I’m sure you get pulled a million ways, so just wanted to make sure you hadn’t forgotten.

Thanks for this! It says a lot that you’re willing to support a product that’s older. I have a new TV, so I’m going to need to order a second one for that, but I’ll wait to see if I need to order two or just one. :slight_smile:

1 Like

With the update it’s awfully busy around here, so it’s taking me a bit of time to get on top of things.

I have messaged you now.

Hello team,

I am experiencing very much the same issues. When the device is plugged in, the red cross lights and stays on. Nothing appears on TV.
I am using the original PSU and it seems to be alright - I get the same symptoms when I connect VERO to PC via USB-A - USB-A cable - the red light stays on.
When connected to PC, I can’t see it in the device manager BUT the chime of a new plugged-in device does sound.
Tried the re-installation process with USB but nothing happens.
BTW: probably culprit is wrong power unplugging. I was leaving for a longer vacation, so I was switching off all the power cords, but did not switch or unplug VERO prior to that…

Would love to try any de-bricking attempt before buying a new device.
Thank you!

If you’ve used the wrong plug (i.e. reconnected the wrong one) and now get that light, the device is likely damaged.

Hey, my device came in, but I’ve been busy and sick since then, so just now getting to this. Could you tell me the last version of OSMC based around Python 2.6? I need to update some custom addons, and I just don’t have the time to do the dev/testing, so I’d like to install an older image for now.


1 Like

Thanks very much!