Persistent red light - will not boot nor reinstall

I’ve already sent this through the Contact - OSMC page but just in case anyone else has an idea:
I think my Vero 4k is dead - it’s only a little over one year old. Suddenly today (after no changes, movements, alterations in power etc.) I went to watch something and the output on the screen was showing the “please standby” screen flashing up over and over (whilst a red light was lit on the front). I removed the power (official adaptor, never used anything else), waited and reinserted but nothing at all appeared on the screen - the red light remained lit.

I have tried re-installing from USB - the “please stand by” screen did initially appear the first time, but the device then looked to be rebooting constantly alternating between “please stand by” and no signal .

I then tried the toothpick method to no avail - as soon as I insert the power, the red light appears and nothing at all appears on the screen to start the installation - multiple HDMI screens just report “no signal”. Tried different cables…the red light on the Vero 4K is lit the entire time.

Is there any saving it, or do I need a replacement?

Try another 5V 2A PSU if you have one.
Take a photo and show us here if in doubt.

Sounds like the PSU has probably died. I can get a new one out for you


I’m afraid I don’t. I have just replied to your email.

Thanks for your help…

No problem. As per our discussion via the support ticket I will send you a new power supply unit out on Monday.


1 Like