Nearly there but still some 4k juddering

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks,

The log can be found here:

https://paste.osmc.tv/ozefelojam

I also noticed the 1080p movie that I checked last night is also having issues. Perhaps I didn’t play it long enough to verify it was ok. However, five minutes or so today and it starts to slow down and become very choppy.

Thanks.

Have you tried using an FTP server instead of SMB to see if that makes a difference? I’m using FTP and it’s very fast. No juddering with my setup.

The log seems to show some throughput issues. Can you show me the fstab line for ChrisB_PC?

Sam

This is what I have for that mount (password changed)

//192.168.1.100/Movies /mnt/ChrisB_PC_Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=Chris\040Burwell,password=xxxxx,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

That looks OK.

I think some advancedsettings.xml changes might do the trick. We want to get some more solid defaults and include them in an update in the future.

See Buffer issues after October Update.

If it does help, I’d be interested to know which values you’ve used.

Sam

Hi Sam,

Thanks, I was also just reading another post regarding the use of powerline adaptors. I do use these, but their diagnostic tool is saying they are connected at 140Mpbs so don’t think they are the problem?

I’ll give the advancedsettings.xml a go and report my findings.

Thanks.

Hi

The first thing I would test would be a direct Ethernet connection if you can do so temporarily.

You may also get a better experience with WiFi

Sam

That was my first thought as well, but unfortunately I don’t have a long enough Ethernet cable to hand.

Tried Wi-Fi and it was a lot worse.

Chris.

Okay – power line it is. For WiFi – make sure 2.4Ghz and 5Ghz networks are separate if possible.

The good news is that users did report improvements after adjusting the buffer, so it should give you a better experience.

The best way to test the speed between two machines, i.e. Vero 4K and PC, would be to use iperf3. There is a Windows version here: iPerf - Download iPerf3 and original iPerf pre-compiled binaries.

Do you know how to use SSH on the Vero 4K?

Sam

Hi,

I tried on the 5Ghz network (they are separate)

I will download iperf and see what that can tell me.

I’m not entirely sure with SSH, I’ve been doing stuff so far with Putty? Is that the same thing?

Thanks.

Yep.

Run iperf -s on PC (command prompt)

and iperf -c IP-OF-PC on the Vero 4K. On Vero 4K you’ll need to run sudo apt-get install iperf3

Cheers

Sam

Hi Sam,

I’ve not done the advancedsettings.xml bit yet - still trying to learn that!

However the iperf results show this??

iperf

Hi

That’s quite low and shows that the speeds seem to vary between 30Mbps and 5Mbps. This will give you problems playing high-bitrate content.

What powerline adapter do you have? A new adapter may improve things; but if your house wiring is old, it may not.

I’m not sure how much adjusting advancedsettings.xml will improve your situation

Sam

They are Trendnet TPL406E adapters and a few years old now. The wiring is fairly new though. To be honest I have hard wired Sky-HD from the lounge to everywhere in the house with Cat 6 Ethernet so I guess one more cable run won’t kill me!

I don’t mind having a go with advancedsettings.xml just to see if it makes a difference…

I also tried iperf again after switching to Wi-Fi, which appears to be a lot faster - but only some of the time!

iperf

WiFi looks much better. If you can’t improve your wired environment, then it might be a better option to stick with Wireless.

Some tweaking on the router might provide you with a more consistent connection. I assume that the desktop you’re trying to stream from isn’t on powerline as well?

Sam

Hi,

No the desktop is connected to a gigabit switch which in turn connects to the router. The powerline adapter is also then connected to the switch, which I will eventually replace with another cat6 cable straight to the lounge.

The router is a BT Homehub 4 (I have a 5 & 6 but they both cause issues with a VOIP app I have on my phone). Playback is definitely worse over wireless though, despite the bandwidth appearing to be better. It’s clearly not keeping a steady bandwidth :frowning:

I gave the advancedsettings.xml a try but it didn’t make any difference as you anticipated. I’ll just copy the movie I want to watch tonight over to a USB stick until I can get my cabling done.

Thanks for all the help :slight_smile:

Chris

Hi,

Just wanted to post an update for anyone following this thread. Fitted a length of Cat 6 cable from the office where the PC is located to the lounge today and patched it into my network. 4K now works fine and iperf is showing a much more positive result:

Capture

Thanks for the help :slight_smile:

1 Like

Brill. Glad to hear it. Thanks for following up and letting us know it works well for you now.

Hi Sam,

Everything is still playing fine since I hardwired Vero to the LAN. However, I seem to have a problem when seeking through files. It appears to fast forward and rewind OK, but when I go to play again the audio continues but the video doesn’t move. I then have to press stop, select the file again and choose ‘resume from x’ and it’s fine. Pressing up to skip say 10 minutes seems to be ok, it’s just when I am doing 2x, 4x, 8x etc.

Any ideas what’s wrong please?

Thanks.