Need help fixing ATV1 with Sad Face

Hey guys,
And thanks in advance for any help you can give me.
Have been running sweetly an old Appletv1 with USB for OSMC/Kodi. Updates have been run regularly, and no ‘add-ons’ been added for few months. Have had this running for 8 months, no dramas.

Requested I run updates this morning, I clicked yes, and saw it start, I now only get a blue screen with OSMC sad face :frowning:
I cannot get in to obtain logs etc. Only a Blue face??

Help! Am a newb, so not a seasoned tweaker! Appreciate any advice. Cheers. Dave

Hi Dave,

Check out the banner on the top of the forum. Should cover you for why you may be getting a sad face loop and should be easy to fix. Let us know if you have problems.


Many thanks for quick response Sam. Much appreciated.

Yes makes sense. but…
uploaded USB from ATV to Macbook, and USB is corrupted?

I cannot see anything. so cannot add code as suggested?

Best way forward please? Disk Image will clear USB of all code I had?

TIA. Dave

When the ATV, is booted with the USB stick inserted… can you use ssh to get into the ATV ?
ssh is not working ?


Unable to get to anything.
Without USB it will boot up as ATV

So, it appears USB corrupted after this mornings update?

Would it be possible to have a link so I can redo the “USB” or maybe a decent link so I can install KODI onto the ATV HD?

Cheers. I Appreciate your help

Just we understand what the situation is:

  1. You have the original Apple TV Software still installed on your ATV1 Hard drive ?
  2. You had OSMC installed on a USB stick, and you booted the ATV1 with that USB stick, to run OSMC ?

Yes, Has run and been regularly updated for 8/9 months. Updated this morning and blue screen and sad face

Does “Yes” mean that the answer to both my questions is “yes” ?

Edit: Sorry my mistake. You mention in your post that you are willing to re-install OSMC on your USB stick, or internal HDD. hehe been a looong day.

So, you tried to ssh into the ATV1 via command line ?

I was able to do that on my own ATV1 when I got a Sad face.
Just because the Sad face came up doesn’t mean that you can’t connect via command line , with a computer connected to the same network as your ATV1

Your can download the OSMC installer tool from here Download - OSMC
If you are using a Macbook, then choose the OSX installer, which is

Stick a USB stick in your mac, run the installer, and follow the instructions.

If you are willing to erase the original Apple TV OS from your ATV’s internal HDD, then, when asked, choose the newest version with HDD in the name.

Before you install OSMC onto the ATV HDD, boot into the original Apple TV software and change the AV setting to RGB High

There is another advantage to installing on the HDD. After it’s is complete, you may be able to copy over all your settings from the USB stick. I suggest using a different USB stick so that this is possible.

Beautiful stuff and again. Many many thanks for all your great and fast support.

I have fully installed OSMC onto the ATV without a hitch. Thanks again.

Now I just have to recall how to set up KODI and instal etc.

Cheers. You guys rock! :wink:


Glad we could help !

1 Like

Hello again. Guess what? It’s gone again. After you great help last time, installed onto ATV it was awesome. Turned on today and sad face again. Me & the TV!
I reinserted USB with code from last time but not having it. Just blue screen. No idea why crashed. Seems it may have tried run update? How do I get it back? Cannot get to any menus etc? Thanks in advance

OK Guys. I downloaded another version, and installed it again successfully. Although I couldn’t get to back up version. So had to reinstall and set up again. BUT HAVE NO SOUND!?! Been to settings etc, cannot see anything to affect it? Any ideas? TIA Dave

Just got the :frowning: Smiley face due to Power Failure. Fixed this way - Posting so anyone comes across this can follow.

The above Sticky Post with its 2 phases of instructions is Key -

I just SSHed on as OSMC with MyPassword

And then Copy Pasted the commands and it seems to be back and working.

PS: Cant help it, at times we get power failures once in a while. So, please keep that in mind that some people may not always have Safe Shutdown in their hands.

Hi All …Sam
Hope all well?
Again here in NZ, Unexpected power outage, adn AppleTV kodi goes down. Sad face on screen again. Could not get into any menu, so reloaded OSMC onto USB and went through procedure again, all fine but it will NOT load repositories!? Have tried various things but cannot get it to load any repo’s. Seen links to a problem for OSX but nothing for ATV1??

Until the outage. It was running beautifully! I was sooo impressed.

Any advice/ideas greatly appreciated.

Cheers. Dave

The default Kodi repo? Because issues with any other repo would have to be taken up with the repo maintainers.

Thanks ActionA, Sorry for delay been full of cold ;o(

Took what you said, and tried some repos already there, and unable to connect messages.

I’ve briefly read other thres etc, Id there problem affecting SSH since last update?
I’ve even tried to reinstall an older version of OSMC, still no joy!

Not a tech person, but any help would be greatly appreciated. Loved my Appletv1 running KODI, it was running superbly. we were so happy!

Cheers all. Dave

No, there is not a problem with SSH in the latest update. There is just a security update that will enforce higher encryption standards.
So do you have problems to connect via SSH?