Need Help with force updating inputstream.adaptive

Hey guys. I’m currently running an experimental build of OSMC running Kodi 19 Matrix. One of my add-ons requires an updated version of inputstream.adaptive, but the kodi repo shows that there are no updates available for it. I went to the github page and tried to install the add on as a zip file, but Kodi said “The add on could not be installed due to invalid structure”. What do I need to do to manually or automatically update inputstream.adaptive?

Hi,

Please provide a link to the github page? So we can have a look the structure of the zip provided.

What version inputstream.adaptive is required?

Thanks Tom.

Hey Tom,
Thanks for your interest.
This is the link to the inputstream.adaptive repo from github: GitHub - xbmc/inputstream.adaptive: kodi inputstream addon for several manifest types
The add on requires inputstream.adaptive to be atleast 2.6.6, whereas my OSMC is running 2.6.18

Thanks

2.6.18 > 2.6.6, isn’t it?

The current version on Github is 2.6.22 :wink:

1 Like

Inputstream Adaptive is a binary add-on – so needs compiling for the target. That’s why we ship it as part of OSMC.

Our version will be very recent – and I’d be surprised if the version we ships needs updating.