Videos won't play in YouTube AddOn, can't install newer version of YouTube addon since it requires a newer version of inputstream.adaptive, can't figure out how to update inputstream.adaptive

I’m a few levels deep in this problem.

For a while playing videos in the YouTube add on worked fine. Then I couldn’t play any videos and instead got a “content not available on this app” error - same as this issue, which suggests updating the add on as a resolution.

I uninstalled my current YouTube add on and tried to install a newer version from a zip file, using this approach (but with a newer version than the comment). In Kodi, when I go to “install from zip file” and choose the zip for version , I get an error “The dependency on inputstream.adaptive version 19.0.7 could not be satisfied”. I get the same error trying to install version Trying to install unofficial version 7.0.2.alpha7, I get “the dependency on xmbc.python version 3.0.1 could not be satisfied.”

I tried updating inputstream.adaptive from the kodi add on repository but could not find it, same as the original post in this thread. I ran “sudo apt install kodi-inputstream-adaptive” from the command line when SSH’d into OSMC and got “E: Unable to locate package kodi-inputstream-adaptive”.

I tried to get a standalone add on zip for inputstream.adaptive but all I found in the github repo was uncompiled zips of the repo, and I’m not sure how to compile it. Same as this thread.

I just want to play videos in YouTube add free on Kodi. How do I resolve this mess?

System info:
Raspberry Pi 3B
OSMC 2021.12-1
INFO : Starting Kodi (19.3). Platform: Linux ARM (Thumb) 32-bit
INFO : Using Release Kodi x32
INFO : Kodi compiled 2021-12-21 by GCC 8.3.0 for Linux ARM (Thumb) 32-bit version 5.10.78 (330318)
YouTube Addon v. 6.8.25+matrix.1

All these versions require Kodi v20, so you first need to upgrade to the latest OSMC version before you can install that version


Okay, I updated OSMC from the interface: My OSMC > updates > manual controls > scan for updates now, and I installed the update and rebooted. Afterwards I saw I was on OSMC March 2022.

I tried again to install these newer YouTube addons from the zip files and got the same errors about dependencies not satisfied for insputstream.adaptive or Xmbc.python.

Log file: hastebin

Latest version is August 2023, you must either try manual upgrade or a reinstall of latest version

1 Like

On raspberry pi it is easier now to run PiOS Bookworm.
It has Kodi Nexus and you can view video on YouTube using Chromium browser instead.
On my setup the YouTube add on is working

We will move to Bookworm soon as well, but it is not necessary for Bookworm for the YouTube add-on to work.

The user simply needs to update to the latest version of OSMC which will give them Kodi v20, save them a re-install and work just fine.

Earlier I updated OSMC from the interface, and then I also ran sudo apt-get update from the command line but still wasn’t able to install newer versions of the YouTube addon.

I realized I forgot to also run sudo apt-get dist-upgrade from the command line to upgrade a bunch of other components (per Keeping your OSMC system up to date). After that I was able to install the YouTube addon versions I was blocked from due to dependencies.

Not sure why updating from the OSMC graphic interface didn’t do this.

Did this work for you?

I updated kodi and youtibe (7.0.1) from rep, but still cant use it, e.g. play trailer.
What do i do wrong?

Yes, after following the “updating from the command line” instructions on keeping your OSMC system up to date, I was able to install version of the YouTube addon from the repository, and YouTube worked again.

I think you need a newer YouTube addon version than 7.0.1. See the latest on the releases page and follow these instructions to install (which I think you already know, but posting it for others)