Netflix - how to guide?

Hi all.

Trying to install Netflix on my Vero4k running 18.9…is this possible? I have a paid up account. Is there a dummies guide out there please?

Thank you

M

Due to google changing the “rules” surrounding libwidevine, we have just been happy to have a working netflix solution as long as we have had. To get it working in OSMC, we need to upgrade the distro to bullseye(next debian release), due to requirements of a more modern libc.

Thanks for the reply. I am just a lay person/end user…so don’t fully understand your answer if I’m honest! Are you saying I can not install it for the moment?

Thank you.

M

In short, google said they would make all old solutions for netflix-watching invalid 1 june (if i remeber correctly), but it has worked a while after but I’ve heard reports of it not working at all right now.

Haven’t tested myself since I know there is a solution, just needs a lot of work behind the scenes to get OSMC there. Right now, OSMC team is focused on getting Kodi v19 out, but i think bullseye will be the next big goal.

OK, thanks. Well I have installed the CastagnalT Repo for Leia and installed version 1.12.16 but can’t put my account details in…under account all I can do is logout…

Have you tried the auth-key solution? Doesn’t mean you will be able to play video since, i’m unsure if the current libwidevine works.

I have tries…but just can’t do it…guess it’s not meant to be…unless there is an easy way!

Netflix is working fine for me. I’m using the Matrix test build of OSMC, latest version of the add-on downloaded from GitHub, and I think I did have to use the auth key thing and restore an older version of Widevine. I don’t know how long it will carry on working.

Even as I have Netflix app (4k) running on the TV, I’m now tempted to do a clean reinstall just to see if i can get it to work. @angry.sardine do you know which version of libwidevine you got that is still working? I still got a few backups from .helper addon on the emmc on the vero and I haven’t tested Netflix in months. I might back up the “working” one and use that in a clean install (This install is getting old. 4 months).

Be interested to know how every one gets on…seems to be quite a popular Addon now…

It says 4.10.1679.0, “extracted from Chrome OS image FIEVEL with version 13505.73.0”.

I don’t know what any of that means :slightly_smiling_face: but hopefully one of those numbers is what you want!

I seem to recall trying a more recent one and that not working.

OK…back on it…I have followed this guide https://makingstuffwork.net/technology/install-netflix-amazon-prime-video-plex-raspberry-pi-kodi-osmc/. and this for the authentifaction Login with Authentication key · CastagnaIT/plugin.video.netflix Wiki · GitHub using my PC. (windows 10)…I have gotten as far as Operations completed! It gives me the PIN protection number and says the ‘NFAuthentifaction.key file’ is saved in ‘current folder’…I can’t find this current folder…

Thank you for your help!

M

That means the folder you are running the NFAuthenticationKey.exe program from.

Thanks for speedy reply…again…not brilliant on PC’s…is there a way to search for it please? Windows 10…

How did you run NFAuthenticationKey.exe in the first place?

Thanks again…I have manage to locate it…old windows machine took a while to remember where things are…now updating the Widevine. on the Vero having transferred the key across. This guide seems to be pretty straight forward for me Watching Netflix on Kodi - Pi My Life Up haven’t tested yet…but question is…what is the maximum streaming for this Addon? 1080p?

Thank you…again!

M

720p

On the Vero 4K or Pi 2/3, for practical purposes, you are limited to 720p. 1080p streams can be accessed, but because Widevine requires software decoding, 1080p won’t play smoothly. 720p generally plays fine.

EDIT: Bah, ninja’ed by fzinken. :laughing:

Thanks…so just about ok…we have 480 at the moment on the basic package…so hopefully 720 will be ok. 1080 will obviously be better…maybe there will be a way in the future with an update?

M

But you wrote better explanation. Restriction is not coming from the App but the Software decoding limits.

1 Like