Netflix plugin stopped working

I tried reinstalling, but it does not help. The log says:

2020-09-25 18:09:39.584 T:3511198432 ERROR: [plugin.video.netflix (1)] Traceback (most recent call last):
File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/run_addon.py”, line 33, in wrapper
func(*args, **kwargs)
File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/run_addon.py”, line 249, in run
success = route(pathitems)
File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/run_addon.py”, line 90, in lazy_login_wrapper
return func(*args, **kwargs)
File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/run_addon.py”, line 126, in route
_execute(nav_handler, pathitems[1:], G.REQUEST_PARAMS)
File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/run_addon.py”, line 153, in _execute
executor(pathitems=pathitems)
File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/navigation/directory.py”, line 64, in root
common.make_call(‘fetch_initial_page’)
File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/utils/logging.py”, line 164, in timing_wrapper
return func(*args, **kwargs)
File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/common/ipc.py”, line 88, in make_call
return make_addonsignals_call(callname, data)
File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/common/ipc.py”, line 161, in make_addonsignals_call
_raise_for_error(result)
File “/home/osmc/.kodi/addons/plugin.video.netflix/resources/lib/common/ipc.py”, line 173, in _raise_for_error
raise Exception(result[‘class’] + ‘\r\nError details:\r\n’ + result.get(‘message’, ‘–’))
Exception: ConnectionError
Error details:
HTTPSConnectionPool(host=‘www.netflix.com’, port=443): Max retries exceeded with url: /browse (Caused by NewConnectionError(’<urllib3.connection.VerifiedHTTPSConnection object at 0xcd3f8b10>: Failed to establish a new connection: [Errno -2] Name or service not known’,))
2020-09-25 18:09:41.758 T:3481252576 ERROR: GetDirectory - Error getting plugin://plugin.video.netflix/
2020-09-25 18:09:41.775 T:4065652736 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.netflix/) failed

Your best bet is to get support from the addon author.

or

https://forum.kodi.tv/showthread.php?tid=329767

I did notice there have been some recent changes at Netflix that might require a new (and more complicated) login process.

1 Like

Perhaps @joakim_s has any ideas? I have followed his instructions and posts in the past. Is the current OSMC based on KODI 18 or 19?

The current stable version of Kodi is based on 18.x (Leia).

1 Like

Thanks!

I think it’s time to update that old guide, since how it’s writen now, you manually have to download a new zip and update the addon manully. They have started two repositorys which support updateing through the gui (i belive). I will actually take some time to do it tonight after the kids have hit the sack (hopefully within 30-60 mins).

1 Like

You may need to update widevine. inputstream helper told me to update one of mine today.

I’ve only recently signed up for Netflix, and noticed some videos (such as the “planet earth” series, which is 1080p HEVC) starts to choke very fast, as soon as it shows the 1000s of penguins in the first minute, it goes to like a 10fps framerate, and shortly after starts losing audio sync. does that on both my veros (the vanilla one on the offical 3.14 release, and the one on the testing/buster release). (my rokus don’t seem to have that trouble). Is that a general netflix plugin thing? (inputstream adaptive just can’t handle it?) or is that related to the HW decoding on the veros?

Well, widevine issues are to be expected since it’s updated regulary outside of the scope of this plugin, this plugin uses widewine, with the help of inputstream_helper plugin, but it’s developed and maintained by Google, I belive.

When it comes to 1080p content on Netflix with our beloved Vero4k(+), it’s at best like 22 fps, due to it beeing software decoded. We are in the same boat as on most Linux distrobutions (in order to hardware decode there alot licesing issues that needs to be taken care of) . I know Sam have looked into this from time to time. I just don’t remember his last thoughts about it.

But in short the CPU power of the Vero4k(+) limits software decoiding to 720p, but be aware that Netflix also impose some resolution restrictions from time to time to us poor Linux folks.

I thought HEVC was hardware decoded. I’ve got plenty of local HEVC videos that play just fine. I played around with the “expert” settings, and VP9, and h264 show the exact same issue. Setting the “limit resolution” to 720p does make it play smoothly though. (not as pretty though).

Here is an old discussion about the subject:

Worth the read if you wanna know abit about why it wont work. Even though the Vero4k has HVEC hwdecoding, widevine needs a special licesnse/level for your hardware device to enable the hardware decoding, which, as i understand it, might limit the open source part in OSMC. But as i said, Sam has the better view about the real license/level issues here.

Appreciated! I owe you a beer if you happen to pass by, once this Corona-thing is over :slight_smile:

Files from your storage and most addons like twitch or YouTube are hardware decoded but Netflix can’t be

So the issue is really on decoding wide-vine (the encryption), rather than the codec of the video, would that be correct? Or is it a matter of Netflix itself wanting a license payment to use hardware decoding?

Currently, Widevine L3 can be achieved using ARMv7 Chromebook libraries that utilise expensive CPU cycles decrypting frames and then have the potential opportunity of passing them to an HW decoder.

Widevine L1 is what is strived for to achieve playback of higher quality streams.

Netflix is a separate entity and usually want an ESN (their method of licensing) to provide the full bells and whistles. I believe Amazon also have their own key management system.

Generally – these services will give you a stream if you comply with Widevine, but the quality is at their discretion and 1080p in software can be tough.

Sam

As Sam says, it’s both, really. As I understand it, the video streams that Netflix makes available are encrypted; Widevine is the only piece of software that can decrypt them, but it’s very much a “black box” - closed source.

Widevine can operate in three different modes, and each mode has different licensing requirements. The “best” mode, L1, can only be used on a device which uses an approved, closed-source operating system, and which has a locked-down bootloader that doesn’t permit any other OS to be installed on it. The mode in which Widevine is allowed to operate on a device like the Vero 4K (which I guess is L2…?) disables hardware video decoding.

On top of that, when a Widevine device connects to Netflix’s servers to access an encrypted video stream, the device identifies which mode Widevine is running in, and Netflix decides which streams it will allow that device access to, depending on which mode Widevine is using.

So, on the Vero 4K, Netflix’s 4K video streams can’t be accessed at all - that would require Widevine L1; 1080p streams can be accessed, but Widevine only allows them to be decoded in software, and the Vero’s CPU isn’t powerful enough to handle that; 720p streams are also accessible, and there is (usually) enough CPU power to handle them in software.

Other video vendors have even more stringent restrictions. Amazon Prime video, for example, doesn’t allow access to any streams above 960x540 resolution.

So, the fact that a given mode of Widevine only allows software decoding is Widevine’s decision; the fact that Netflix’s video streams can only be accessed by using a software-only Widevine mode is Netflix’s decision.

Is this the correct way to install netflix on Vero 4k?

After installing OSMC and completing the configuration of the first boot, you must connect from the computer with a terminal software that support SSH connection type.

On MacOS you can use Terminal app, on Windows Putty, on Linux use the “ssh” command.

You can find some detailed instruction on OSMC WIKI To connect to OSMC, you need the IP address of device and user/password (default credentials on OSMC WIKI)

After establishing the connection with a terminal:

  • In the terminal run these commands:

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install python-crypto
sudo apt-get install build-essential python-pip
sudo pip install -U setuptools
sudo pip install wheel
sudo pip install pycryptodomex

  • In the terminal run these commands to download the Repository zip:

USE THIS FOR KODI 18 LEIA: wget https://github.com/castagnait/repository.castagnait/raw/master/repository.castagnait-1.0.1.zip USE THIS FOR KODI 19 MATRIX: wget https://github.com/castagnait/repository.castagnait/raw/matrix/repository.castagnait-1.0.0.zip

  • Now open Kodi and in the Add-ons browser, choose Install from zip file
  • Navigate in to the Home folder
    then install the repository file repository.castagnait-1.0.x.zip
  • Return to the add-ons browser and choose Install from repository
    then select CastagnaIT repository and install Netflix add-on

There’s a script which speeds things up a little:

2 Likes

I did some changes the other day to that script, haven’t had time to test it yet, but the manual instructions should work if the script is acting up. Please Feed back if there is issues.

1 Like

[quote="[HOW-TO ALL PLATFORMS]Can I use Netflix on OSMC?(post 4) Help and Support, post:4, topic:54741"]
wget https://raw.githubusercontent.com/zjoasan/netflix-install-script/master/netflix_prep_install.sh chmod +x netflix_prep_install.sh ./ne…
[/quote]

OK, ie:
sudo apt-get update
sudo apt-get dist-upgrade
, ie sudo reboot
after reboot:
wget https://raw.githubusercontent.com/zjoasan/netflix-install-script/master/netflix_prep_install.sh
chmod +x netflix_prep_install.sh
./netflix_prep_install.sh

Did that and it acts like before, ie I select the plugin under videos/plugins. I am presented with the list of users. Select any if them and I am thrown back to videos/plugins

Okey, sounds strange. Would you please uninstall the plugin and all userdata (usually ask if it should). There have been quite a few changes in the addon, so old userdata/authentication can mess it up.

But, since you downloaded and run the new updated script, you should now have a Netflix repositry zip. Install that repository and then Netflix from it’s repository.

When it’s installed, you should get a “Background service starting” notice, after that you should try to start the addon and log in.

I know sine before, you porbably know too, that running this addon, while connecting through a VPN provider won’t work.

In Kodi:

goto Settings
choose Add-on browser
choose Install from zip file
navigate to homefolder (homefolder/addons, if you used the script)
choose repository.castagnait-1.0.1.zip
Return to the add-ons browser and choose Install from repository
then select CastagnaIT repository and install Netflix add-on
go back to main menu
goto Video->Video add-ons
If you dont have netflix there, go to my addons, video-addons, netflix and enable.
First time you start Netflix it will ask you for your login credentials.
When you first start a video in netflix plugin, it will notice you dont have libwidvine installed and help you install it. (takes a while, will download an image and extract the latest liwidvine, and install it. Let it run as root, when it asks)