Network issues since Dec update

Also where can I find out the smb settings for kodi and windows? I’ve tried googling where to no avail!

OSMC: Settings -> Services -> SMB Client

For the Win10 side

Thanks guys, I’ll have a look at kodi shortly. Fzinken, I did see that link but didn’t want to start turning different types on and off without advice! It says that the standard Windows 10 smb is V3.

Correct and I wouldn’t change it. Just use the comments to ensure it’s enabled

Ok I’ve checked both Kodi and the server and they are running Smbv3.

Has anyone had a chance to look at the above log from the kodi smb client? If I’m reading it right it seems to be continually authenticating each and every directory on the server over and over?

Well have to admit I can not really seeing whats going wrong from the log. What really wonders me that you even have smb messages in the system logs.
What you could try:

  1. Check your .kodi/userdata/passwords.xml and check if username/password is correct
  2. Try from coomand line with smbclient to access the files and see any errors

That is the log with smb specific logging enabled, someone previously recommend that I should post it?

Should there be that many smb authentication entries? It just continuously kept doing it.

The passwords.xml is slightly strangely formatted, it doesn’t list all the source shares but only has two with a from/to structure. Here is a copy -

smb://192.168.0.11/Series smb://LOGIN:PASSWORD@192.168.0.11/Series/Comedy/

The name login and password are correct though. As I said I don’t have a problem accessing any of the shares or the files, just that the connection is so slow that HD content is unplayable due to jerkyness. The same file on a usb plays no issue.

Happy try via the command line but I’m afraid I’ve no idea how to do that?

Well that was me, but I didn’t assume it end up in system log

Ah ok, well I couldn’t see any other log where it went? Where should the component logging end up?

Also not sure why the above code is half disappeared, altho I’m writing this on an iPhone which doesn’t help.

My sincere apologies we had many threads with people having access problems after the update that I didn’t checked the details of your problem and thought you can not access.

So let’s reset ourselves and start from scratch:

  1. Disable all component specific logging and the debug logging
  2. Check you network throughput between OSMC and Windows with iperf3
  3. Try to copy a file via filemanager (Setttings -> Filemanager) and time the duration to estimate the throughput

I had similar problems. Try SMB mount from commandline (mount.cifs) and play movie from that mounted directory.

Thanks fzinken. All logging cancelled and below is the results:

I ran iperf3 from osmc to both the server and to my PC, with each both being client and server. It gives a fairly consistent 93-95Mbit/s.

However trying to copy a file from the server to OSMC is much slower. I tried a number of different files and used both the SD card and USB drive and only averaged around 1-1.5Mb/s (both timed and from the speed estimate in kodi)

Thanks Beam for your input, how would I mount a Smb share from the cli? Isn’t CIFS part of smbv1? or am I getting confused (easily done!)

I am still wondering how that can be related to the December Update.
Anyhow maybe try the fstab based mount as @Beam suggested.
Details are here

Well it was all working fine before the update, however I will try to mount one of the shares and see if the performance is better, although its not ideal as I have a Mysql database and if I change all the shares its a going to be a pain to have to rescan all of the media!

Well first check if it makes a difference. If it works with fstab mounting that you can use path substitution to match the Database entry
http://kodi.wiki/view/Path_substitution

Hey guys. Sorry for the delay,I’ve been away with work.

I’ve had a good play around with lots of different settings and I’ve found that it was to do with an add on that I’ve been using. I use Watchdog to keep all the media updated, I found disabling this fixed the issue. On further investigation it turns out my wife had plugged in the old Rpi2 to watch some tv and so we had two devices constantly checking the sources for updates. As such the strain of this meant SD shows played ok but the HD didn’t have the bandwidth. Thanks for all your help though!

On a separate issue osmc popped up saying that an update has failed to install and to post on the forums. Shall I open a new thread for it?

I tried using the cli but that had an error as well.

Yes open new thread and add grab-logs -A output

Recently i had face some similar issue, after read your thread it could be related with WatchDog since i use it as well and yesterday i noticed it was taking a lot to update just a couple of Movies/TVSeries

My thread is in case is useful too: SMB issue since last upgrade - #18 by Tom_Doyle

Thanks for sharing the link I will check and hope it helps. :slightly_smiling_face: