New osmc install gives sad face on streaming add on

My vero 4k was getting a bit cluttered up with all the junk i had on it so I reinstalled OSMC. Everything works fine like playing shares from PC, streaming from my seedbox but when I tried to stream some sport from my Spark sport addon it get sad face before the video starts and back to main kodi menu.

The only thing I have installed since OSMC reinstall is the spark sport add on, which worked fine before I performed the reinstall of OSMC. I haven’t changed any settings or anything,

Could it be that addon needs a working widevine installation?

Upon installing the Spark Sport app, it automatically installs the latest version of widevine. Version 4.10.2449.0

Nice. I haven’t used that addon, but I know that it doesn’t matter which addon that get libwidevine into the system, the problem is that the OS needs to have a few modules installed, in order to manage the “widevine decryption magic” which my script aims to fix.

I turned on my tv today to discover a OSMC update waiting. I Updated and tried the addons that require widevine. They all worked.
The issue solved itself I guess.

Thanks :slightly_smiling_face: