New Vero 4K+ goes into blue screen loop when switching AVR source


I just received my 4k+ today and so far I’m happy with the quality, but I’m having a problem. When I first set it up, I went through the install process and then did the update process through the My OSMC section. When it rebooted, the GUI would not come back up. I unplugged and replugged the unit and everything was fine.

Now every time I switch the source on my AVR to something else and then switch back, I get the same blue screen and have to unplug/replug. I can still access SSH and I’ve tried restarting mediacenter through systemctl, but it just comes back to the same blue screen until I physically unplug and re-plug it back in. I also just had the same issue after attempting to play a movie via the PlexKodiConnect app. It loaded the intro screen and then went into the blue screen.

My setup is as follows: The Vero4K+ is connected to an Onkyo TX-NR787 via HDMI which is connected to a Vizio E60-E3. All of my components go through the AVR which feeds the tv through a single HDMI.

I’ve attached logs here of the failure using PKC :

and here of the failure attempting to restart using systemctl:


Welcome to the forum, and thank you for explaining the problem in detail. The only thing missing is could you turn on debug logging (Settings-System-[set level to Standard or above]-Logging-Enable debug logging).

To get to a known state, can you set your display to 1080p60Hz (there is no benefit in setting it to 4k) and disable Plex and see if it’s any better? Post logs again if you still get a sad face.

Thanks for the quick response. Changing to 1080p60hz does seem to solve the BSOD problem, but now my AVR freaks out when I try to play any file, flipping rapidly between no output followed by a few seconds of the file in a loop. I’ve also uninstall PKC for the time being so that one problem at a time can be fixed. It may also be helpful to know that the files that I’m trying to play are 4k HDR with 7.1 TrueAudio Atmos, both of which my AVR and TV can play with direct stream. I’ve also made the necessary changes to the audio settings (7.1, enabled TrueAudio and Passthrough).


Did a fresh start by moving the kodi directory and removing the walkthrough file and didn’t change the Interface resolution this time. Seems to have fixed the blue screen and direct play from NFS. I’ll tinker with the PKC again later when I have more time. Thanks again for the help!

Did you enable adjust refreshrate on start/stop?

No it’s set to Off in the log. Should still play at 1080p, but I don’t know how this interacts with Plex.

I meant after the clean Kodi approach assuming that it still works fine then

1 Like

Sorry, had to grab a few hours of sleep. I tried turning it on when I was having the problem, but it didn’t make any difference. After the clean approach I didn’t touch anything in the display section.

Ok, while you would need to enable if you have a 4k TV

Interesting, I’ll double-check it when I get home but a quick test last night played the file fine and did initiate both the 2160 and HDR lights on the Vizio. I’ll report back this evening.

Ok, so apparently I’m not fixed. I checked and fzinken is right, the Vero was only outputting 1080p with the auto adjust refresh rate setting turned off. When I turn it on, I’m back to the problem of the AVR cycling between the video and no source rapidly. Here’s the log from when I tried playing Infinity War with auto adjust refresh rate set to start/stop:

And here’s the debug log from within OSMC:

So to sum up where we are now, I can play everything in 1080p fine if auto refresh is off. I can play everything in 4k HDR fine if I set the interface to 4096 x 2160 but then I have to manually unplug/replug the Vero everytime I change the AVR input. If I leave the interface at 1080 and turn auto adjust refresh rate to start/stop, files become unplayable with the AVR rapidly cycling between no source and the video with no audio.

What HDMI cable do you use between the Vero and the AVR? Any chance to cross-change this with another 4k device working with the AVR?

I had that same though. Swapped it with the cable that works perfectly with my Roku Ultra and still had the same problem, though. :frowning:

Ok, next basic to check: Latest greatest firmware on the Onky? There was an update in Dec 2018 regarding stability (whatever this means), see

Yup, the TV/AVR/Vero are all on the newest firmwares.

Just to clarify: Is this “blue screen” something from the Vero or the AVR? Any logo visible?

Sorry, that wasn’t clear. The blue screen comes from the AVR not being able to find or play a signal.

Ok, just to take out the Onky out of the equation: Is this issue also reproducible with a direct HDMI connection between the Vero and the TV? I don’t know this TV, but if possible to do this test be careful to connect it to a 4K capable 4k HDMI port, then.

Ok, the file plays perfect when connected straight to the tv, though obviously without Atmos.

Just a note, I get the same blue screen when I swapped the HDMI back to the Vero from the TV, which isn’t unexpected, but given it’s the same symptom could it possibly be a handshake issue? I’m just tech savvy enough to be dangerous but not savvy enough to really interpret the logs that I posted.

Edit because apparently I’ve reached my post limit for the day? I understand cutting down on spam, but that makes life more difficult.

Just tried disabling TrueHD and using the DTS track. The video plays smooth with this setting but the audio still skips repeatedly.

For what it’s worth, I’ve had no problem playing Atmos audio through the Xbox One X that is also attached, so I know it is capable of utilizing it.

I do believe it to be an issue between the Vero and the Onkyo after tonight’s troubleshooting, though.