New Vero 4k, no center channel audio, channel mapping issue

I just received my new Vero 4k. Did a full round of updating to current etc. When I try to play any of my movies I get what appears to be no center channel audio.

My setup is a badass receiver (HDMI). I have the system configured for 5.1 and passthrough on the audio. This works perfectly on the Pi3 that this Vero 4k is replacing. My receiver is showing proper audio codec and channels but I literally have no center channel audio outputting. I have tried a dozen different files just to be sure. Only way I can get center channel is to change from 5.1 to 2.0, but of course that eliminates the surround.

I’ve tried all manners of adjusting the settings and I cant get this to work. Please help!!

Never heard of that brand before. Maybe telling us the actual brand and model would be more helpful. And as always:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Its a Pioneer Elite VSX-LX301… but I honestly don’t see how that matters since it appears the channels are not being properly outputted from the Vero. (I have it set to passthrough). I’ve run Pi’s with OSMC for years without issue across a broad range of receivers and this is the first time Ive seen this. Going through the forums, I can see others have had similar issues, but I haven’t been able to find any concrete resolution as of yet. I’m short on information, but it appears that things were fine until the july '17 update when there was an audio driver update.

I will look at your link to submit a support request. I was just hoping it was a known issue with an easy fix I could apply.

Since you’ve done some searching, you should have also noticed that screenshots of your audio setup pages can be helpful.

Is the problem with all media, or just some? If it’s just some media, then mediainfo can also be helpful.

Here are the basic proper settings:

Audio Output Device: AML-M8AUDIO, HDMI
Number of channels: 2.0
Output configuration: Best Match

Its all movie files I have tried to stream to it. Most everything is AC3 or DTS, and they all have the same issue with no center channel audio. I do have it set to AML-M8AUDIO, HDMI and Best Match. If I change Number of channels from 5.1 to 2.0 with passthrough disabled I get the center channel back, but then I lose surround sound. No matter what I set anything to, if I enable passthrough, (which is what I want), the receiver indicates all 5 channels and proper codec, but I have no center channel audio.

Thus far the only way Ive been able to get any center channel audio is to have passthrough turned off and number of channels set to 2.0. This is obviously not acceptable for my surround sound desires… hehe :slight_smile:

What happens if you have # channels 2.0 with passthrough on? I did forget to mention that Passthrough should be on with the other options.

Same deal. If I have channels set to 2.0 with passthrough on, including all the sub passthrough options… I get no center channel output.

I tried a number of fixes outlined in some other posts with no luck, so Im wondering if I need to repave the install to fresh if we are going to troubleshoot.

So just to be clear…

channels set to 2.0 and passthrough off = good center, no surround (receiver displays front and center speakers)
channels set to 2.0 and passthrough on = no center, good surround (receiver displays all 5 speakers)

channels set to 5.1 (or 7.1) and passthrough on or off = no center, good surround (receiver displays all 5 speakers)

Ok, logs and screenshots of your audio setup page are needed at this point.

Ok, I will see what I can do about getting the logs. Screenshots should be easy, but Ive tried every combo of options on those settings. Everything works perfect on the Pi2 & 3 with the settings Ive used for years.

And thank you for your help!

Hmm, just a thought, but you could try resetting the Kodi configuration. Maybe something got hosed up. If you can SSH into your 4K:

$ sudo systemctl stop mediacenter
$ mv .kodi
$ sudo systemctl start mediacenter

You will need to set your sources again. But that will make sure that there are no other changes or no addons that could be causing a problem.

Ok, I did that and re-setup everything… no joy/same issue. Only way I get center channel is setting to 2.0 channels and passthrough off which also eliminates surround etc. Any other config = no center channel.

I will note that this is a raw install, no addons. Just cracked the box open upon arrival today and ran updates.

I wish you had said that before. But anyhow… I’m about out of ideas, except: Have you tried another HDMI cable?

If swapping cables doesn’t do it, then logs and screenshots.

Its the same cable (4k compliant) I used with the Pi3 that it replaced. I can try another cable though. Based on what I’ve seen in the forums though, this seems to be a real issue that others are experiencing. I will see about getting some logs.

I must really be missing something. I’m not aware of this other than a few reported problems with HD audio and Denon receivers.

While I assume you are refering to the discussion in this thread you could try the hotfix mentioned in there

I tried this already with no success. I was really hopeful when I found that in the forums but still no go. I still have no center channel with passthrough enabled and more than 2.0 channels selected :frowning:

Ok, than it must be a different issue. Suggest you provide debug enabled logs and the screenshots of the audio settings and hopefully tomorrow someone with more audio knowledge can try to help.

Thank you for the assistance, I really appreciate it. I guess I’ll need to figure how best to gather the necessary logs. I wasn’t expecting this after years of non-issues on the Pi, but at this point the Pi’s don’t have the horsepower to keep up. I have several more orders for the Vero 4k that I have to hold on until I sort this audio issue out.

I gave you a link how to provide logs. You can do it from MyOSMC. Just make sure you turn on debugging.

roger that… I will work on that now