New Vero 4k+ - Problems playing/scrubbing movies


I just received my second Vero 4k+.

After setting up with the Vero to pull media from a Synology 1819+ NAS (via SMB), I discovered an issue with all media (HD or 4k) where the Vero would attempt to play the file, the screen would switch/go blank as if it was about to start displaying the movie, but then revert back to the 'Movies ’ menu (ie the wall with the covers).

With 4k movies, it was more likely to jump back to the Movie page rather than start the movie…however if it did start the movie, if you fast-forward at all, you immediately were ejected back to the Movie Page.

With HD files, you were more likely to have the movie start, however upon fast-forwarding, again you are returned to the movie page.

When this occurred the Vero seemed to operate as expected…ie it hadn’t ‘crashed’, and appeared operable, other than not playing files.

I immediately suspected the network. I am using a Synology RT2600ac, with a wired connection to the Vero and the NAS. I use the same network for work and achieve an easy 120mb/s transfer speed between a desktop and the NAS with an approx equivalent cable length between.

My investigations involved removing all other devices from the network to see if the issue persisted, leaving a single dedicated link from Vero to switch, with the problem still persisting.

The same network infrastructure has been working with a AppleTV4k, running MRMC with no similar issue.

A Full set of logs are here - [https://paste.osmc/tv/ujaneyiseb] https://paste.osmc/tv/ujaneyiseb)

Can someone have a look at the logs to see if the issue has been recorded…and advise on a fix.

I really like the Vero Product…I passed my original 4K to my sister so I had an excuse to get a 4k+. I have faith that Sam and the team will help us Id the issue and resolve!



How would that be a number on a proper network? EIther it would be 92mb/s on a 100 Mbit or 920mb/s on a 1000 Mbit network. Everything differnent than that would indicate a problem. Did you test with iperf3?

Actually found the reason in your logs files. You have Ethernet and Wireless enable! Disable the Wireless interface!

Hi Guy’s,

Thanks for the fast responses…

I was thinking someone may call out my quoted network speed…yes I was slightly high…just re tested, 85-111mb/s range.

Thanks Fzinken for the test suggestion and guide…setting up the test now…

As for the wireless…my bad. I left that on after I was trying to find the source of the problem. The problem persists even when the wireless is disabled.

I will run the network iperf3 test first, see the results and then get in touch if still unclear as what is the issue.

Hello Again.

Ok I have run iper3…results below…


For a gigabit network…they look as expected, 920-935Mbit/s.

So I have relogged the issues, this time with the wireless adaptor off.

Logs are here…

For a point of reference the files I selected to trigger the issue are 1917 and A Bugs Life. Both 4k, I have attached a MediaInfo Text export of the files here.

The issue also is evident with non4K media.


Ok, for the two 4k movies the issue could be that they have TrueHD audio, see this.

But that would explain the issue you have with the other Movie that doesn’t have TrueHD Audio, but I couldn’t find that being played in the logs.


I have tried a file without TrueHD…same result…MediaInfo file can be found here (Blood Diamond)

Vero Logs are here…

2021-06-05 13:58:23.851 T:3536822496   ERROR: ffmpeg[D2CFA0E0]: [mov,mp4,m4a,3gp,3g2,mj2] stream 1, offset 0x960236: partial file
2021-06-05 13:58:23.877 T:3473875168   DEBUG: Thread FileCache 3473875168 terminating
2021-06-05 13:58:23.937 T:3560960224   DEBUG: CDVDClock::ErrorAdjust - CVideoPlayerAudio::OutputPacket - error:-25645.790142, adjusted:-25645.790142
2021-06-05 13:58:23.951 T:3536822496   ERROR: ffmpeg[D2CFA0E0]: [mov,mp4,m4a,3gp,3g2,mj2] stream 1, offset 0x960583: partial file

Suggest to copy the file to the emmc to exclude the network as an issue.
As you use synology NAS you might also want to try
Settings → Services → SMBclient → Mitigate MTU issues with SMBv2

Thanks for the suggestions…as soon as I deal with the kids…and grab a beer…I will give it a go.


Ok…so when I copy files onto a SD card and read from that…no problem, for either the HD or the 4K media. The logs (using media stored on a SD can be found here… I used Blood Diamond again, but had to use a 4k episode of The Grand Tour otherwise I didn’t have a large enough SD card.

As suggested…I also switched the SMBclient → Mitigate MTU issues with SMBv2.

With regard to network stored media, this improved the situation. Now there are no issues with HD media, but 4K media now loads and plays, allows some scrubbing but then results in the “Unhappy Blue Face” and being returned to the menu. I have logged this event, they can be found at… The Media used was the 4K version of 1917 referenced earlier.

By the way…thanks Fzinken for your efforts in working through this.


1 Like

Just to be sure: You’ve set highest available SMB protocol on the Synology like

Next level could be to use kernel mounted SMB shares instead using the kodi built-in samba stack.

Hi Everyone,

Looks as though we have solved the issue…

The Synology NAS is or was part of the issue, once we updated its SMB settings…the Vero runs as expected…almost flawlessly…except for the aforementioned scrubbing issue when viewing TrueHD media, in that left and right scrubbing works, however if u use the up or down arrows to ‘jump’…the Vero gets ‘unhappy’, shows u a sad face and kicks you to the menu. I can work with this while a fix is sorted.

I would like to pass my thanks and appreciation onto the OSMC team and wider community. It is this level of support that made me come back to OSMC and Vero. Nothing against the guys at MRMC…but you guys are on another level. Well done and keep up the good work.

OSMC, Vero and a great support community, an outstanding combination.



Glad to hear this is solved.