Newb questions.. :(

Hello folks,

a good friend suggested me a Vero 4k to replace the Roku as I was sick of non-stop the video format support issues.

this said, the magnificent piece showed up last night, I connected it… and now sitting with the “now what?” question.
My set up is as follows:
Windows 10 Home PC (will be upgraded to pro in a bit) dedicated to serving video data from 3 shared folders. Currently, it is running Serviio server because Roku isn’t smart enough to see shared drives on its own.
Vero is connected via 5ghz wifi channel, and is the only device sitting on it; I know it is seeing the wifi - the IP address was obtained, and it sees internet - it pulled weather.
questions:

  1. How do I get Vero to see my shared drives? I am not familiar with samba; is there a step by step instruction for this?
  2. Is there a way to configure Vero to have several shortcuts to the shared folders? (It needs to pass the wife test. Say, if you select “Videos”, can the next option be “folder A”, “folder B” and folder C"?)
  3. Is there a way to remote into vero to make the changes or do I have to make all the changes via UI?

thank you in advance

1 and 2. are covered here: http://kodi.wiki/view/First_time_user

You can login via the command line. More information is here.

Sam

1 Like

thank you sam. reading right now.
I am starting to suspect that i’m not smart enough to get it working… :expressionless:

command line is the only option for remote access, right? no gui RDP?

There’s a VNC server, but you will see what
you see on your TV.

Going to Videos -> Add Source will allow you to add
network sources.

You can connect to your windows shares without the command line. However, the built-in library that lets kodi do it from its own gui isn’t as efficient as making a direct connection via your fstab file.

Do you have any other Windows machines on your network that you can use to make sure you have your windows shares accessible? You won’t need that special server software that you used with the Roku.

Once you have other Windows machines that can see your shares and access them, you can use the “add source” function to browse your network and add a source in Kodi.

how do I start the VNC? I do have putty installed, and am able to connect via command line.

I did, initially, try to go to Videos and add source, but Revo says that it doesn’t see the path (neither the network path nor the IP).

I am curious about VNC as I am RDPing into the Windows machine from work atm, and if I could try setting stuff up without being in front of the tv, it would be a huge plus :slight_smile:

All my other devices on the network are able to see the shares; I have 3 apple machines and another win 7 based laptop that is able to see the drives.

Well, I’m home for the moment.

Confirmed folders are shared and are visible by other machines.
Ex \media\shows (or 192.168.1.61\shows).
Go to add video, browse… and when entering the address, I’m told that the system was unable to locate the path.
I really don’t know what I’m doing wrong.

Browsing does not work in the current version of Samba. You can manually enter the path name and it should work. But this is linux so instead of \ use /.

It may help if you post logs.
https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Would i use /192.168.1.x/folder?
When i enter that i get “couldn’t retrieve directory information. This could be due to the network not being connected”.
I’ll try pulling logs in abit.

Also, just realized, that weather is not being updated. I added Yahoo plugin to confirm that it can see wan, but it just shows empty screens.

Is able to ping my home server from the command prompt… it feels like the credentials somewhere are missing

Erm. I think i just uploaded logs by sheer accident.
https://paste.osmc.tv/livesazizi

To start tracking the problem down, install the smbclient on your Vero 4K.

From the command line:

sudo apt-get install smbclient

Once smbclient is installed, try this:

smbclient -L 192.168.1.61

What do you see? You may need to supply a -U username option

Also I would strongly suggest that you mount the drive via FSTAB instead on in Kodi for performance reasons. An example of a line to add to your /etc/fstab would be:

//192.168.1.61/Shows /mnt/Shows cifs x-systemd.automount,noauto,iocharset=utf8,user,username=<user on server>,password=<your server password>,uid=osmc,gid=osmc,iocharset=utf8,file_mode=0770,dir_mode=0770 0 0

Then run

sudo mount -a

to test the mounts.

aha…
when running smbclient -L command, i am asked for osmc’s password.
Is this the share password or OSMC?

Use the -U username option if the share is password protected.

It’s the password of the SMB server on 192.168.1.61

ok, I feel like i’m getting there.

sbmclient -L 192.168.1.61 -Umedia

yields list :
Enter media’s password:
Domain=[MEDIA] OS=[Windows 10 Home 15063] Server=[Windows 10 Home 6.3]

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    C$               Disk      Default share
    D$               Disk      Default share
    Fresh Media     Disk
    Good movies     Disk      Movies we liked and kept
    IPC$            IPC       Remote IPC
    Media           Disk
    Movies          Disk
    Shows           Disk      TV Shows we liked and kept
    Users           Disk

Movies, Media and Shows folders are the ones I need to make available.

also, how do I access FSTAB?

i’m sorry about these stupid questions; this is my first serious experience with Linux platform

Taking Shows as an example, you need to add the line in the third box in post #11, remembering to substitute the username and password, to file /etc/fstab.

sudo nano /etc/fstab

Ctrl-X to save and confirm with Y.

Then to mount the share:

sudo mount /mnt/Shows

Repeat the above for Movies and Media.

thank you

I added the following lines (now when I run the sudo nano /etc/fstab, I see them
//192.168.1.61/Shows /mnt/Shows cifs x-systemd.automount,noauto,iocharset=utf8,user,username=media,password=1,uid=osmc,gid=osmc,iocharse$

rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)#/dev/vero-nand/root / ext4 defa$

//192.168.1.61/Media /mnt/Media cifs x-systemd.automount,noauto,iocharset=utf8,user,username=media,password=1,uid=osmc,gid=osmc,iocharse$
//192.168.1.61/Movies /mnt/Movies cifs x-systemd.automount,noauto,iocharset=utf8,user,username=media,password=1,uid=osmc,gid=osmc,iochar$

however, when I go to sude mount /mnt/Shows (or any other name), I get an error
Couldn’t chdir to /mnt/Movies: No such file or directory

P.S. is there any literature you guys would suggest to learn the basics? I see the commands, but I know not what they mean, and that bugs me; I feel like I should learn this stuff

The lines from your /etc/fstab are all truncated and end with a dollar sign. I assume that this is just a copy/paste issue but, if not, you need to fix it.

Regarding the mount error, first try rebooting the Vero4K. If that hasn’t worked, I guess you could try:

sudo mkdir /mnt/Shows
sudo mount /mnt/Shows

User name is Media and Password is 1 (I know, it is VERY secure).
the dollar sign, is, in fact, the truncated line; it shows the full line from post 11 in the actual screen.

rebooted Vero; now I am getting a different error when trying to mount it
mount error(16): Device or resource busy
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

So, i does feel like the credentials issue

the entire strings are these:
//192.168.1.61/Shows /mnt/Shows cifs x-systemd.automount,noauto,iocharset=utf8,user,username=media,password=1,uid=osmc,gid=osmc,iocharset=utf8,file_mode=0770,dir_mode=0770 0 0
//192.168.1.61/Media /mnt/Media cifs x-systemd.automount,noauto,iocharset=utf8,user,username=media,password=1,uid=osmc,gid=osmc,iocharset=utf8,file_mode=0770,dir_mode=0770 0 0
//192.168.1.61/Movies /mnt/Movies cifs x-systemd.automount,noauto,iocharset=utf8,user,username=media,password=1,uid=osmc,gid=osmc,iocharset=utf8,file_mode=0770,dir_mode=0770 0 0

thank you so much for your patience with me.