News feed is not displayed

Hi
News feed option is enabled, but still no news feed is displayed.

Thanks a lot

Hello

Do you mean RSS feed?
If so: which skin are you using?

Sam

Yes
I use Estuary and Aeon Tajo.
No RSS feed is displayed with both skins.

Then more information is needed. Like what’s the RSS feed. And of course logs.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

The problem is simple to understand.
Since the last software update, the standard OSMC RSS news feed is no longer displayed.
Previously, the OSMC RSS news feed appears immediately on the skin if you have enabled the option in the Kodi settings.
I also did a Kodi reset, but the default OSMC RSS news feed is not displayed.

And what I asked you to do was also simple. Provide logs. Sorry that we are not mind readers here.

It is not necessary to read minds.
But you can think about it even without logs.
But the question of logs is always such a question to look for the problems at the user.
It seems to be a general OSMC problem.
Kodi is clean after a reset.
100% clean and nothing else installed.
I just enabled the default RSS news feed and still no default RSS news feed is displayed.
LAN and internet also work on the device.
Has the default RSS news feed URL been changed?
Do I need to change something in the Vero 4K+ for this as well?
Logs will come later.
Just patience.

@ser.vie Thx to make us aware of this!

Could you please try to change the content of the file

/home/osmc/.kodi/userdata/RssFeeds.xml:

Change the line

<feed updateinterval="240">https://blog-cdn.osmc.tv/rss/</feed>

to

<feed updateinterval="240">http://blog-cdn.osmc.tv/rss/</feed>

so, replace httpsto http and let us know whether this helps as workaround.

I will try out it tonight.
Has this been the only URL change?
I have the feeling that no updates for Apps and OSMC are found either.

Unfortunately, the link cannot be changed.
After saving it is always displayed only
http://blog-cdn.osmc.tv/rss/&lt;/feed&gt;
The RSS feed is still not displayed.

Just retried with Vero4k+, OSMC stable release

OSMC skin:

Estuary skin:

@bmillham asked for log data but you did not follow his advice

How to change in the GUI

Thanks a lot @JimKnopf
With OSMC skin I will try it.
How to change the position of the RSS feed?
My RSS feed was always on top.
My OSMC GUI is set to 4K.
Maybe it is the problem?
The RSS feed is only out of view?
Sorry
Enable log files is not the problem.
But how to upload the log files?
I don’t know anything about SSH yet.

This is not recommended and you don’t gain quality with that.

Possible, did you configure your TV for 1:1 or Just Scan?

You can just use MyOSMC -> Log Uploader

@fzinken
Which OSMC GUI resolution is recommended?
TV is configure for Just Scan.
“Log Uploader” ? I go in search of this function.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

1 Like

Thanks a lot @JimKnopf and @fzinken
I was able to change and save the RSS feed link with the OSMC skin.
After changing the GUI resolution to 1080p, the RSS feed is displayed again.
Recommended changes set and whitelist activated and resolutions set.
All videos are played correctly.

So 14 days ago, I asked for logs. You refused to do that. If you had, we would have noticed right away that you had the GUI set incorrectly. There is a reason why we ask for logs…

My sincere apologies @bmillham
But sending the log files is not really “user friendly” for beginners.
But the main reason was not the 4K resolution setting.
The main reason was that you changed the RSS feed link without updating the OSMC clients! :frowning:
The second reason was that you can manually change the link only via the OSMC skin.

Well I have to disagree with this statement.

Maybe the “how to upload logs “ guide could be simplified but the procedure of uploading logs is literally just pressing up, down and ok buttons on your remote and clicking through 2 menus displayed on your tv.

I mean reading and navigating teletext is hard compared to this