NFS and SMB, Neither work well!

I tried it both ways, about the same result, looks like there is nothing wrong with the network at least.

I don’t mind using nfs via autonfs, I really don’t care what I use, even if I spent money on Hanewin and have to switch to free FTP, I don’t care, as long as it works properly.
I haven’t used my media centers in 2 months now, I just used netflix on a tv because my own network sucks.

I hope you guys can help me figure it out, I really have no clue what to do anymore. There seems to be nothing wrong yet nothing works.

Then go ahead, setup is well explained in the autofs thread.

been there, done that, didn’t work! That’s why I had the NFS things in my autofs, I tried it myself but massively failed and stopped because after a week of trying it only got worse.

Well from what I saw you even didn’t had autofs installed! You had nfs configured via fstab.

That’s what I meant, fstab, lol I know absolutely nothing about networking, let alone unix/linux based networking haha

Than try autofs (as you already have installed it now).

But I get lost at step 5 :crying_cat_face: I don’t know what lines to add to my list to actually make it not start baking popcorn lol.
It’s that you gave me the line to put in autofs for smb else I wouldn’t have known either!.

this is my hanewin export

exports example

please read doc for a list of all options

drive letters should be in upper case, because file-id returns upper case

by default (option setting) they are mapped to lower case for clients

Option -range restricts access to specified address range

a list of addresses restricts to these clients only

Option -readonly prohibits create/write/delete

Option -name: makes folder for clients avalailable as /

Option -maproot: maps unix root to specified

without it uid root -> uid NOBODY

Option -alldirs allows clients to mount folder or any subfolder

Use UNC path specification for access to remote drive

Hidden volumes without a drive letter can be mounted by volume GUID

#C:\ftp -range 192.168.1.1 192.168.1.10
#C:\video -readonly 192.168.1.1 192.168.1.4 192.18.1.23
#C:\server -alldirs -name:server -maproot:0 -range 192.168.1.1 192.168.1.30
#\router\FRITZ.NAS\SanDisk-U3CruzerMicro-00 -name:fritz
#\?\Volume{6afa3aa3-1b38-11e6-a140-0000fbaa0005}\ -name:drive1

t:\Shows -readonly 192.168.1.106
v:\Movie -readonly 192.168.1.106
r:\Anime -readonly 192.168.1.106
t:\Shows -name:Shows -readonly 192.168.1.105
v:\Movie -name:Movies -readonly 192.168.1.105
r:\Anime -name:Anime -readonly 192.168.1.105
q:\Audiobooks -name:Audiobooks -readonly 192.168.1.108
u:\Movies -name:Films -readonly 192.168.1.105
u:\Movies -name:Films -readonly 192.168.1.106

I’m so sorry but I just don’t know.

Well I think it is well explain in the second section in that thread.

Can you from OSMC showmount -e 192.168.1.106
Also what is the IP of your OSMC box you are currently working with?

First change /etc/auto.master to remove the smb entry and add

/- /etc/auto.nfs.shares --timeout 15 browse

Then sudo nano /etc/auto.nfs.shares and add /mnt/Movies 192.168.1.106:/u:/Movies

This might work while I am not sure about the colon in your share name.

To make things easier for me (and maybe you too) I turned my host into 192.168.1.120 temporarily and I changed all the boxes from random 103-105 to 114, 115 and 117, with the PI as 116 because I’m messing with that one right now and I’d rather screw up my Pi than my vero haha.

I also changed the Hanewin export accordingly.

showmount will be slightly different because they are all static leases temporarily.

The lease for the pi i’m currently working on will be 116

osmc@osmc:~$ showmount -e 192.168.1.120
Export list for 192.168.1.120:
/t/Shows 192.168.1.116,-readonly
/v/Movie 192.168.1.116,-readonly
/r/Anime 192.168.1.116,-readonly
/Films 192.168.1.116,-readonly
.
I replaced smb with nfs in auto.master.

I created a new file named /etc/auto.nfs.shares (didn’t exist) and added /mnt/Movies 192.168.1.116:/u:/Movies (116 is my pi ip, the PC is 120).

Anything I can do to test?

Not to interrupt @fzinken

but as you mentoined NFS host is 120, i guess you should be 120, instead of 116, cause that is the clients IP.

furtermore it seems to continue with:

Testing the config:
After you have made the changes restart autofs:

sudo systemctl restart autofs

To test if your mounts works execute:

ls -lah /mnt/<server1>/<share1>

you should see the files from your network share. If it didn’t work run

sudo systemctl stop autofs
sudo automount -f -v -d

to debug what’s wrong. While this is running, it will appear to keep trying to mount. That’s normal. While automount is running, open another SSH connection and try:

 ls -lah /mnt/<server1>/<share1>

again while watching the output from the automount command.

To exit if running automount, just do a CTRL-C. To restart the service once everything is working, either reboot or:

sudo systemctl start autofs

Ok based on your showmount output I can not see “U” being shared and also the : as I expected is removed.
So lets use v for testing. The line in auto.nfs.shares should be
/mnt/Movie 192.168.1.120:/v/Movie

Thank you I tend to screw up anyway haha.
I changed the /etc/auto.nfs.shares to /mnt/Movies 192.168.1.120:/u:/Movies which is the host.

Ok but this is where I usually rope myself, /mnt/<server1>/<share1> in this case would that be /mnt/192.168.1.120:/u:/Movies ?
I have no idea what I’m doing when it comes to this.

Please check my correction based on your showmount output.

So that means adding /mnt/Movie 192.168.1.120:/v/Movie to /etc/auto.nfs/shares? Next to the already existing /mnt/Movies 192.168.1.120:/u:/Movies?

edit, ah i see, remove the :

As @fzinken already replied it should be

/mnt/Movie 192.168.1.120:/v/Movie

and then with the other steps in the link of @fzinken you should test it, see my lines which are from this link. As you need to restart autofs

Remove the line with /mnt/Movies 192.168.1.120:/u:/Movies for the time being. We just want one test to work first before we do clean additions of all.

OK /etc/auto.nfs.shares now only contains /mnt/Movie 192.168.1.120:/v/Movie

then sudo systemctl restart autofs and try ls /mnt/Movie/

ls /mnt/Movie/
ls: cannot access ‘/mnt/Movie/’: No such file or directory

Please paste

paste-log /etc/auto.master
paste-log /etc/auto.nfs.shares