NFS and SMB, Neither work well!

When I right click the folder, then go to share and see the “choose people to share with” window I see Everyone “Read”, Desktop “Owner” and OSMC “Read”.

Also went to Advanced Sharing > Permissions > Add. Typed OSMC in the bottom box and Check User which turned it into OSMC (DESKTOP\OSMC) and gave that read options as well.
ls still errors no permission.

Did you add “List Folder Contents” as a right?

Yes, Read, Read/Execute and List Folder Contents.

That is strange, maybe check the Windows Event Logger if you see any error when you try to access the share.
I may fire up a Windows VM later to test.

It really is weird, I’m a complete idiot when it comes to networking but if you take into account that NFS sharing “sort of worked” too it makes it even stranger. Things generally either work or they don’t, and if an error occurs there is an extensive log you can access yet I’ve never been able to find it.
I used the exact same setup as I did from RaspBMC up to the start of OSMC and then it started getting flakey, of course I did move from windows 7 to 10 in the same period but the general idea is still the same.

It might end up being one thing I forgot to toggle or one line I forgot but for now it’s a mystery to me. I see nothing (but a failing hard drive but that’s another story lol) in my event viewer that would make any sense and looking at my Comodo Firewall logs I see nothing blocked.

What I COULD do is use Comodo to log output all allowed connections from source x to device y on port a and b just to troubleshoot but as for blocking anything I don’t see anything happening, and even with it turned off it doesn’t work.

Well a “permission” issue normally would not indicate a firewall issue (BTW are you sure the Win10 Firewall is disabled)?

That is strange, if I fire up my VM later I will also check that.

Generally NFS should be rock solid. While it can be quite a hassle with firewalls.
Maybe you want to try the autofs mounting with NFS as a test if that is working better.
Also still suggest to look into your network connectivity with iperf3.

I think so, maybe? I let Win10Privacy handle that at the start of each upgrade and it looks like the little windows defense shield tells me Comodo is active as a firewall so I think so.

Ok, thank you for your time, this has been a problem spanning years and it just seems to get worse so I just want to get it fixed and be done with not knowing when my computer might or might not show me something, it’s like a theater, only running my Blu-rays on day x time y or all the time lol.

I wouldn’t mind sticking with Hanewin NFS (I paid for it) but it has to work and I don’t know how to get it to reliable. I don’t exactly know what iperf3 is, I suck at networking and my linux/unix skills are so-so at best with all the changes over the years.

I’m completely wired, the only thing between my host and devices is a new dd-wrt router and I switched modems and routers while still having these issues but I’ll run it anyway.

also how do you start it in server mode? It opens and closes right away, it’s just one exe and a dll file.

Well wasn’t it written as iperf3 -s. Assuming on Windows open command line and then iperf3.exe -s

just browse to the folder and run it like that? Documentation says nothing and clicking it isn’t doing anything lol.

windows firewall is not turned off btw, I just cot a popup, never see those.

Got it working though.

iperf-3.1.3-win64>iperf3 -s
Server listening on 5201
Accepted connection from, port 53992
[ 5] local port 5201 connected to port 53994
[ ID] Interval Transfer Bandwidth
[ 5] 0.00-1.00 sec 11.5 MBytes 96.5 Mbits/sec
[ 5] 1.00-2.00 sec 11.4 MBytes 95.3 Mbits/sec
[ 5] 2.00-3.00 sec 11.2 MBytes 94.3 Mbits/sec
[ 5] 3.00-4.00 sec 11.2 MBytes 94.5 Mbits/sec
[ 5] 4.00-5.00 sec 11.4 MBytes 95.4 Mbits/sec
[ 5] 5.00-6.00 sec 11.4 MBytes 95.4 Mbits/sec
[ 5] 6.00-7.00 sec 11.2 MBytes 94.4 Mbits/sec
[ 5] 7.00-8.00 sec 11.4 MBytes 95.3 Mbits/sec
[ 5] 8.00-9.00 sec 11.2 MBytes 94.5 Mbits/sec

Looks about right. You may want to also test reverse direction and also increase duration a bit.

Anyhow maybe try nfs via autofs.
Will see if I find time to test on Win10 to see if I can reproduce your issue.

I tried it both ways, about the same result, looks like there is nothing wrong with the network at least.

I don’t mind using nfs via autonfs, I really don’t care what I use, even if I spent money on Hanewin and have to switch to free FTP, I don’t care, as long as it works properly.
I haven’t used my media centers in 2 months now, I just used netflix on a tv because my own network sucks.

I hope you guys can help me figure it out, I really have no clue what to do anymore. There seems to be nothing wrong yet nothing works.

Then go ahead, setup is well explained in the autofs thread.

been there, done that, didn’t work! That’s why I had the NFS things in my autofs, I tried it myself but massively failed and stopped because after a week of trying it only got worse.

Well from what I saw you even didn’t had autofs installed! You had nfs configured via fstab.

That’s what I meant, fstab, lol I know absolutely nothing about networking, let alone unix/linux based networking haha

Than try autofs (as you already have installed it now).

But I get lost at step 5 :crying_cat_face: I don’t know what lines to add to my list to actually make it not start baking popcorn lol.
It’s that you gave me the line to put in autofs for smb else I wouldn’t have known either!.

this is my hanewin export

exports example

please read doc for a list of all options

drive letters should be in upper case, because file-id returns upper case

by default (option setting) they are mapped to lower case for clients

Option -range restricts access to specified address range

a list of addresses restricts to these clients only

Option -readonly prohibits create/write/delete

Option -name: makes folder for clients avalailable as /

Option -maproot: maps unix root to specified

without it uid root → uid NOBODY

Option -alldirs allows clients to mount folder or any subfolder

Use UNC path specification for access to remote drive

Hidden volumes without a drive letter can be mounted by volume GUID

#C:\ftp -range
#C:\video -readonly
#C:\server -alldirs -name:server -maproot:0 -range
#\router\FRITZ.NAS\SanDisk-U3CruzerMicro-00 -name:fritz
#\?\Volume{6afa3aa3-1b38-11e6-a140-0000fbaa0005}\ -name:drive1

t:\Shows -readonly
v:\Movie -readonly
r:\Anime -readonly
t:\Shows -name:Shows -readonly
v:\Movie -name:Movies -readonly
r:\Anime -name:Anime -readonly
q:\Audiobooks -name:Audiobooks -readonly
u:\Movies -name:Films -readonly
u:\Movies -name:Films -readonly

I’m so sorry but I just don’t know.