NFS - can browse to and play .mp4 but cannot play music files

Getting old and forgetful! I can browse and play all the mp4 videos mounted on NFS from NAS on lan and visible in Videos subdirectory.
I can also see the Music subdirectory and drill down through genre, composer, disk but when I get to the directory with the flac audio files they are not shown, let alone being able to play any. What have I forgotten please?

The “Videos” section is for videos and configuring video sources. By default it only shows files using video extensions so FLAC files are not shown as that is not a format that supports video. You would need to go to the Music library section and use the files option to configure a path that would then allow you to browse or scrape audio only formats.

I am looking at Settings>Media>Library>Music but cannot see how to configure the path. Am I down the wrong tree?

There should be a “add music” option under that unless you had disabled Settings>Media>General>Show “add source” buttons> which would hide the option.

I had all except hidden files and directories enabled.

When I started this thread I had been drilling down from Videos>Files>Multimedia>Music>Genre>… which is my NFS mount but not unreasonably it wouldn’t play anything. My bad.

Going down the Music>Sources>Multimedia takes me to *All artists and then a list of many thousands which if I drill down I assume will play a track. Not what I need.

Going down Music>Files>Multimedia>Music>Liturgical (for example)>Bertali, Antonio etc.>Bertali - La Maddelena>01 - Version_de_Mantoue, …etc.flac does not play.
Other .flac tracks in similar tree do play.

Couldn’t work it out until I looked at the permissions in the NAS. A bit of a muddle I fear, possibly because the collection has been built up over years. I have tracks which play with permissions 755 and those that do not with permissions 600. More work from me required I think.

Thanks for the reply. I did say I had forgotten everything!

I was confident I had identified the problem yesterday but today when I go down the tree
Music>Files>Multimedia>Music>I get nothing beyond here. ie. no genre or indeed anything else and now I cannot even get back to playing my videos.
My NFS connection appears OK but now I am completely stuck.

Logs please so we can see how you have configured your system.

Hi and thanks for the reply. I have restarted, enabled debug logging and tried to browse to my music collection on the NFS NAS site.

I have then uploaded the log but not familiar with the process. I know that the log will be in my system but how do I get it to you please?

When you upload the log you will be presented with a URL, share that here.

Here it is:-

I see that you have set both a video and music source to the same nfs:// path instead of nfs:// and nfs:// as they had previously been set. I don’t know if this is the cause of the problem but I do know that Kodi very much does not like multiple sources of different media types using the same path.

I also see that you made a system mount. Is that working and does that allow you to browse and play your files from it?

Hi and many thanks. Part of my problem is that I have been working on the Vero only using the remote control. The last change I made was in response to my attempt to correct a problem which unfortunately has made it worse.

If you could please guide me through undoing and re-setting my sources correctly it would be much appreciated.

I confess I do not know how the system mount fits in here but my objective is to have the Vero work as a “dumb” player. All the work is built into the curation of my music collection and tagging. I do not want the “intelligent” activity of scraping and other media manipulation by the Vero.

If I just drill down through the files I used to be able to get to the track I wanted and it would play. My problem was that some flac files played correctly, a few did not. I believed, perhaps wrongly, this was due to a permissions problem on the NAS.

If you tell me I can ssh into the Vero and edit the paths etc. or work with remote. Whichever you suggest.

Thanks again for your reply.

OK, I connected to Vero and see the various mounts which must be in conflict and have removed the unwanted connections leaving nfs:// which has the three intended subdirs; Music, Photos and Videos.

My problem is that drilling down past Multimedia the connection is refused with permission denied.
I have set read only permissions for OMSC in the NAS but this is where my knowledge fails.

osmc@osmc:/mnt/$ ls -l
total 40
drwxrwx---+  50 1002 users  4096 Sep 15 18:28 Music
drwxrwx---+ 245 1002 users 12288 Nov 23  2020 Photos
drwxrwx---+ 241 1002 users 12288 Feb  7  2022 Videos

I have users and groups conflated with what I have on my NAS which is an account for OMSC.
How can I sort this out please?

What NAS system is it?

My media files are on a Qnap TS 559 Pro II. Rather old now but only doing light duty.

Just tried to understand the manual of this NAS (German version). It looks like there is no NFS squash concept here which allows to map all remote users to a specific QNAP user. Normally without squashing, NFS bases on user ids means if you use user osmc with id 1000 on the osmc device and have a user with id 1000 on the NFS server side, the remote osmc user is allowed do anything which is allowed for the user with id 1000 on the server.

Your permissions you showed are drwxrwx---+ ... 1002 users means the file/folder is owned by the QNAP user with user id 1002 which belongs to the user group users(typically group id 100) and permissions read+write+execute are allowed for this QNAP owner and all QNAP users in this users group.
Obviously the osmc user with id 1000 does not belong to this group … so no access and this causes the errors NFS3ERR_ACCES(-13) in the logs.

Since I’m not owning a QNAP NAS. I cannot give a advice what to do on the device, so the osmc user with id 1000 belongs to the QNAP user group users or how the osmc user is also created on the QNAP with id 1000.

To set a squash value like map all users to system admin user on the NAS would make it quite easy.
I see that some kind of NFS-Host Access is mentioned in the QNAP manual but there is no image explaining this in depths nor mentions the term squash.

Kodi has a complex looking QNAP section in their wiki how to setup NFS for the Kodi mediacenter:

1 Like

Hi Jim,
You have it. My problem is that all the Qnap system runs on Linux it is directed to Windows users so they make much of settings for different users but all using names and passwords not UUIDs.
There are settings for the NFS share and perhaps I should change these.
I had the Squash Option as ROOT_SQUASH. I can change this to NO_ROOT_SQUASH but I am not sure this will help because it is the client that is looking for the share.
I shall try the change and see if it helps with permissions.

I think I have it. By removing “Advanced Permissions” in Qnap it now behaves as a normal nfs share.
As in:-

osmc@osmc:/mnt/$ ls -l
total 40
drwxrwxrwx  50 1002 users  4096 Sep 15 18:28 Music
drwxrwxrwx 245 1002 users 12288 Nov 23  2020 Photos
drwxrwxrwx 241 1002 users 12288 Feb  7  2022 Videos

I am not sure if this will do what I want but will try and get back to you tomorrow.
Many thanks for the help.

1 Like

I am now very confused. I have done what I think is necessary, (although not secure because NAS is only NFSv3,) but somehow I have my target directory mounted twice as in:-

osmc@osmc:/mnt$ ls  alastair  Multimedia

If I cd to the ip address I get:-

osmc@osmc:/mnt$ cd
osmc@osmc:/mnt/$ ls

And further in:-

osmc@osmc:/mnt/$ cd Multimedia/
osmc@osmc:/mnt/$ ls
Music  Photos  Videos

And I should have opened one of these but forgot but they all open as do the other mount directory below.

But I also have:-

osmc@osmc:/mnt$ ls  alastair  Multimedia
osmc@osmc:/mnt$ cd Multimedia/
osmc@osmc:/mnt/Multimedia$ ls
Music  Photos  Videos
osmc@osmc:/mnt/Multimedia$ cd Music/
osmc@osmc:/mnt/Multimedia/Music$ ls 
 Ambient         Choral       Folk                            Iris_Dylan_2.m3u8             'New Age'    'Progressive Rock'   Soul
 Ballad          Christmas    Gregorian_Chant                 Iris_Early_1.m3u               Oldies      'Punk Rock'          Soundtrack
 Baroque         Classical   'Hard Rock'                      Iris_Hildegard_1.m3u8          Opera        Radio_Programme     Speech
 Bluegrass       Country      House                           Iris_Mitchell_2.m3u8           Oratorio    'R&B'                Techno
 Blues           Disco        Iris_Adams_2.m3u8               Iris_Moore_2.m3u8              Orchestral   Recital             YT_music_downloads
 Canto-Pop       Early        Iris_All_2.m3u8                'Iris_The Joshua Tree_2.m3u8'   Organ        Reggae
 Celtic          Electronic   Iris_Classical_Playlist_1.m3u   Iris_Various_2.m3u8            Piano        Rock
 Chamber_Music   Ethnic       Iris_Cohen_2.m3u8               Jazz                           Pop         'Rock & Roll'
 Chanson         Eurodance    Iris_Diamond_2.m3u8             Liturgical                     Pop_Folk     Russian_Orthodox

My problem is that I do not need both mounts.
I cannot browse to any from the Vero.
I only know how I mounted the IP address mount, I have no idea how the other mount was installed.

Here is my present /etc/fstab:-

 rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)
#/dev/vero-nand/root  /    ext4      defaults,noatime    0   0
# UUID=64A5-F009 /mnt/alastair exfat rw,users,uid=1000,dmask=000,fmask=000,nofail 0 0 /mnt/Multimedia   nfs   noauto,x-systemd.automount  0  0

Please advise/help me!!!

One via fstab and one via autofs?