Niveus remote


I have been using OSMC on my Raspberry Pi 3 for some weeks and are very happy with it, and everything works fine.

But I found this old Niveus RF remote which I got about 10-15 years ago. I used it on Windows XP, where it works fine.

I have tried to see if it’s possible to use this with OSMC, but no luck so far.

When I connect the reciever to the USB port on the Raspberry Pi and run the ir-keytable command I get this:

Found /sys/class/rc/rc0/ (/dev/input/event2) with:
Driver ati_remote, table rc-ati-x10
Supported protocols: other 
Enabled protocols: 
Name: X10 Wireless Technology Inc USB 
bus: 3, vendor/product: 0bc7:0005, version: 0x0100
Repeat delay = 500 ms, repeat period = 125 ms

And when I check /proc/bus/input/devices I get this:

I: Bus=0003 Vendor=0bc7 Product=0005 Version=0100
N: Name="X10 Wireless Technology Inc USB Receiver"
P: Phys=usb-3f980000.usb-1.2/input0
S: Sysfs=/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.0/rc/rc0/input3
U: Uniq=
H: Handlers=kbd event2 
B: EV=100013
B: KEY=108c0020 2800043 0 0 0 0 18000 101c0 10402804 9e1ec0 0 14003 40040ffc
B: MSC=10

I: Bus=0003 Vendor=0bc7 Product=0005 Version=0100
N: Name="X10 Wireless Technology Inc USB Receiver mouse"
P: Phys=usb-3f980000.usb-1.2/input1
S: Sysfs=/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.0/input/input4
U: Uniq=
H: Handlers=mouse1 event3 
B: EV=7
B: KEY=1b0000 0 0 0 0 0 0 0 0
B: REL=3

Since the ir-keytable refer to ati remote, I tried to select the ATI driver from MyOSMC and then reboot. But it doesn’t work.

I came across this post:

And tried to install the hid_mapper tool and tried to run it, entering the manufacturer and product id I got from /proc/bus/input/devices but it doesn’t seem to recognize any key when I push buttons on the remote.

I have also confirmed that the remote is still working, as I still have Windows XP on one of the computers I used the remote on earlier. And the remote works fine when connected to this computer. But on Windows XP it’s necessary to install the software which was included on a CD together with the remote.

Anyone know if it’s possible to get this remote to work on OSMC?